Return to Level1Techs.com

Windows Games on Steam for Linux. [Proton client Testing grounds]

steam-play

#1

WELCOME TO THE UNOFFICIAL WINDOWS GAMES ON LINUX TESTING THREAD :wave:

There are now many new games to test on Linux. Thanks Valve and everyone involved in making this happen :+1:

In order for it to work you need to opt into the beta channel on your Linux Steam client. In: settings - > account. Then goto the Steam play tab in the same menu and enable the above. Experiment with the second option if you want.

See also the Beta option in the beta client [insert yo dawg meme] this allows for you to test up coming functionality not available in the stable branch

Post your experiences and if you feel okay doing so, your hardware Specs / Distro.

begun

Pro-tip: Make a ‘Proton’ or similar category in your games list ( right click on a game and ’ set categories ’ )
That way you remember what games you have been testing.

Note: updates may have caused some of the Proton games to stop working
You can delete the appid folder from steamapps/compatdata and it should reset the proton portion of a game.
This will include any user made tweaks. (do this at your own risk ofc).

Finding the appid of a game is as easy as going to the store page and looking looking at the URL presented on the top of the client.
There is also the https://steamdb.info/apps/ search function.
Thanks @Dje4321 for the headsup.


L1T WIP Working Games List, results many vary. <<<

DOOM (2016) :white_check_mark:
rouge galaxy :white_check_mark:
Payday: The Heist :white_check_mark:
Skyrim SE :white_check_mark:
Wolfenstein: The New Order :white_check_mark:
Bejeweled 3 :white_check_mark:
Peggle :white_check_mark:
Trials 2 second edition :white_check_mark:
Unreal Gold Edition :white_check_mark:
Skyrim (none SE) :white_check_mark:
Heat Signature :white_check_mark:
Titan Souls :white_check_mark:
RUSSIA BATTLEGROUNDS :white_check_mark:
Ratz Instagib 2.0 :white_check_mark:
DARK SOULS III :white_check_mark:
Lego Star Wars III :white_check_mark:
Witcher 3 :white_check_mark:
Jamestown :white_check_mark:
Scribblenauts Unlimited :white_check_mark:
Pac-Man Championship Edition :white_check_mark:
Pac-Man Championship Edition 2 :white_check_mark:
Sonic & All Stars Racing Transformed :white_check_mark:
Dark Souls: Prepare to Die Edition :white_check_mark:
BioShock :white_check_mark:
RAGE :white_check_mark:
Fallout: New Vegas :white_check_mark:
Mortal Kombat 9: Komplete Edition :white_check_mark:
Sonic Mania :white_check_mark:
Supreme Commander 2 :white_check_mark:
Ultra Street fighter IV :white_check_mark:
Crysis 2 “Maximum Edition” :white_check_mark:
Steins Gate “Maximum Edition” :white_check_mark:
Metal gear soild 5 :white_check_mark:
rebel galaxy :white_check_mark:
Star wars-Shadows of the empire :white_check_mark:
Danger zone :white_check_mark:
The Ultimate DOOM :white_check_mark:
Doom II: Hell on Earth :white_check_mark:
Doom 2016 (Vulkan) :white_check_mark:
Quake (Software) :white_check_mark:
Bioshock 2 (original) :white_check_mark:
Bioshock 1 (original) :white_check_mark:
Bioshoc2 (remaster) :white_check_mark:
Altitude0: Lower & Faster :white_check_mark:
Assassin’s Creed :white_check_mark:
The Banner Saga 2 :white_check_mark:
Alien Versus Predator Classic 2000 :white_check_mark:
Geometry Wars: Retro Evolved :white_check_mark:
FINAL FANTASY XII: THE ZODIAC AGE :white_check_mark:
MONSTER HUNTER: WORLD :white_check_mark:
Shadow Warrior 2 :white_check_mark:
DARK SOULS III :white_check_mark:
Ori and the Blind Forest :white_check_mark:
Grim Dawn :white_check_mark:
RAGE :white_check_mark:
Sniper Elite 4 (and NZA games) :white_check_mark:
ELEX :white_check_mark:
Mirrors edge :white_check_mark:
STALKER: SoC (no Mods) :white_check_mark:
Grim Dawn :white_check_mark:
Red Faction Geurilla Re-Mars-tered :white_check_mark:
Fallout 4 :white_check_mark:
Dishonored :white_check_mark:
Death Rally :white_check_mark:
Dark Souls III :white_check_mark:
Cyberdimension Neptunia 4 Godess Online ( wat?) :white_check_mark:
10 Second Ninja :white_check_mark:
Alan Wake :white_check_mark:
Another Perspective :white_check_mark:
Antihero :white_check_mark:
ASTRONEER :white_check_mark:
The Witcher 3: Wild Hunt :white_check_mark:
No Man’s Sky :white_check_mark:
Shantae: Risky’s Revenge :white_check_mark:
The King of Fighters XIII: Steam Edition :white_check_mark:
Ikaruga :white_check_mark:
Spore :white_check_mark:
witcher :white_check_mark:
Max Payne :white_check_mark:
Deus Ex :white_check_mark:
Divinity :white_check_mark:
Beyond Divinity :white_check_mark:
Divinity II Developer’s Cut :white_check_mark:
Divinity Original Sin Classic :white_check_mark:
dark souls 2 :white_check_mark:
dark souls 3 :white_check_mark:
rain world :white_check_mark:
quake 3 :white_check_mark:
age of empires 2 hd :white_check_mark:
Double Dragon Neon :white_check_mark:
Puzzle Quest :white_check_mark:
Mortal Kombat X :white_check_mark:
Nosferatu :white_check_mark:
Grand Ages Rome :white_check_mark:
Dragon Age Origins :white_check_mark:
Vampire Bloodlines :white_check_mark:
Borderlands :white_check_mark:
Trackmania 2 :white_check_mark:
Hellblade: Senua’s Sacrifice :white_check_mark:
Call of Juarez:Gunslinger :white_check_mark:
Fallout Shelter :white_check_mark:

fp

For a full compatibility list check here: https://spcr.netlify.com/
Now called: https://www.protondb.com


Steam Play Games Compatibility List
Any Steam Play Experiences so far?
Steam Play: Windows Games on Linux (Proton Discussion)
Its been three days since I finally stop back and forwarding windows and linux
How To Play Crash Bandicoot N. Sane Trilogy on Ubuntu 18.04 using DXVK
New(ish) to Linux and am requiring some help/advice
#2

Games I’ve tested so far:

Games that Work:

  • Payday: The Heist
  • Skyrim SE
  • Wolfenstein: The New Order

Games not working:

  • Sniper Elite 3
  • Batman Arkham Asylum GOTY

Games tested without second option.


#3

Some older Games I’ve tested so far both options:

  • Bejeweled 3

  • Peggle (ohh god the addiction is real)
    FYI turn Off 3D acceleration in the menu and it goes from 20fps to 60+ fps silky.

  • Trials 2 second edition

  • Unreal Gold Edition (unbelievably smooth)

No performance issues or glitches so far.

fyi i have a slow connection so going for older lower spec games. il let others with faster connections do the heavy lifting


#4

Have been testing this and I’ve only tried a couple of games.

Games that run:

  • Skyrim (none SE)
  • Heat Signature
  • Titan Souls
  • RUSSIA BATTLEGROUNDS
  • Ratz Instagib 2.0
  • DARK SOULS III
  • Dragon’s Dogma: Dark Arisen (runs but keyboard controls are stuck)
  • Red Faction Guerrilla Re-Mars-tered (runs but keyboard and mouse doesn’t work in game except for the menu)

for Skyrim performance isn’t great and have screen tearing on some of the games I’ve tested.

Game that don’t run:

  • Just Cause 3
  • No Mans Sky (runs but has a blank screen)
  • Elite Dangerous

Will update when I’ve done more testing and tried more games.

I am running this Fedora 28 with a custom 4.17.14 kernel on a R7 1700 and GTX 970 using the 396.45 Nvidia Drivers.


#5

I will test this later when I have the time.


#6

Games which work on my system:
Lego Star Wars III
Witcher 3 (bad performance)
Games which dont:
Fallout 4 (only blackscreen after the launcher)

Running Arch, newest nvidia drivers with a gtx 1060 and an i5 6600k @ 4.6 ghz.


#7

Installed three games and struck out. It will open a box saying what the game is and will instantly crash. Running Elementary Loki. Will try Ubuntu 18.04.

Caesar 3
Pharaoh Cleopatra
Mount and Blade

Update: Installed Ubuntu and got the same result. I’m not going to worry that much. It’s a day one beta release. I’ll keep an eye on it.


#8

for a week


#9

Games I’ve tested so far:

Games runing:
Jamestown
Scribblenauts Unlimited

Games not runing:
Batman Arkham City GOTY
Batman Arkham Asylum GOTY
F.E.A.R. 3


#10

Anyone else having trouble getting Civ4 to run with it? Interesting considering civ4 is gold support (or whatever) for regular wine.

It’s my fav civ game, and I prefer it over 5 and 6


#11

I put it in my download queue and I’ll check it in the morning. What exactly does it do?


#12

I wish I could test FFXIV (it already looks okay-ish with DXVK) but the download size is humongous.

Did anyone tested with a DualShock4? Does it works like it should or it is presented as a x360 controller?


#13

Keep in mind, that you have to enable the beta first. You can do that by going to Steam --> Account and enable Beta participation.

Also, for those with separate windows partitions with Steam installed on it, I suggest adding the directory to your Steam Library Folders in the Downloads section.

It’s neat seeing my library of 190 games all appear in Steam. I’m sure a lot of them will not play. But it will be interesting to see which ones do.


#14

My first game is:

Pac-Man Championship Edition

OK, after playing one 10 minute round, the game works flawlessly. The audio works, the game runs at 60fps (it is Pac-Man) and my game controllers work.

The only issue I had is that my linux mint distr o decided to go into sleep mode after 10 minutes because it thought my PC was inactive.

This is the first game I wanted to try, because I could not get it to work properly in Wine. But this works… surprisingly well.

Game 2:

Pac-Man Championship Edition 2

This one works just as well as the first game. Actually it did crash on me once while I was playing through the first tutorial maze. But interestingly enough it never happened again. As I played through the tutorials and first challenge map.

Game 3:

Sonic & All Stars Racing Transformed

This one gets another pass. I am not running the greatest of hardware here, and I do need to upgrade my PC. But on Windows I can get this title to run at a solid 60fps at 1440p. Not so much here. The game does run at a pretty solid 60fps at 1080p, though. Not too bad.

Game 4:

Dark Souls: Prepare to Die Edition

I do not have the Remastered Edition. This is the original. But it does work well enough under Steam. There are a few hic-ups, but nothing bad.

Game 5:

BioShock

This is the original, though I have the remastered too. So far it works, but there seem to be a few minor issues. The game crashed on the first loading screen. But restarting the game over, it did not crash. Managed to play through the introductory stage and a bit of rapture at 1080p and it maintains a pretty good 60fps.

Game 6:

Wolfenstein: The New Order

OK. I’m really impressed with this one. I went through the introductory level, and into the first proper level and the performance is fantastic. The New Order runs on OpenGL, so I have to wonder if the Vulkan to OpenGL wrapper is really well optimized. I think this actually runs better on Mint 19 with a compatibility layer than it does on my Windows partition.

Game 7:

RAGE

No surprise here that the game would run flawlessly. It is an older game than Wolfenstein: The New Order, but it works great. That’s ID Software for you.

Game 8:

Fallout: New Vegas

Yeah, 8 year old title from 2010. But always good to check older classics like this one. Generally, it runs really well. There are a few odd visual artifacts, but I’m not sure if that is just New Vegas being New Vegas or the compatibility layer.

Game 9:

Mortal Kombat 9: Komplete Edition

Works. Though the framerate does like to hover a bit under 60fps on my computer. A few tweaks does fix that issue though. Not bad overall.

Game 10:

Sonic Mania

Figured I would give a 2D platformer a try, and Sonic Mania has worked flawlessly for me. This one is impressive because I could not get it to work on Wine.

Game 11:

Sonic CD

This is a port of one of the 16bit Sonic games that was ported by the main programmer of Sonic Mania. I figured that this one would work as well, but it crashes on me at launch.

That about does it for me for now. I honestly have to install more games later and try some of them out.


#15

That’s the problem, it’s doing nothing.

First off, 2 versions appear in steam for BTS - One is 200mb, another is 2.5gb.

One of them gives an error saying .app is missing, the other does nothing except spams other steam accounts with ‘Radio is now playing Civilization Iv Beyond the Sword’, but doesn’t do anything beyond that. It doesn’t launch.


#16

Some initial testing with a few games. I have a Ryzen 7 1700 with an RX 580 running Fedora 28 and the amdgpu open source driver.

Dishonored 1: Graphics are fine, but keyboard controls frequently become stuck or unresponsive. Xbox 360 controller seems to work better, but I suck with a gamepad. EDIT: Once I disabled Synergy the keyboard controls worked fine.

Final Fantasy X/X2 Remaster: Installer locked up (I suspect .NET was the issue.)

Metro 2033: Graphics are fine in DX9 mode, in DX11 mode the game won’t even start. Audio is a mess, though you can play with subtitles on.

It’s possible Synergy caused the DIshonored control problem, so I’ll have to try with it disabled again tomorrow.


#17

Games I’ve tested and are flawless:

Games I’ve tested and are flawed:

  • Mass Effect
    • Audio is broken, works in the loading screens, but not in menus, cutscenes or in-game.

Games that straight up don’t work:


I’ll be monitoring this thread and updating it as I test things.

@GeNerator, would you like to make a list of “working” “semi-working” and “broken” in your OP? I think it would be nice to keep that up to date. (I’d be happy to help you with the list maintenance if you’d like)

I’m starting on some “heavy lifting” for ya, I’ll be testing Project Cars, Far Cry 3, Empyrion Galactic Survival, Oblivion, Borderlands The Solus Project (playing solus on solus, kek) and a few others.

If anyone has any requests for games tested, this is my games list:


#18

AyyMD FX cpus have black textures and its completely normal feature, no idea hows Ryzen


#19

In Windows, it’s fine. I didn’t experience it in Linux, but I didn’t really test it that extensively because once I realized the audio wasn’t going to work, I decided to give the game a pass for the time being.


#20

Same deal, it’s also missing the ancient instruction set that game relies on. Easily patchable.