Return to

Ryzen instability [solved]



My Ryzen rig crashes at random, it behaves as if it overheated (fans go 100%, then it restarts 20 seconds later).

System specs:
Ryzen 7 1700X @ stock
2x 8GB Corsair Vengance LPX 3200MHz @ 2133 || 2400MHz
R9 Fury @ stock
Seasonic M12II 750W
ASRock X370 fatality gaming K4
Win7 64bit Homepremium
Build log

Failed Debugging steps taken:
- Tested different video card as the vga driver apologized for the crash (Radeon settings have been restored due to unexpected power failure)
- Tested different PSU (it was a power failure after all?)
- Set RAM clock to 2133MHz (DDR4 spec)
- Tested older BIOS version
- 12 hour CPU stress test using CPU-Z stress (No crash during the run)
- 12 hour GPU stress test using Furmark (No crash during the run)
- 3 hour RAM error test (no crash)
- 6 hour combined CPU/GPU stress test (no crash)
- updated/reinstalled drivers for everything

Currently testing:
- High performance Windows powerplan

System bahaviour:
CPU idles arround 33°C (@ 20°C room temp) with temperatures fluctuating into low 40s
GPU idles at 38°C
During load, CPU reaches 55°C and GPU caps out at 65°C

Software that causes the most crashes:
- Heroes of the Storm
- Sony Vegas 13

I am a bit lost as to what to do now. Halp!


Sounds like a memory issue.

If you want to confirm, run memtest for about 24 hours.

Once you want to fix it, raise the SoC voltage to 1.15 (up to 1.2 is safe) and memory voltage to 1.35. (up to 1.5v is safe).

Then run Heroes of Storm and any other games to see if they crash. Metro Last Light works...erm crashes great for me when stability testing.

Then to confirm, run memtest for about 24 hours again.

A faster alternative to memtest is this program called "LinX" that has not worked for me but was recommended by an AMD spokesperson.

edit: LinX spelling correction


LINX yeah its actually pretty good. I have used it. I like it since its based on linpack

as for instability on stock systems.. ALWAYS test memory first. Its almost always memory


This is a case of crazy off ram timings. Not something you can fix with more voltage. A lot of boards have this issue especially since the Agesa 1006 update where you will encounter random machine check exceptions leading to an immediate reboot.

Updated RTC 1.01

EDIT: RTC Removed. It will eat your PC and your Kids.

You’ll get something like this:



Did you manually set your timings to match mine? :laughing:
They look identical.
Or is that simply how yours where?


Thats what Taichi & Flare X does, as if I'd know what to poke


Saw this last week, I'd probably try dialing towards these and see if it works :smiley:

I would also imagine 99.99% people here not really knowing what the fuck should you do with ram, so.. compare notes and poke till it works?


@Peanut253 I doubt 24 hours are yielding me different results than 3 hours, but I´ll try anyway.


Exactly that!


Almost all of those settings are WAAAAYYY too high for 2133Mhz.

The tFAW in particular.

Can you give me the exact model number of your RAM?
So I can look up the JEDEC+XMP data for the SPD table. (I have a pretty large database of RAM)

I'm guessing it's something like:

I'm going to talk you through getting that RAM setup stable :smiley:



The clock is set to 2133 as anything higher will run unstable.


Your RAM timings table good sir :smiley:

Dial those In on your board and see how it chooches.


XMP Specifics:

Only use those values with the T behind them, these are the Ratios your board uses.

The other values are the actual parameters and time in ns.

TRCD is used twice once for the TRCDWR and TRCDRD.
Pay particular attention to tFAW and tRFC

In addition to that you want to set GearDownMode Disabled and set ProcODT to 60ohms.
Stock for Ryzen ProcODT is 53.3Ohms however 60Ohms helps a lot with getting an overclock stable.


And If you are interested.

Here's the timings for your RAM:

You can manually dial those in from the XMP profile:

G.Skill ram btw is just amazing stuff. Just look at the XMP timings vs the JEDEC timings.


XMP Table


I have never touched RAM settings apart from clock.
Just for reference (not my system) this is how my UEFI for OC looks like:

Settings I dialed in now:


I think I've got the same board.

ASRock X370 Gaming K4 (Yup)


Weirdest thing so far is Stock+XMP suddenly crashing RAM after toggling things like nope that one did not work, back to bios and toggle it back, aaaand now RAM just refuses to work like after Taichi has tried its best it has decides to set it default.

Then did reset default settings for bios and Stock+XMP was again just fine.

I'm confident that I did not toggle extra things by myself, like either
1. Something toggles another setting but doesnt dial it back the same way
2. Bug

Anyways, nice that RAM disables that XMP profile / goes default if its not working.


Currently the ASRock Boards actually have a Bug whereby they sometimes set wholly unrealistic Timings for some RAM.

Hopefully it gets resolved with the next update.


And some OC Tips:


Dialed in settings (updated reply).


Ok. I'll start listing the parameters to change and update this post accordingly.

Ok so first thing:

Lets set your RAM to 2933Mhz. I know that's something your board should support. Currently I still see it sitting at 2133Mhz.

Then set the CPU Load Line Calibration to Level 3 (much better than Level5)

Also set the VDDCR_SOC Load Line Calibration to Level 1 and
Set the VDDCR_SOC Voltage to the lowest offset 0.00625 or some such value. You can also try going one offset higher to help stability of the memory controller.

Next set the Fail Count to 1 (No point retrying several POSTS if the first fails before reverting to default settings

Set the following values as follows:

tCL: 16
tRCDRD: 18
tRCDRW: 18
tRP: 18
tRAS: 36
tRC: 54
tFAW: 36
tCKE: 6 or 7
ProcODT: 60Ohm

If this works you can try and go for 3200Mhz, But I'm not sure if E-Die will go that high right now on this board.


You also want to go to the advanced DRAM menu under the AMD CBS options and Disable Gear Down Mode.

As for the tRFC, tRFC2 & tRFC4 you may try yo go higher if the current options don't work
tRFC1: 525 tRFC2: 389 tRFC4: 239

or maybe even
just for the heck of it and see if that improves stability for this RAM chip.