Return to Level1Techs.com

Ryzen instability [solved]

amd
ryzen

#21

Put all of these settings in (except for 3200MHz, do not feel brave enough).
It works! You are a freaking magician!

Now to see if random crash happens. Big thank you so far!


#22

Is this now at 2933Mhz?


#23

It is. Never thought this would work o_0


#24

Have a check again with RTC just to verify and then run a memory test as you did before.


#25


#26

You might still want to disable Gear Down mode in the advanced settings.
That option is currently a bastard when it comes to odd behaviour. Which is funny since it's designed to improve ram stability (Signal Integrity).

Gear Down effectively halfs the frequency (1/4 of MT) of command and address lines, while maintaining the frequency (1/2 of MT) of data (DQ) lines.

So at 3200 MT the command and adress lines would run at 800 MHz, while the data lines run at 1600 MHz.
This is different from using 2T command-rate, because the latter still runs the lines at high frequency, which in turn may be less stable compared to 1T at lower frequency.


#27

This is way over my head.


#28

:stuck_out_tongue:
Just posting for others in general.


#29

Dear Catsay, could you please help me to configure my bios? i´m trying to figure what is causing my pc to have input lag, or visual lag while playing, wish you can help me please, i´m yuriy from Venezuela my english is not that good

i have already posted in AMD for help but just one person is trying to helping, but i realized that you know too about memories and tweaks help plz, im attaching here the taipon specs of my memory ram+ ryzen timing checkers, and the whole post that i start in AMD forums, in case you can check more details
https://community.amd.com/thread/217179


#30

This is a very interesting problem.

I'm not yet sure exactly what's causing it, however there can be a few options:
0. There are a lot of system interrupts of some sort that slow your input.
1. Your graphics card is not working correctly.
2. There are powersupply problems, that's causing your GPU to microthrottle or drop frames. -But I think your powersupply is doing something strange:

  • The +12V voltage is 2Volts higher than it should be:
    • +13.05V is within specification as an acceptable maximum for the 12V rail during normal operation (ATX standard).
    • But your system reports a +12V of 13.984V (Which is VERY high)

Your GPU sensors however reports a input voltage of 12.109V, which is good.

Now is where it get's interesting.

Open your system processes tab in task manager and look for the System Interrupts process:

This can be indicative of bad powersupply or failing hard drive.
I read that you are using an M240 SSD which is probably working fine, however If you have some other older mechanical disks plugged in thay may be to blame.

Use something like Crystal Disk Info to see if your disks are all healthy
https://crystalmark.info/software/CrystalDiskInfo/index-e.html

Lastly we are going to test the powersupply stability under load.

Get the Prime95 program, this is to stress the CPU so the system also puts more strain on the PSU so we can see if it is behaving correctly.
https://www.mersenne.org/download/

Lastly you need the All Purpose multi-tool for sensors check, HWInfo
https://www.fosshub.com/HWiNFO.html

Run HWInfo and log the sensors data to a CSV file using the Small '+' button in the bottom right.
Then run Prime95 to stress the CPU and Powersupply.
Afer about 20Minutes (or sooner if temperature gets very high) stop Prime95 and stop logging with HWinfo.

There are a few things that should happen when you test this:
1. The CPU frequency should peak to maximum on all cores
2. The CPU voltage should increase to the maximum
3. The Temperature of the CPU should rise a lot
4. The Powerdraw (Watts) of the CPU should increase to over 100W if your CPU is overclocked.
5. The Powersupply voltage 5V and 12V should drop to a lower voltage.
6. The system should not crash in approximately ~20minutes of running Prime95 :wink:
7. The CPU shouldn't get over ~90C and should be around ~75C at maximum.
8. The VRM temperature should maximum reach ~75C

Do those tests and post here again with the screenshots and the CSV file of the sensors information you logged in HWInfo.

If those tests all went well and the voltage didn't drop too much on the PSU, then we can be reasonably sure that your CPU, Mainboard & RAM are all good.

If the hard disk is healthy then we can also be sure that that is not causing the lag problem.

You said you had the Lag in the BIOS as well? That means that this is not an Operating System(Windows) problem.
Then the problem can only be the graphics card, mouse or keyboard.

What graphics card are you using now? GTX580 or GTX1060?


#31

Thanks so much for reply my comment cat, i'm so happy
And yeah i have lag in bios as well, i will be recording with phone later to show the mouse cursor lag
Before attaching pictures and things, i wanted to say that i was Gifted with a EVGA GTX 1060 6GB by a friend, so that AIDA-EXTREME 64 picture up there that i posted in the amd forum is from the old gtx 580, but even with this new EVGA, the problem persist

Now some observations, i did upload my wholebios settings configuration biosallpictures, but i followed Rebell user in AMD aka (jane) and she told me to set my dram volts from 1.35 to 1.4 i did, also i did set or up the cpu volt from 1.3 to 1.35, i had to put all PSTATES AUTO, to achieve volts 1.35, then after it configured it self i ended up putting it disable like a friend recommended. Now i will attach here the before and right photos, also by following Jane advice, i turned off the SMT, and security device like she recommended me.

Also yesterday i tried to changed by myself the TFAW and RC because when using xmp profile 2.1 it goes to 3200 but, if i remember Wardog from Asrock, recommended me also to set my ram mhz to 3066 and timings 16-17-17-36 (but he wasnt sure at all) A funny thing that i discovered is that Xmp profile seems to not config the TFAW or RC, by default it set the TFAW to 24 and RC 40, so for that reason. Then when running read test in thaipon burner i notice that TFAW+RC are set to tfaw 36 and RC 64 for 1600 mhz, for that reason i don't if this is okay or not, but by using 1533 in each ran, i set the tfaw and rc 36&64, and now the ryzen timming is different, from the picture that i post here yesterday, above.

Lemme made this first comment with the Bios things, and i will made another comment down below with the prime test, and aida ok, thanks for you time

My english is terrible :frowning: , PD: if you want i can send you the mediafire link with all bios settings, but in that compressed rar setting, i didn't updated the tips that rebell/jane gave me about security device off, dram 1.4v, cpu 1.35 or smt off, thats why im posting here

What a problem i need to made another post with the rest of 2 pictures it only allowing me to post here 2 pictures, sorry if put 3 comments in a row okay, brb


#32

Here attaching the last 2 pictures, the last bios picture and the the ryzen timmer

PD: all above picture and ryzen timmers, is that what im using now, and the same config for prime95
Observation, this is weird if you see i put Trc 64, but in the ryzen timing checker it appears like 100, instead of 64


#33

Okay now i will be posting here the CSV file, and i want to put here a picture of AIDA-64 extreme that i take today before the prime95 test, among with the task manager interrupts system, plus the Crystal Disk i guess

but i don't know where to attach the CSV, so i had to upload to mediafire, the file name is TestBlend95prime, i did the blend test, but i can make others test, if you want

TestBlendprime95

Now here is the aida+task manager (interrupts) and yeah i was also impressed by the 13.3 volts in 12 o.O didn't notice
This is a aida and task manager, without stressing or running any software.



#34

Sorry for slow responses. I'm a very busy person during the work week.

I had a look at the CSV data to see what I can figure out.

To me it looks your PC & PSU is in perfect health still. The voltages are perfectly stable even under heavy load.

Only thing I found strange is that the VRM temperature is always 23C.
It should be getting a lot warmer.

Your WDC 160Gb drive should also still be fine, it only has a few Write and Read Errors.
The Crucial SSD is also perfectly healthy.

As for all the CPU, RAM and other Voltage tweaks others have told you to do, those are completely unnecessary.
I don't think they know what they are doing really :grinning:

You can set your RAM voltage back to normal 1.35V. 1.4V is really excessive for your RAM and will only cause it to get hot.

In thaiphoon burner, open up the the RAM again, then from the Tools menu select "XMP Enhancer" and post a screenshot of the window that shows up.

The important values we will need:

  • tRFC1
  • tRFC2
  • tRFC4

So first thing, let's reset your BIOS to default settings and adjust from there so we can get things stable first and later overclock.

On your CPU you can re-enable SMT. SMT has nothing to do with the problem you are experiencing.
You can also re-enable fTPM and SVM if you want.

One important option you need to find in your BIOS is "Gear Down Mode" - this is in one of the Advanced Settings NBIO / RAM menus.
This option is hard to find, so go through every menu until you find it, and disable it.

For now, for stability lets set your RAM to 2933MHz (This is still plenty fast enough for now). Every ASRock board should be stable with 2933Mhz easily.

Then set your RAM timings to:

tCAS: 16
tRCD: 18
tRP: 18
tRAS: 36
tRC 64
tFAW: 36
tRRDS: 5 or 6
tRRDL: 8 or 9

(Read these from XMP Enhancer in thaiphoon burner)
TRFC1: 
tRFC2:
tRFC4:

These timings are a bit higher than they need to be, but they will be stable and work properly.

Now for the important part, do you have some really old PCI-e graphics card, something like GT220 or GT730.
Just anything that works without extra power so we can test to make sure if it also happens with such low performance GPU's.

Also If you have not yet done so, try and test with some other mouse and keyboard.
If you can find a old PS/2 port keyboard try that, your PC supports those and they can be much faster than USB keyboards.
The Green & Purple port on the bottom left:


#35

Maybe an easy question but did you clean install windows when you built it?


#36

It wouldn't be happening in the BIOS too if that was the case.


#37

Wow cat you are one in a miillion and don't worry if you are busy i can wait n.n, i'm so happy to be here (i know this compliment may sound kinda shy or uncomfortable maybe, but i don't know how to describe, but im so happy) :slight_smile:

And yeah, i will be follow your help, captain , lets put this black pearl in shape ^^ Captain cat, not jack xd

Okay now i will be then, putting all on default right? i guess you check my bios.zip with all pictures of what i have there configured, so now im go set everything on default and follow your advises, and see what happen.

This is the XMP profile enchancer

Now the PS/2 things, yes, i have a membrane keyboard very old, like Old spice xd, but this motherboard comes with ps2 connector 2 in one, i mean i can only connect A keyboard or a Mouse. I have tested in bios, the ps2 keyboard, and differente optical mouse or lacer in all usb ports, and problem persist, maybe now i need to test only a ps2 mouse? instead of ps2 keyboard right? I have too, tested this pc with, a 9600 XFX gpu in bios, not in windows just bios, and problem persist, also the GTX 580 gpu in windows and bios has the same problem, the funny thing is that, I remember when testing either the XFX 9600 or Gtx 580, their Display port 1/2 , when connecting DVI cable monitor into display port 1<-- i remember that, when booting to post bios, in display port 1, the pc takes 6.40 seconds to post bios, but when connecting the monitor cable to the display port number 2<-- of both cards (gtx 580 or xfx 9600) seems to be posting more fast to bios like in 5,20 seconds, but now thanks god, this EVGA gtx 1060, that is built only in one display port, does not comes with that problem , it will post to bios in 5.0 secs or even less i guess

Okay so i will be setting all to default in bios, and them re-enable SMT, FTPM, and disable the Gear Down Mode, also by setting up the ram to 2933 with your recommends timming.

Now my only question, do i need to test again with prime95 and Hw64 monitor both video cards? like separated first the GPU XFX 9600? then, take off and put the gtx 580 and test again with prime95 and hw64? or nope?

I only have 3 Video cards:

XFX 9600 nvidia
Gtx 580 EVGA Nvidia
GTX 1060 EVGA Nvidia.

And one mouse lacer g9 from 2008, one USB optical mouse m100, and logitech g15 keyboard (which has a problem, with the f4 keys by pressing itself like internal) i always disable with software that key, also i have to check device manager and disable human interface device, otherwhise it can be a problem in games, also this g15 press itself in bios, and when installing windows.

And yeah i have a membrane keyboard ps2 super old like 2004, and i have tested that keyboard and problem persist, but yeah if you want i can use that keyboard, wish i can have a mechanical keyboard with ps2 adapter, with some lights, but here in Venezuela everything is expensive, and you cant find anything good lol x.x

So, lemme know if you want to me, to test XFX 9600 by using the same drivers of gtx 1060? or by using old drivers on xfx? thanks Cat, sorry for writting alot.

Oh by the way yesterday i did too a LARGE FT in prime95, with the same settings that i did on Blend
And cpu up to 82, you can check here CSV 26 minutes running
Test with LARGE FT prime95


#38

Also sir Catsay, when you say put all default, you mean that i should wait for more instructions, i leave default everything and only applying your ram recomendations, and SMT, FTM, gear down disable right? and leaving cpu on default clock 3.2, volts default etc etc right? thanks, also should i disable ADvance memory training, while applying this settings, or leaving on?

This what i have done at moment: i set all to default, activate SMT+SVM+FTM, disable C6 and amd cool quiet, and i did something new, i didn't touch the XMP PROFILE it has auto and enable, so i didn't touch that, and went to advance DRAm timing and set overlock to manual, and configure there the timings and dram speed, i will ad a third comment down below, puting the last 2 pictures with Geardown and Powerdown


#39

I skim read at best so I probably missed that part!


#40

Now adding the last 2 pictures i disable Gear down mode and power down mode both disabled, and thats how the main tab looks after all that settings.