ASRock x370 taichi & ram

Well I spent a lot of time on this one, and still nothing. When I load XMP Settings to the first profile which is what my ram is supposed to operate at... ddr4 3200 14-14-14-34 .. but it shuts down and reboots into ddr4 2133 15-15-15-36 ...
I raised the dram voltage to 1.4 and to no avail.
Any one got a clue on how to get this ram running faster or am I waiting on a mobo update ?

Basically what you want to do is make your timings even higher.

So am I understanding this correctly?
I gotta take my ddr4-3200 14-14-14-34 ram
and run it at ddr4-3200- 15-15-15-36 ? or such ?

It sounds to me like he is talking about ddr4 2400 and trying to push it to ddr4 3200 by changing the latency proportionately.

In the video there Wendell explains how to do it. Not sure really what the exact thing was but it had the timing hitting like 18 or higher.

OK I manually set the ram to what auto did, and I get the same crash dance. I guess that answers that. Wait on a mobo update.

Sorry I couldn't be much more help.

I don't own a Ryzen plattform, but I'll ASK some questions to help other people help you:

Which RAM do you use?
How many modules have you thrown into which slots?

1 Like

That is the ram I got...
I got those two sticks on A2 B2

Quoting from the thread of the Taichi Review:

Might give that thread a full read, maybe then posting your problem there since the "official" threads tend do get a little more attention.

As I said, no Ryzen for me ATM, so can't do much more.

Your model number is not yet listed in the Memory QVL for the Taichi.

If you purchased this kit online you might be able to do an RMA with one of the two compatible 3200 kits listed. If you explain you ordered the wrong SKU to an agent on the phone, you may even be able to have the new kit cross-shipped.

1 Like


The kit will still work, but will need manual setting, XMP won't work on it. It's not a big deal from my point of view, but if you feel like it is for you, which is totally OK, you can actually expect that from RAM, just swap out the kit for a kit that is supported by the mobo.

I guess I just assumed that OP already tried plugging in the values manually, but I have read where sometimes that didn't work as there was still some conflict with the mainboard.

Yes i did set values manually... that failed as well.. even setting the manual values to what the auto reading does, gives a failure. I tried single stick .. both individually , same failure. Funny story, my part number on invoice is different then what I ordered & received. F4-3200-14D-16TZ R ... The only difference I can tell is the RGB... well it looks like I may have to call newegg, and see what they say.

If it's a different model than what you ordered you can get a free shipping label RMA----Hands Down!

Yeah the Ryzen platform is very picky on memory.
Do you have the newest bios updated?

Wait, the kit you said you got is not RGB memory... did they send you RGB memory? I'm confused...

Other than that maybe they messed up your order, given that Trident Z is available in so many different timings and speeds, not unlikely. Any Labeling directly on the modules so you can absolutely confirm the kit?

OP said they sent the wrong model number than what was on the invoice, so an RMA with free return label and a cross-shipment should be no problem for them.

LOL let me clarify ... I got the ram I ordered... however on the bill it says I ordered the rgb ram... which I did not... The order number leads me to the correct ram I ordered however the billing says otherwise.. even though i got what i ordered... my first link was wrong... apologies.

This is what i ordered and this is what i got

However the PART number on my bill has leads me to the RBG. which I did not order.

Although the actual ORDER number of the bill leads me to the one i have... Just a mistake on their behalf...
I updated the bios to 2.0 early this morning. Still no go... I tried single ram in A1 , A2/B2 configuration and even A1/A2 configuration. Nothing works at anything other then 2133 latency 15. I contacted Gskill via email and stated my problem to them... as I saw on another site some people had exact same ram and it ran perfect, and another had the same ram doing exactly what mine is... they contacted gskill and were told the ram is bad... so I wait for gskill to respond.

OT---Are you applying to AsRock for Rebate for the mainboard?
The process is a Chinese Puzzle designed to trip you up!

LMAO I actually jumped through some hoops to get a paper I gotta print off and fill out and send in... OMG definitely a zen riddle for the taichi rebate lol

Scratch that rebate deal....
Offer valid from Jan 27 to Mar 02, 2017
is the first thing on the email I got after filling out the