Return to Level1Techs.com

Windows Games on Steam for Linux. [Proton client Testing grounds]

steam-play

#585

To be fair AV1 is fairly new and not exactly widely supported, so IMO it’s fine they don’t support it (yet). Remains to be seen how adoption goes though. The official final release was March this year, that’s barely one development cycle for big software like this (if at all, not sure how their release cycles actually are).

More wondering why neither supports VP9 though.


#586

I’m wondering why VP9 isn’t in more game engines too. WebM is mature and VP9 itself is mature, but currently it’s really only web video that uses it.


#587

And even there it’s somewhat scarce outside of YouTube and memes. I don’t think any of the commercial content sites use VP9, do they? I never really bothered to check tbh.


#588

Netflix was considering it, and may be using it for Netflix 4K. Netflix may be the first to move to AV1 though, along with YouTube.


#589

Yeah that makes sense since they’re part of the Alliance


#590

Bf bc2 won’t work now after updating to fedora 29…will try clean install later…


#591

Just an update, I found a fix for “A Hat in Time” also applies to “Breathedge.”

You need to do winetricks xact and then add xaudio2_7 as a DLL override (Native) to winecfg

Apparently Wine’s stock xaudio2_7 implementation doesn’t work with modern audio engines well. A lot of games will need this fix down the line, as more of them rely on proper Xaudio calls.


#592

Okay, I’ve been noticing a regression in stability with wine-tkg-3.19 with Unity engine games as of recent. I’ve had to change those games over to Proton 3.16-4 and it’s actually more stable on 3.16-4 than on the latest wine-tkg build from Lutris.

Here’s 2 games where that is the case…

PC Building Simulator:

tkg-3.19: Turns into a zombie process
Proton 3.16-4: DX11/DXVK ends in “GetThreadContext failed”, OpenGL works fine

I am Bread:

tkg-3.19: Instant crash
Proton 3.16-4: with -force-d3d11, doesn’t crash.

Gonna wait for wine-tkg-nopulse-3.20 (or 3.21) before I draw any conclusions.


#593

tkg-nopulse-3.20 results:

PC Building Simulator: Still turns into a zombie process

I am Bread: Still broken. Crashes on startup.

Both games seem to be having massive issues now on tkg builds. I’m not sure if it’s because I tried to add libraries for Windows Media Foundation to my prefix. I may have to start over.

Edit: Nope. Fresh prefix does not resolve these 2 games. So non-vanilla Unity games that have additional libraries now have a very high likelihood of crashing on wine-staging or wine-tkg. In those cases, Proton 3.16 is by far more stable than actual Wine.

Edit 2: Now Subnautica stopped working too on wine-tkg-3.20 if you have a controller plugged in or are plugging in a controller.


#594

WARNING

Do not update to the Nvidia 415.18.02 drivers. It breaks ALL (and I seriously mean it, ALL) Unity games requesting transform feedback from DXVK with the dreaded “GetThreadContext failed” error. Applies to both Wine and Proton. This is a EXTREMELY COMMON bug with the 415.xx series drivers with no solution in sight.

Avoid until a new rebase with a higher version.


#595

Thought if might be good to mention something rather important I found out a while back. There is some kind of interaction between dxvk and tearfree that causes games to be a stuttery mess if they aren’t running at exactly 60fps. I have confirmed this with Monster Hunter World and The Witcher 3. I tried to test this with MGSV as well be it ran so smoothly I couldn’t get it to dip below 60 #firstworldproblems. And I know it’s to do with dxvk because it doesn’t happen with Doom or No Man’s Sky.
you can disable tear free on the fly with this command
xrandr --output <output> --set TearFree off
and you can just as easily turn it back on by replacing off with on in that command.


#596

Now that protonDB is out I only report there. Totally forgot this thread exists. Here are the lists of games I got to work:

  • Crysis
  • Dead Space
  • DOOM
  • DUSK
  • F.E.A.R.
  • Hellblade
  • Legend of Grimrock 2
  • Rage
  • Red Faction Guerrilla Re-Mars-tered
  • S.T.A.L.K.E.R. SOC
  • Spintires: MudRunner
  • Supreme Commander: FA
  • Thief

Games that do not work but want to fix them:

  • TimeShift
  • Lichdom: Battleage

#597

Id love to figure out what is making Rust so studder-y


#598

If you are using amd gpu, and you have tearfree enabled try the fix I posted. If you’re using Nvidia, try messing with composition pipeline options


#599

should be able to try tomorrow… maybe tonight


#600

how do i find what the OUTPUT options are?

image


#601

You’re using Wayland not X11. Wayland doesn’t use xrandr.


#602

I figured out the studder tho…

theres a double input bug in the version of unity they currently use.

The workaround is:

https://steamcommunity.com/app/252490/discussions/5/1735462352484709361/

image


#603

Looks like there still isn’t a solution to the 415.xx Nvidia driver issue. And likely is falling on deaf ears.

In cases like this, a link to an old driver is always appreciated, so here’s the still active link to 396.54.09:

https://developer.nvidia.com/linux-3965409


#604

Skyrim Special Edition ran for awhile I played 10+ hours .

Now it’s no launch black screen. Its crazy beta months in :slight_smile: