Return to Level1Techs.com

Windows Games on Steam for Linux. [Proton client Testing grounds]

steam-play

#505

Ok Thanks for the info, but HOW do I do that? I’ve tried typing in terminal " steam_runtime=1 steam" and it does nothing


#506

It’s case sensitive. It needs to be exactly like I posted.


#507

Again the default is running steam-runtime not native. If you run it native on Mint if will ask you to install 32-bit runtime libraries that are not included on Mint out of the box. The native refers to using the system libraries and not the ones coming packaged with steam.


#508

Hmm interesting. The error message I received when trying to run doom 2016 in Linux steam about " failed to read config.default or default.cfg" per some forums pointed to the fact that some claimed others were NOT running it steam-runtime but running it steam native ( native meaning either just install steam straight from Software Manager) or via downloading and installing steam within the Terminal. I suppose I should just purge and completely uninstall/remove steam in every context/way from my Mint installation and start again fresh. …

So how should I download and install Steam to ensure the steam-runtime is how it will run when I double click that item? I know of two or maybe three possible ways:. 1 Software Manager, 2. via terminal command(s). 3. possibly going to the steam store url.

I appreciate everyone’s time and info about this. :]


#509

When you run “steam” in a terminal, What does it say? Obviously yours won’t say Gentoo like mine.

Does it look like this?

Running Steam on gentoo 1.0.0.56 64-bit
STEAM_RUNTIME is enabled by the user

Or does it look like this?

Running Steam on gentoo 1.0.0.56 64-bit
STEAM_RUNTIME is disabled by the user

#510

So does this mean when I double left click on steam to run it just like I normally would in Windows 10 that it will auto run using the Steam runtime given the info on the screen shot?

Fresh install of Mint 19 cinnamon 64 bit with NO updates unless you count running STEAM_RUNTIME=1 steam in terminal for the first time after installing it via terminal with " apt install steam" and selecting y for yes to install it.

my rig :

4790 cpu
16GB of ram
rx580 8GB vram sapphire nitro + vid card
144hz ips 1440p monitor


#511

-_-. I am seriously frustrated to no end on trying to simply get doom 2016 running within steam in linux. Valve basically claims it just works with this new proton bullcrap, but it DOES NOT for me.

Tried the following combinations but all results in one of two error messages and I’ve ensured STEAM_RUNTIME=1 steam is how I started the whole deal when just installing steam from within Terminal command or running from first time running it. Then ran it via Mint Menu and searching for " steam" and run it from there. :

Before and after “apt install mesa-vulkan-drivers mesa-vulkan-drivers:i386” since I have an AMD rx580 vid card

With and without launch options of +r_renderapi 1 +r_renderapi-1 +r_renderapi_1 +r_renderapi 0 +r_renderapi-0 +r_renderapi_0 AND all those combinations with API capitalized *** and *** ENSURED it was being ran via steam runtime and NOT the native client I never asked me to install any 32 bit libraries but it installed so far I couldn’t tell if it did that anyways or not via the terminal installation.

Before and after all updates, with stock kernel 4.15.0-20 ( active), and tried kernel 4.15.0-34 and ensured it was active.

then tried using Ukuu to upgrade to latest kernel which as of 11:34 p.m. 9-28-18 with this utility is 4.18.10 and ensure it was the active one and uninstalled the previously running kernel. and ensured everything else worked properly BEFORE trying again .

x( This is the EXACT situation-results as to why I always end up right back in Windows ( where shit ACTUALLY works and without such asinine endless-rabbit-hole loop headaches that still end in failure), and I don’t want to be back in windows again.

I just don’t know what to do anymore. I’ve reinstalled mint 19 cinnamon 64 bit at least 3 times and tried Manjaro and ubuntu within September 2018. I sincerely need some help here. II just want to get doom 2016 ACTUALLY working and working right in Linux WITHOUT running a VM or LUtris or complicated bs ( Hell if I can get it working with within PlayonLinux the so be it…

I’m open to successful suggestions :frowning:


#512

I have similar hardware config to yours and urge you to properly follow the instructions and try again.

Steam with proton + latest stable kernel (4.18.10) works just fine with DOOM 2016.

It might be a Mint quirk, as is usually the case because its usually outdated and using these new toys requires more bleeding-edge packages (at least for now).

Not sure what/ where you went wrong. The process took me less than 5 minutes to get working on my first try. If all else fails, try Ubuntu Mate. That’s what I’m using and the experience was smooth. You shouldn’t have to do any fiddling.


#513

Since when is Mint outdated? Joe Collins would have a different opinion of that and he’s been using Linux long enough.

I’ll try again another time. As far as those " instructions". I"m not doing Lutris as I don’t have a massive disposable income ( and SHOULD NOT have to have two video cards just to be able to game in linux with the same hopeful performance as in windows with one video card), and not doing a VM. So it’s POL or Steam for me or no go.

I’ve followed the instructions otherwise on that url to the T as I have already explained before. Mint 19 uses the same base stuff as ubuntu 18.04…so if Mint is outdated, as you claim, so is ubuntu 18.04 then.

I’ve tried Ubuntu 18.04 mate less than 20 days ago, but I’ll try that again given this newer steam beta 3.7-7 beta selection.

As far as the endless-rabbit hole problem or deadend - I’ve explained what all else I’ve tried. That should be enough to justify my frustration-vent in that comment part. It just feels like endless amount of variables to deal with and I still can’t yet get a game that valve and some others CLAIM to work basically " out of the box" with Steam in linux …( some have claimed to have it working without even having to install the mesa-vulkan driver within terminal command)

I mean all good vibes man. It’s just I’m sick and tire of failing at being able to go 100% linux when crap like this happens. I’m beyond fed up with Winblows and have gotten all other ( except my g keys in Logitech 710+ keyboard to work) needs to work in Linux except AAA title gaming.

I’ll try again tomorrow. Cheers and gnite.


#514

Sure, I’d love to speak with him.

I didn’t do Lutris either. Just pure Steam with Steam play.

Are you using Mint that’s based off of Ubuntu, or Mint that’s based off of Debian?

All this was working for me since proton 3.6-4. There’s gotta be something else. Just a matter of finding it.

I feel your pain too. And I hope that you do get it sorted out.

Sounds good! ciao


#515

Lutris is not VM software its a wine wrapper. Its basically like proton.

Also Please read the instructions on the steamplay page: https://github.com/ValveSoftware/Proton/blob/proton_3.7/PREREQS.md

You need the Pandoka PPA drivers to run steamplay smoothly. Did you update the drivers? The ones that come with mint are older (as with any ubuntu based distro) and could have issues with Proton.

I have the Nitro 8b 470 with Mint on the 4.15 kernel with updated drivers and Doom works fine.


#516

I thought the mesa-vulkan driver was all I needed if running an amd compatible video card ( rx 580 for example). Either way, I decided to give it one more shot tonight. Installed ubuntu 18.04 mate 64 bit. downloaded all updates, installed Steam from within the Software Boutique. updated to Kernel 4.18.10 via UKuu, Opted into the latest proton beta version 3.7-7, while downloading Doom 2016, I set the launch option to +r_renderapi 1, and after it installed…it just worked. I cannot believe it FINALLY …just worked. I didn’t even have to change from open gl 4.5 to Vulkan within the in game settings menu. It was already set to vulkan and I’d dare say it is faster and smooth than in Windows, but perhaps there is something i’m missing or misunderstanding. Either way i’m exhaust but very happy.

This makes me wonder if the desktop environment itself is the weird problem. I haven’t tried Mint 19 mate yet. I’ll test that tomorrow afternoon and report back the result. So now…6 of my 20 something games work versus in Windows. :smiley:

Giggidee and fat cheek babies!! Gnite yall.


#517

Thanks for that tid bit.


#518

The mesa Vulkan driver is still a driver and needs to be kept up-to-date. But since things work no problem leave as it is…just keep it in mind if you get into problems again in the future.

Also yeah the desktop envirorment does play a role in stability and cinnamon tends to be more invasive than Gnome and Mate. That is why it is important to have updated drivers.


#519

BTW an other good advice is that when you get everything as you like it use Timeshift (a recovery program) to make a snapshot of your system. Thus if anything gets borked if you ever need to experiment with drivers, wine and the like you can always recover to your stable state.


#520

also noteworthy, in the Proton 3 Beta folder there is a file user_settings.sample.py rename the file to user_settings.py and edit its contents removing the comment # this way one will get additional information.

e.g:

#to enable these settings, name this file "user_settings.py"

    user_settings = {
        #logs are saved to $HOME/steam-$STEAM_APP_ID.log, overwriting any previous log with that name
        "WINEDEBUG": "+timestamp,+pid,+tid,+seh,+debugstr,+module",

        "DXVK_LOG_LEVEL": "info",

        #Enable DXVK's HUD
        #"DXVK_HUD": "devinfo,fps",

        #Use wined3d for d3d11 instead of dxvk
        #"PROTON_USE_WINED3D11": "1",

        #Disable d3d11 entirely
        #"PROTON_NO_D3D11": "1",

        #Disable in-process synchronization primitives
        #"PROTON_NO_ESYNC": "1",
    }

becomes

#to enable these settings, name this file "user_settings.py"

user_settings = {
    #logs are saved to $HOME/steam-$STEAM_APP_ID.log, overwriting any previous log with that name
    "WINEDEBUG": "+timestamp,+pid,+tid,+seh,+debugstr,+module",

    "DXVK_LOG_LEVEL": "info",

    #Enable DXVK's HUD
    "DXVK_HUD": "devinfo,fps",

    #Use wined3d for d3d11 instead of dxvk
    "PROTON_USE_WINED3D11": "1",

    #Disable d3d11 entirely
    "PROTON_NO_D3D11": "1",

    #Disable in-process synchronization primitives
    "PROTON_NO_ESYNC": "1",
}

EDIT: of course don’t uncomment everything like I did for the example simply what you need


#521

I think you have a massive misunderstanding of what Lutris is. Lutris is just using wine underneath just like PoL and Proton.

What you are referring to is passthrough and has literally nothing to do with Lutris.

Not really a wrapper as it just manages wine prefixes.


#522

Well the only example I saw Wendell talk about in any videos is when he was doing it as a passthrough ( such as the video with him and Linus just shortly before this whole proton steam play thing with Valve launched around one month ago). But, if I encounter any more problems, I might give it a shot if it’s free.


#523

Wendell on LTT video was timing wise funny when steam / valve dropped the steam play bomb.


#524

Also they didn’t only talk about passthrough…
They talked first and foremost about native gaming, then wine, and passthrough for very advanced users…