Return to Level1Techs.com

Windows Games on Steam for Linux. [Proton client Testing grounds]

steam-play

#485

Just got Fallout 4 working with Steam Play in Proton 3.7-beta. Unlike previous attempts, audio is fine. Mouse control was crazy, so had to add bBackgroundMouse=1 to Fallout4_Default.ini (under [Controls]) in the main game directory. Other than that game seems fine for several minutes of gameplay. One notable missing feature is a lack of mod support. Mods loaded in the Data directory were ignored, and the Mods option in the in-game menu was disabled, so even Bethesda.net mods are unavailable. I have not tried a 3rd party mod manager in Proton yet.


#486

Did you manage to install the game?

As an update ppl are trying to fix the DE bug with divinity original Sin 2 in Wine. There are patches like these submitted: https://source.winehq.org/patches/data/150821

And i see similar fixes in the release notes of 3.16 staging : ntdll: Relax checks for valid affinity mask in NtSetInformationThread().

I will try today and see if this is fixed


#487

Ok tried the GOG version it in Lutris with 3.16 and works like a charm. I expect that it should also work for proton if the version is based on 3.16 as long as you do the naming workarounds.


#488

I can confirm that the Steam for Windows version of Divinity Original Sin 2 works in wine-staging 3.16. Steam Play/Proton has apparently not incorporated the patch yet, as launching from Steam for Linux gets the same hung black screen.


#489

Looks like a open version of corefonts is now available:

It’s called foss_corefonts:


#490

Hopefully i’m not speaking off topic or much off topic here. Can anyone tell me how to install and run Steam-runtime instead of the native linux steam client? I can’t seem to get a straight answer just googling it. Thank you.


#491

If you want to use the new steam play on linux you install the normal client of steam.

Then follow the instructions in the top of the thread.

Its all options in the steam client.


#492

Trying to get Warframe working but it’s not launching and not sure how to debug. Gonna try Lutris version.


#493

For my source I use.

https://spcr.netlify.com/app/230410


#494

From what i hear ppl are using this to launch through proton: https://gitlab.com/GloriousEggroll/warframe-linux/tree/steamplay-proton

Although the lutris side should worth a try as well.


#495

So I downloaded the script and with my inexperienced ways i think I did everything required. It is busy running stuff so lets hope!


#496

Which distro are we talking about? Most packages include both versions and it is a matter of what execute command you use. the default is also runtime usually.


#497

How am I supposed to run this? I exracted the zip to the tools folder and run the game from Steam. It shows running for a while and then closes.

Running the launcher also doesn’t work… Sorry - really don’t have allot of experience with wine/dxvk

#edit: Seems like I was too impatient - after a while a popup came up running a preprocess that seems like it is going to take a very, very long time


#498

I am just a guy on the internet.

Install linux, Install steam, Click a few options inside steam to be on the beta and bam.

The instructions are way more useful than my sentence. But you get what you pay for.


#499

Well all I needed was patience. I’m in game so seems like the installer worked.

BTW: Your answer was golden!

#edit: Now to get the sound working…
All working now!


#500

I looked but didn’t see any options within the native linux steam client that said anything about " use steam runtime in stead" or " enable steam-runtime".


#501

Linux Mint 19 cinnamon 64 bit…and I didn’t see any settings options within the native linux steam client that talk about " steam-runtime" in any way of enabling that. to Answer the other guy’s response too.


#502

Valve just updated the Proton beta today:

3.7-7 Updated DXVK from 0.70 to v0.80. Valve also added some fullscreen and .net fixes as well.


#503

Steam runtime isn’t an option in Steam. Its a launch argument.

STEAM_RUNTIME=1 steam

Will launch Steam with Steam runtime enabled

STEAM_RUNTIME=0 steam

Will launch Steam with Steam runtime disabled.


#504

What @Diffident said