Return to Level1Techs.com

Windows Games on Steam for Linux. [Proton client Testing grounds]

steam-play

#445

One more report. Hellblade: Senua’s Sacrifice doesn’t launch in Proton. The game titles load, but then the game locks up to a black screen with some creepy voices in the background.

My wine-staging 3.11 install with a Fallout 4 audio patch does much better. The game loads and plays with good fps, but there are problems with lighting and shadows. I’ve noticed similar issues with Fallout 4. Also of note is that the DXVK HUD does not show up, so I think this is a DX9 (or maybe DX10) title. For now, I’m playing it in my Win10 VM.


#446

That’s weird because someone above had a video of it running.


#447

Hi,

I just saw an email asking me about Hellblade, Sensua’s Sacrifice.

“Saw you succeeded in getting this game working. It’s on sale and the concept is interesting. How do you like it so far? What GPU are you running it on?”

Yes the game runs fine for me with max graphics quality at 1080p set so far.
I bought it in the Steam Sale. I had been hoping to purchase it in a Steam Sale for the Graphics Quality to use it as a GPU performance test case anyhow.

I thought it might help promote Steam Play Beta and gaming on Linux if it worked. The game won a number of awards.

I did nothing special to get it to run.
I ran a clean install and set the 3 option switches in Steam Play Beta.

RE: the concept is interesting

Yes, I think it attempts to simulate ‘mild psychosis’. I think If it succeeded in simulating a real psychosis attack you would be in utter hell, hiding under your PC desktop in terror for your and your families lives. I think the visual effects would be much more severe and horrifying than what I see on the game so far.

RE: How do you like it so far?

I like the Graphics Quality. The game runs rather well on Fedora 28 with latest Mesa 18.3.0 drivers. There are some performance dips, but remember I run the recording using Vokoscreen, and that causes some of the performance dip in the video.

RE: What GPU are you running it on?

I have all System information in the video description.
I am running with a AMD Sapphire R9 Fury X. It has an AIO watercooler.
You should see slightly lower levels of performance with an AMD RX 580 8GB card at 1080p on this game.

If you do have problems starting the game, set it to borderless fullscreen or windowed before you launch the game. If the game does fail to launch, uninstall it, reinstall it, set it to borderless fullscreen and try to launch it again.

If you do buy it just for Linux and it does not run for you, then please remember that the game is not whitelisted by Steam yet, and I might just be lucky to have OS/Driver/GPU combination that works.

I hope that is enough information for you.

Thanks.


#448

I seem to have a lot of audio issues with Proton - not sure why. E.g., while Divinity: Original Sin 2 runs in Proton for me, the audio is horribly choppy. In my custom Wine build, I don’t seem to have this problem. Also, he has Mesa 18.3.0, whereas I have 18.0.1.

As an aside, is there a simple way to get the latest Mesa OpenGL/Vulkan/AMDGPU in Fedora 28 without borking my rpm database?


#449

I bought the humble tabletop bundle for $1 and got 3 games: ticket to ride, sentinels of the multiverse, and mysterium: a psychic clue game. I wanted it for ticket to ride and it works perfectly while the other two fail to launch. I never knew my luck stat was so high.


#450

Late response here. But I did give spinrite a try and it actually worked. I have managed to recover the HDD. Thanks for the suggestion!


#451

I can’t even get the game to install. Were you installing it from GOG with all the parts?


#452

Yeah i did…But it is easy to mix up if you do it manually. Its like 16 parts. So i just logged on windows and had gog galaxy make a back up to make sure I did not miss a part (it just downloads all parts, nothing else) and it works fine when it comes to installation. I have added the game manually through lutris by first defining the installer as an executable (make sure you disable DXVK for that) and then when the install was done changed the executable to the correct game executable (not the supporttool.exe btw the other one on the DFED/bin).

That is how i did it with the normal edition as well and it worked fine.


#453

Hellblade: Senua’s Sacrifice run without issue for me as well.

It just worked.

System: Host: Jennifer2 Kernel: 4.18.5-041805-generic x86_64 bits: 64 gcc: 8.2.0
Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1) dm: lightdm Distro: Linux Mint 19 Tara
Machine: Device: desktop Mobo: ASUSTeK model: RAMPAGE IV BLACK EDITION v: Rev 1.xx serial: N/A
BIOS: American Megatrends v: 0801 date: 07/04/2014
CPU: Quad core Intel Core i7-4820K (-MT-MCP-) arch: Ivy Bridge rev.4 cache: 10240 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 29597
clock speeds: min/max: 1200/4500 MHz 1: 1246 MHz 2: 1367 MHz 3: 1339 MHz 4: 1279 MHz
5: 1304 MHz 6: 1259 MHz 7: 1305 MHz 8: 1269 MHz
Graphics: Card: NVIDIA GP102 [GeForce GTX 1080 Ti] bus-ID: 01:00.0 chip-ID: 10de:1b06
Display Server: x11 (X.Org 1.19.6 )
drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
Resolution: [email protected]
OpenGL: renderer: GeForce GTX 1080 Ti/PCIe/SSE2
version: 4.6.0 NVIDIA 396.54 Direct Render: Yes
Audio: Card-1 NVIDIA GP102 HDMI Audio Controller
driver: snd_hda_intel bus-ID: 01:00.1 chip-ID: 10de:10ef
Card-2 Intel C600/X79 series High Def. Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:1d20
Card-3 Logitech G430 Surround Sound Gaming Headset
driver: USB Audio usb-ID: 007-006 chip-ID: 046d:0a4d
Sound: Advanced Linux Sound Architecture v: k4.18.5-041805-generic
Network: Card-1: Intel 82579V Gigabit Network Connection
driver: e1000e v: 3.2.6-k port: f040 bus-ID: 00:19.0 chip-ID: 8086:1503
IF: eno1 state: up speed: 1000 Mbps duplex: full mac:
Card-2: Broadcom Limited BCM4352 802.11ac Wireless Network Adapter
driver: wl bus-ID: 0d:00.0 chip-ID: 14e4:43b1
IF: wlp13s0 state: up mac:
Drives: HDD Total Size: 5501.1GB (10.1% used)
ID-1: /dev/sda model: Samsung_SSD_840 size: 250.1GB serial:
ID-2: /dev/sdb model: Samsung_SSD_840 size: 250.1GB serial:
ID-3: /dev/sdc model: WDC_WD10EZEX size: 1000.2GB serial:
ID-4: /dev/sdd model: WDC_WD10EADS size: 1000.2GB serial:
ID-5: /dev/sde model: WDC_WD10EADS size: 1000.2GB serial:
ID-6: /dev/sdf model: ST31000528AS size: 1000.2GB serial:
ID-7: /dev/sdg model: SAMSUNG_HD103UJ size: 1000.2GB serial:
Partition: ID-1: / size: 229G used: 18G (9%) fs: ext4 dev: /dev/sda1
RAID: System: supported: N/A
No RAID devices: /proc/mdstat, md_mod kernel module present
Unused Devices: none
Sensors: System Temperatures: cpu: 30.0C mobo: N/A gpu: 0.0:69C
Fan Speeds (in rpm): cpu: 0
Repos: Active apt sources in file: /etc/apt/sources.list.d/additional-repositories.list
deb https: //dl.winehq.org/wine-builds/ubuntu/ bionic main
deb http: //apt.llvm.org/bionic/ llvm-toolchain-bionic-7 main
deb-src http: //apt.llvm.org/bionic/ llvm-toolchain-bionic-7 main
Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
deb [arch=amd64] http: //dl.google.com/linux/chrome/deb/ stable main
Active apt sources in file: /etc/apt/sources.list.d/graphics-drivers-ppa-bionic.list
deb http: //ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic main
deb-src http: //ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic main
Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http: //packages.linuxmint.com tara main upstream import backport #id:linuxmint_main
deb http: //archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
deb http: //archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
deb http: //archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
deb http: //security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
deb http: //archive.canonical.com/ubuntu/ bionic partner
Active apt sources in file: /etc/apt/sources.list.d/teamviewer.list
deb http: //linux.teamviewer.com/deb stable main
deb http: //linux.teamviewer.com/deb preview main
Active apt sources in file: /etc/apt/sources.list.d/teejee2008-ppa-bionic.list
deb http: //ppa.launchpad.net/teejee2008/ppa/ubuntu bionic main
deb-src http: //ppa.launchpad.net/teejee2008/ppa/ubuntu bionic main
Info: Processes: 295 Uptime: 3 days Memory: 4563.8/32108.3MB
Init: systemd v: 237 runlevel: 5 Gcc sys: 7.3.0 Client: Unknown python3.6 client inxi: 2.3.56


#454

This might have been mentioned before, and I posted it on a YT video but it probably can help here too because allot of people don’t know about the 3 things below.

Three things people might need to do, however some titles will work either way.
-Increase Open File size so Esync can work correctly: https://github.com/zfigura/wine/blob/esync/README.esync

-Some games require spoofing your GPU to AMD due to NVAPI issues (just disabling them still causes issues): https://github.com/doitsujin/dxvk/wiki/Configuration

-Other games will require you to install xact libraries in their proton compat folder with winetricks to get audio working correctly.

Not doing this may result in games not starting, freezing, infinity loading loops, ultra low fps or other performance issues.

I can post more details on howto do certain things if need be.


#455

Yeah okay, i didn’t know about the GPU spoofing thing… I bookmarked that page incase need it.

tell me more about this…


#456

Thanks for this reminder. I keep forgetting that Proton has a separate prefix for each game. I’ll try it with Hellblade and see if it helps.

UPDATE: Even with xact installed into Hellblade’s prefix, it still won’t start. However…I tried to install it on my laptop, and it runs on that device … with issues. FPS are low, and audio is weird. Lip sync is messed up, and sounds do not attenuate with distance. Instead, they suddenly abruptly discontinue at some distance from their source. I’ve noticed the same thing with Skyrim (or maybe it was Skyrim SE.)

The reason it works on my laptop may be that I have the latest beta drivers from Nvidia. On my Fedora 28 desktop, however, I have older amdgpu/mesa drivers (18.0.5). How can I get more recent drivers on the desktop (hopefully w/o compiling from scratch)?


#457

Pretty simple, here is a command I used for one of my games (deep rock galactic). I assume you can figure out the correct syntax for your case scenario?

This is all on ONE line of text, forum wraps text unfortunately.

env WINEPREFIX="/mnt/GamesSSD/SteamLibrary/steamapps/compatdata/548430/pfx" WINEPATH="/mnt/GamesSSD/SteamLibrary/steamapps/common/Proton 3.7 Beta/dist/bin" winetricks xact

Perhaps keep track of this:
https://github.com/ValveSoftware/Proton/issues/943


#458

Hmm, tried a number of tricks from that thread in my laptop’s prefix to fix the audio issues. Including winecfg>libraries>xaudio2_7>native,builtin, winetricks xact and PROTON_NO_ESYNC=1. I also tried modifying the system files necessary for esync to work. But I’m still getting pops and clicks and other audio anomalies. It’s kind of irrelevant anyway.

The combat in this game is frustrating the heck out of me, even on easy. Strange since all the reviewers say the game is so easy. But I’m used to RPG and strategy games, not fighting games. It’s a shame, because the production values are so high and the concept seems really interesting.


#459

Thanks for testing Hellblade. For me it crashes on the loading screen. Will try to clean install fedora 29 as only one game tested till now worked. Running Fedora 28 mesa 18.2 HD 7970.


#460

Try setting it to borderless full screen or windowed before launching.

I have an HD7970 OC 6GB card.
I also have an R9 280x 3GB which is a Tahitil XTL GPU - very similar to an HD7970 OC 3GB.
If you are really stuck I can try Hellblade with one of those GPU.
Bye.


#461

this might be useful.

https://forums.linuxmint.com/viewtopic.php?t=272283

apparently old AMD cards have issues with dxvk, but this will fix it.


#462

The stock testing is done for me. It’s time to get my hands dirty.

If a game simply won’t launch try going into the local files and make some minor changes. Put the launcher exe in a folder and rename the main exe as the launcher. As always back this stuff up. These are the games that I got going doing this.

Age of Empires 2 HD
Fallout
Fallout 2
Fallout Tactics
Sins of the Solar Empire: Rebellion
Sims 3

I also upgraded to 3.7-6 and I got some games working that I couldn’t before. I’m going to try and reinstall Bioshock remastered 1 and 2. I’ll let you know tomorrow.

Here are the games that now work
Rome Total War: Flawless
Rome Total War Alexander: Flawless
Total War Rome 2: Flawless
Spore expansion packs: Flawless.

Ubuntu 18.04
Intel® Core™ i5-7200U CPU @ 2.50GHz × 4
Intel® HD Graphics 620 (Kaby Lake GT2)
8.0 gb ram
3.0 Mesa 18.1.7
Kernel 4.15-33
Proton 3.7-6


#463

I’ve got Doom running, and the gameplay is great, except that Steam will be in full screen mode, but the game only occupies the left half of the screen. The monitor is an LG ultrawide, 2560x1080. I’m not sure why this is happening. Disclaimer, I did recently switch from Kubuntu over Ubuntu Mate 18.04. I’ve checked the video settings within the game, within Steam, and even looked at compositor settings in Ubuntu. I can’t figure out what’s going on. Any ideas?


#464

Try lowering your desktop resolution and see what happens. Which Doom are you referring to?