Return to Level1Techs.com

Windows Games on Steam for Linux. [Proton client Testing grounds]

steam-play

#465

I’ll give that a shot when I get home tonight. I believe it’s Doom (2016), not the old Doom I used to run on Windows 95 (showing my age).


#466

I was the one showing my age by assuming it was the old one. The lowering of the resolution might have worked for that one. I’m not sure about the new one. It won’t hurt.


#467

I’m pretty sure it’s just a setting issue, or maybe an update borked it. I’m running the beta Proton client, which is what got me to the point of actually being able to get Doom to work in the first place. I’m also thinking it might be an issue with the AMD drivers, and proprietary vs open driver. I’m pretty sure I’m running the open driver, but I was pretty sure I had installed both (AMDGPU and AMDGPU-PRO).


#468

Okay. Open up Software and updates and click on “Additional Drivers”. It will tell you what you are running. If you aren’t running the Proprietary driver you need to install it. Once you get that install you need to go to this page and get the latest drivers.


#469

I do remember that there was nothing listed on the “Additional Drivers” page, so I’m assuming that I don’t have AMD’s proprietary driver installed. I’ll try installing it again tonight. Thanks for the help!


#470

No problem:) Let me know how things work out.


#471

I get similar issues on Windows 8.1, I thought they had made a patch that would remove the need for Windows live.


#472

You can try the pulse audio latency variable (run program via terminal with variable set first to test.

There are also adjustments that can be made in the following file for sound issues with wine (google about them).

/etc/pulse/default.pa
/etc/pulse/system.pa
/etc/asound.conf


#473

@The_Riddick I did a couple of things that improved the overall experience in Hellblade. I still couldn’t get it working in Proton/SteamPlay. However, after upgrading to Mesa/amdgpu 18.2.0 + LLVM 6.0.1 and changing the ulimit parameters it ran much better with my custom wine-staging 3.11. Performance is still an issue; lowering texture size to medium and effects/postprocessing to low mostly fixes the low fps. Still can’t get near native performance though. The audio weirdness is definitely gone, fortunately.

Those changes were also enough to get GTA V running - or at least the benchmark. Again, no luck in Proton, but my custom build seems to work fine. I’m really not sure what the special sauce is…


#474

So I did some testing last night regarding the game playing in half-monitor mode. So remember that Steam is running in full screen mode. All of the games were doing the same thing when opened, they’ll open up in “full screen” mode, but only occupy the left half of the monitor. If I change the setting to Borderless, The game window moves up to the top left quarter of my monitor. If I change to “Window” mode, I find that this will at least show up in the center of my monitor and I can resize it a little larger. I cannot F11 it into actual full screen mode though.

As for installing the AMD proprietary drivers, I still haven’t managed to get that to work. I’m using the install script as instructed on AMD’s site (and within the package folder). I’ve tried several times to install, and every time I get a message that no new packages have been installed, because it’s already there. But when I go to Additional Drivers, the proprietary drivers don’t appear as an option.


#475

Okay. In Steam there is a help tab. Click on that and in the drop down menu there is an item named system information. That should tell us what you are working with.


#476

Some additional info:

lspci -k | grep -EA3 ‘VGA|3D|Display’
VGA compatible controller: Advanced Micro Devices Inc…
Subsystem: ASUSTek Computer… Radeon RX 460/560 / Pro 450/455/460/560]
Kernel driver in use: amdgpu
Kernel modules: amdgpu


#477

Are you familiar with this page?
https://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Install.aspx

I’m coming up empty on Google.


#478

I guess I’ll have to look that up tonight. I’m using Chrome Remote Desktop and trying to open Steam I get this error “glXChoseVisual failed”.


#479

We’ll be here:)


#480

I haven’t come across that exact page, but it is very similar. I’m running Ubuntu Mate 18.04, and this is replicating a lot of the instructions that were included in the amdgpu-pro download. I did notice one thing in that link you showed mentioning the user being part of the “video” group. I am not. I appear to be a member of many groups, but video is not listed. I’ll give that a shot, and hope I don’t screw something up.


#481

THE PLOT T H I C C E N S

Nekopara Vol.2 works with Proton 3.7.6-beta

OS - Gentoo
GPU - Intel iGPU Graphics via Mesa.


#482

quake 3 works well


#483

I noticed some discussion about xact as well.

Proton is allowed to distribute DirectX for Windows if the dev explicitly says in the install script it’s a Steamworks Shared file requirement.

However, since DirectX pretty much drives everything, Proton itself needs to pull from Steamworks Shared to install DirectX when making a prefix.

This is a different situation from winetricks corefonts as xact can be easily resolved with a DirectX redistributable which is very commonly distributed on Steam without issue.

Corefonts though is Arial and etc. which MS still asserts some copyright too, and can’t be included in Proton.


#484

@Azulath On the same hardware I got about 100fps on Windows, was around 50 on Linux. pretty big in terms of raw numbers. But still very playable.