Return to Level1Techs.com

Windows Games on Steam for Linux. [Proton client Testing grounds]

steam-play

#425

Isn’t that Unity update is what caused Rust to derail too?


#426

Unity 2018 seems to not play well with OpenGL right now.


#427

I’m thinking of shutting off my updates to Cities:Skylines. That’s the only Unity game that I am aware of. Developers and publishers don’t exactly advertise that engine:)


#428

Finishing up finally.

Age of Empires 2 HD: Won’t launch
Arcanum: Launches very slowly and the menu lags. The game itself freezes or it’s running at 60 frames per hour. Won’t run.
Borderlands: flawless
Caeser 3: Runs fine but in it’s resolution of 800x600 edge scrolling will not work on the bottom or right side of the screen. Switching to 1024x768 solves this. Runs flawlessly.
Dragon Age Origins: Flawless
Grand Ages Rome: Flawless
Nosferatu: Flawless
Pharaoh and Cleopatra: See Caeser 3
Sims 3: Won’t launch
Sins of the Solar Empire: rebellion- Won’t launch
Vampire Bloodlines: Flawless
Warhammer 40,000 Space Marine: Won’t Launch
Zeus and Poseidon: Same problem as Caeser 3 but the menu glitches making the options invisible.

Ubuntu 18.04
Intel® Core™ i5-7200U CPU @ 2.50GHz × 4
Intel® HD Graphics 620 (Kaby Lake GT2)
8.0 gb ram
3.0 Mesa 18.1.7
Kernel 4.15-33
Proton 3.7-3


#429

Will edit this later when I get home, just going off memory on these and haven’t checked if any have been mentioned already.

Trials 2: Second Edition: technically runs flawlessly, but pops up with a font error dialog (doesn't stop the game from running)
Trackmania 2: Stadium : Flawless. (Custom skins do cause hitching when they load, but this occurs windows as well.)

CPU: AMD Ryzen 7 1700 @ Stock
GPU: Nvidia GTX 1070 (SLI Disabled)
RAM: 32.0 GB RAM @ 3000Mhz (I think.)
OS: Manjaro (Installed via Architect, need to check Uname later)
DE/WM: Deepin (unknown version)
Kernel: 4.15-??
GPU Drivers: Nvidia 396.54
LLVM: unknown (will add later)
Proton: 3.7-3


#430

You have to rename the EXEs to launch Age of Empires II HD.


#431

I heard about that but I didn’t do it. I didn’t want to do a lot of configuring with files or do wine prefexes. I also didn’t do the latest beta. I pretty much went with the stock settings. I know I have the absolute worst computer for gaming on Linux. I tested all of these games and if they work straight out of the box for me no one else should have any problems.

It really wasn’t my goal to see how many games I could get to run. I wanted to see how well Steam did with their initial offering.

Considering that this project is far from finished, I would say they did a remarkable job.


#432

FYI to all, Proton’s Beta channel has been updated to 3.7-6 in time for this weekend.


#433

Here’s a link to the improvements

Click the changelogMD link.


#434

Tested a few more this weekend. They seem to be running really well.

Hellblade: Senua’s Sacrifice:

and:

Call of Juarez:Gunslinger

Bye.


#435

I’ve been testing every game in my library (not incredibly thoroughly but still) since the beta came out and I’m just finishing up so I thought I’d share my results. All results were from the completely stock steam version of proton on a fairly exotic linux system of gentoo, xmonad and only alsa for sound.
I had a total of 25 games that worked perfectly
payday and doki doki literature club of course but they were already in the whitelist.
Ame no marginal, auditorium, ben there dan that!, the binding of isaac, castle crashers, deadlight, enemy mind, eXceed 2nd, eXceed 3rd, gearcrack arena, Japanese school life, the king of fighters XIII, memory’s dogma CODE:01, mitsurugi kamui hikae, narcissu 10th anniversary anthology, orcs must die! 2, recettear, root double -before crime * after days- xtend edition, sid meier’s pirates, sid meier’s railroads, time gentlemen please, tower wars, and worms revolution

I had 15 games that I would consider playable as in they have bugs that don’t severely impact play, have very easy workarounds, or only break sometimes and are otherwise flawless.
arcana heart 3 love max - was unable to save user settings after restart (keybinds most importantly) and had slightly more “unable to connect to opponent” than normal but once you are in game it was exactly as it should be.
chantelise - About half the time it would just not have any sound at all when launched.
the elder scrolls V skyrim - when changing settings (such as FOV) in the .ini file changes don’t take effect until the tab menu is opened.
dark souls prepare to die edition - the opening cutscene had completely black video and no audio.
guilty gear Xrd sign - won’t save user data in the same vein as arcana heart
guilty gear XX accent core plus R - same as Xrd sign
idol magical girl chiru chiru michiru parts 1 and 2 - minor, persistent graphical glitches such as sprites not loading on cues. Playable but not exactly pleasant
the incredible adventures of van helsing - minor graphical glitches on images with transparency. They show a white background rather than the intended transparent background.
nekopara volumes 0,1,2 - working perfectly except for japanese language version. Japanese text shows up as blank boxes.
orcs must die - when you enter a map for the first time various important inputs do not work (such as those needed to open the trap menu) but if you scroll forward into first person mode all inputs immediately work as intended for the rest of the round regardless of first-personness.
the witcher: enhanced edition - in some camera modes there is a constant camera acceleration that moves up and to the left similar to if you had a laser mouse with a broken sensor. I consider this unplayable (see the ship) but because there are other camera modes that work perfectly it’s in this category.

I found 17 games that are completely unplayable but still launch successfully.
100% orange juice - no sprites load at all and the mouse control is completely broken. Buttons need to be clicked halfway across screen and clickable window size is larger than rendered window size so only part of the screen is accessible. If you are fullscreen on a widescreen (1080p) monitor then pointing mostly works however.
blazblue: continuum shift extend - black window and nothing else
darksiders - game will boot and initially seems playable (you can walk around and kill things just fine) but there is absolutely no UI to speak of. HUD simply doesn’t exist and the pause menu sounds work but nothing else. If you knew this game backwards and forwards it might be playable (and even a fun challenge) but in general it’s not.
double dragon neon - game boots and all controls seem to be working except no matter what I try I can’t get my character to stop running back and forth.
eXceed gun bullet children - constant movement up as if the up arrow were depressed (in menus and in game) similar to the ship and the witcher’s camera bug.
the ship (tutorial, multiplayer, and single player) - all versions exhibit the same mouse problem as the witcher: constant camera movement up and to the left. There are no alternative camera modes so it is unplayable.
sid meier’s civilization IV (all 4 versions) - the base game won’t launch at all, beyond the sword crashes after getting into a map, and colonization and warlords are mostly playable but all text icons are broken (TXT_KEY_MAIN_MENU_MULTIPLAYER) which makes all the buttons overlap one another.

The following I lost my notes on why they were broken and don’t feel like reinstalling them to remember:
galactic civilizations II: ultimate edition, arma: cold war assault, consortium, darksiders II deathinitive edition, insectiside, star wolves

I found 6 games that crash after getting to at least some sort of screen.
audiosurf - starts loading from server then crashes
bad rats - crashes after about a minute of being opened
darksiders II - crashes before getting to main menu
nidhogg - can get into a game and play for a minute or two then crashes to desktop. Generally unstable
rivals of aether - finishes opening animation but crashes when starting a game
sid meier’s civilization III complete - crashes as soon as a game map starts to load

I found 31 games that simply won’t launch a game window at all (settings window or basic startup logo like bioshock included)
bioshock, bioshock remastered, bit trip runner, brothers - a tale of two sons, darksiders warmastered edition, dead bits, defy gravity, divekick, DLC quest, FLY’N, ghost in the shell: stand alone complex, Giana Sisters: twisted dreams, Hell Yeah!, Jet set radio, KARAKARA, Magicka, mount your friends, one finger death punch, ORION: prelude, out there somewhere, pixeljunk eden, retro/grade, rock of ages, sid meier’s ace patrol (incl. pacific skies), starseed pilgrim (was playable once but haven’t been able to revive it since), street fighter X tekken, super amazing wagon adventure, two brothers (also launched once and never again), universe sandbox

and last but not least I had one game that is dead on all platforms. Rest in peace magicka wizard wars :pray:


#436

It’s been a while since I posted here, but I have been using this to play a few games, and wow, it sure is nice.

Anyway, earlier I mentioned that I tried STEINS;GATE (Steam release) both with and without the community patch, and that it worked, but there were some issues. Further testing has shown that

  1. Valve fixed the controller problem - mice and keyboards no longer show up as controllers and make the game glitchy if you don’t have an actual controller plugged in. This was fixed after a Proton patch that came with a Steam client update.
  2. The unofficial patch doesn’t actually work. Installing it doesn’t cause a problem and the game still runs, but the patch doesn’t actually start up under the default environment. After seeking help in the Committee of Zero Discord, I found that the winetricks package, dinput8, is required to make the patch run. To install that, I used WINEPREFIX=/path/to/steamapps/compatdata/412830/pfx winetricks dinput8
  3. The patch’s configuration tool doesn’t work either. I needed it in order to enable subtitles (using the higher quality Japanese videos with softsubs instead of the hardsubbed ones that come with the English release). In order to get this working, I had to run the configuration tool on a computer actually running Windows, then copy %LOCALAPPDATA%\Committee of Zero\SGHD\config.json from that computer to /path/to/steamapps/compatdata/412830/pfx/drive_c/users/steamuser/Local Settings/Application Data/Committee of Zero/SGHD/config.json.

Now I have a perfectly working and patched version of Steins;Gate on Linux. The day I never have to use Windows again draws ever closer. Anyway, I figured I should document the process because I figured it out mostly on my own (Google was useless) and I will most likely need to refer back to this in the future.

I also bought PSYCHO-PASS: Mandatory Happiness and confirmed that it works perfectly with no additional setup. Steam Play is awesome.


#437

Just for fun, I decided to try an officially supported game. Fallout Shelter worked perfectly.

Tried GTA V. I can run the benchmark for about 10 seconds before it locks up. It reports ~50fps while it’s running, but stutters like mad. It eventually hard locks the PC.

Sadly, I’m now out of disk space having tried all these games.


#438

That’s an odd problem with Double Dragon Neon.
It’s usually the first game I try out when testing my wine setup, because in know it works flawlessly in regular wine and it’s a quick download. If I remember, I can give it a try this week and see if I have problem too.


#439

Definitive edition does not work still. I can install correctly but i get a black screen with just the cursor working. The same goes with proton as well.

But someone on reddit found the issues (has do to with how the game checks available core threads) and made a redare2 patch:

Unfortunately since then the game was updated…Meaning that this patch is no longer valid. So unless the patch is also updated it is not possible to make it work at this point.


#440

I’m having a heck of a time with DOS2 Definitive Edition on my Kaby Lake+1050 Ti laptop. Same black screen with the 3d cursor that you’re seeing. I couldn’t even get the black screen in a Windows VM. But it was a snap to get working with Fedora 28 on my Ryzen 7 + RX 580. Yay, AMD?


#441

I also have a Ryzen 7 and a 470 and does not work. The black screen is very hardware specific and maybe OS specific as well.


#442

The developer dumped support for Linux in their first game and never looked back (they were suposed to support it). so second game no support at all. its trash on linux.

a semi working workaround on wine is to run it directly running EoCApp.exe. it wont work through steam.

https://appdb.winehq.org/objectManager.php?sClass=version&iId=35767


#443

Yep, that’s how I got it working on my AMD box. But even running EoCApp.exe fails on my Intel+Nvidia laptop.


#444

It’s a shame that you can’t run Proton on native Linux games. Some of these Linux ports are terrible.