Return to Level1Techs.com

Why Asus Pro WS X570-ACE not working with 3 GPUs? Code 43

The Asus Pro WS X570-ACE is supposed to allow me to run 3 cards in x8x8x8 mode, but I’m yet to get all 3 cards working together properly.

I have three RTX3060 video cards (ea PCIE 4.0 compatible) plugged directly into this motherboard. All three are showing up in Device Manager and working “normally”, however GPU #3 has error code 43 in Device Manager.

What’s even more puzzling is if I remove the GPU #3 that’s plugged into PCIE3…then GPU #2 in the PCIE2 stops working and gives code 43 in device manager as well"…very frustrating to use…seems like a hit or miss…

I used a Thermaltake PCIE 3.0 riser last night, with GPU #3 in the PCIE3 slot and it worked (finally) but at PCIE 3 x4 …instead of x8, but after trying to troubleshoot this, it is back to not working again.

My specs are below:

Motherboard: Pro WS X570-ACE
CPU: Ryzen 7 3700X (3rd Gen)
OS: Windows 10
GPU: 3 x Zotac RTX 3060 (Non-Ti)
PSU: 850W

I’m at a loss, the GPUs have all been tested and work on one of my older boards without issue. Please help if you can.

1 Like

coughs in crete. Imma say pcie lanes my hude.

The board is supposed to support x8x8x8 as long as the CPU has 24 lanes

“Fully loaded takes on new meaning when you have up to 24 PCI Express® lanes and those lanes can be split in a 3-way x8/x8/x8 configuration spanning the board’s trio of PCIe x16 slots, allowing you to load up on GPUs to accelerate an increasingly diverse array of workloads, including AI training, 3D rendering, and scientific or financial modeling.”

The board uses x4 lanes from the x570 chipset to achieve this in the 3rd PCIE slot

I’d try putting the cards in different orders then. Could just be something stupid.

Or asus lied like they usually do. Wait for more users, thank you for posting.

1 Like

PCIe 16_3 really is electrically x8 (uses the X570 chipset as a PCIe switch), ASUS is not lying here. I’d guess either BIOS or NVIDIA driver bugs - would contact both about this.

Have a couple of Pro WS X570-ACEs but only a single RTX 3000 GPU so I can’t recreate the situation - but a Quadro P2000 works fine with x8 in PCIe 16_3.

Maybe the motherboard can’t handle the power demands of what the three GPUs want to suck over the PCIe slots at the same time?

I’d also try a different/larger PSU for testing.

Have you tried the latest beta BIOS?

https://www.asus.com/Motherboards-Components/Motherboards/All-series/Pro-WS-X570-ACE/HelpDesk_BIOS/

2 Likes

Thanks, I have a 1000W PSU which I can add to make 1850W (using Add2PSU), but I tried powering 1 GPU with it and it didn’t make a difference.

Regarding the BIOS, I have the version before that - “3402”, because I was afraid of trying the beta. Maybe I’ll take the risk.

Just to be sure:

  • You tested all GPUs directly installed on the motherboard without risers

  • 4G Decoding enabled

  • Resizeable BAR Support enabled (+ Windows installed on GPT disk in UEFI mode)

  • AMD CBS Options → NBIO → IOMMU: Enabled

  • AMD CBS Options → NBIO → Alternative Routing Support enabled

?

1 Like

Yup,

  • Each tested individuallly without risers - Working
  • 4G Decoding - Enabled
  • Resizable BAR Support - Enabled
  • IOMMU - Enabled
  • ARI Support - Enabled

I am now looking to see what ports etc. I can disable from the chipset to see if that helps.

  • Windows also running in UEFI mode on a GPT-initialized disk?

  • Boot Options: CSM disabled?

1 Like

Just checked to confirm, yes to both

Any other devices showing errors like Ethernet or wifi

If multiple NVIDIA driver versions have been tested (not only the most recent one) since that Windows version was installed, have you used Display Driver Uninstaller in Safe Mode to completely remove the previous driver before installing the new one?

Nope, it’s just the GPUs

Yup, used DDU with at least two NVIDIA driver versions but get the same results.

What’s more frustrating about this is that I’ve reached out to ASUS through numerous channels, but their customer service is soooo slow.

Just another thought:

Try enabling Windows Kernel isolation (don’t remember the exact name) in Windows’ Security settings. (SVM in the BIOS has to be enabled)

This virtualizes the running operating system itself so there is an additional abstraction layer between the hardware/GPUs and the drivers.

Maybe this can help the communication between the driver and the multiple GPUs (this feature isn’t enabled by default, I have it enabled on Ryzen systems with an NVIDIA RTX 3000 and other ones with AMD GPUs, no issues).

Have you checked if your GPUs maybe have a firmware update available?

I just enabled it, but still no bueno :frowning:

I also tried the latest GPU drivers from Nvidia, no diff.

Made a strange observation myself:

Can’t turn off my ASUS Pro WS X570-ACE systems right now but I am in a constant state of experimenting with an ASRock X570 Taichi Razer Edition.

  • I installed two Radeon VIIs in PCIe x16_1 and PCIe x16_2, both from the CPU (3950X) so they should run at x8/x8 (PSU is a Seasonic TX-1000, so 99.9 % no cause for issues here).

  • Depending on in which GPU I plug in my display when turning the system on I always get a display signal so both GPUs are working

  • But when booting up Windows only one GPU shows up

Strange.

Can you test if you get a display signal on each of your three installed GPUs during POST?

You mentioned a riser – have you tried completely without risers or extensions? Even fallback to pcie3 mode is not necessarily guranteed to be error free with pcie4 devices.

Try setitng everyhting to pcie3 mode across the board and if you can try not to use any risers, extensions or anything like that. straight into motherboard?

that was clearly written when most gpus were pcie gen3.

so an 8x gpu at pciegen3 hanging off of an x4 pciegen4 link is the same bandwidth and this is prety clever of asus.

but with gen4 gpus its like just having an x4 gen4. no magic extra bandwidth
x8x8 x4 for storage x4 for chipset

this is why in my motherboard videos, even for boards that have a good slot layout like the x570ws I am hesitant to even recommend dual gpu vfio with the 3900/5900/3950/5950

I forgot to mention this, but you’re correct. My GPUs all show in the BIOs, but sometimes they don’t show up in Windows…at all or if they show up I get he code 43 error.

this is another symptom of the pcie bus being flooded with pcie bus errors