Return to Level1Techs.com

Unable to activate GNOME screen sharing

After I wrote the post below I tried to run it again and for some reason (and after some battery re-connecting) it booted up again.

Since I usually have no screen attached, I had to remove the files necessary for the headless version. So, I went to /ect/X11 and removed my headless configuration.

Now I have a display again, but desktop sharing is not toggleable. I use GNOME on Manjaro and I’m pretty sure now that the recent GNOME update did this. Any way to make it toggleable again? (by toggleable I mean that I cannot activate it from the GUI. It simply does not respond to my mouseclick).

=============== OLD ===================

I have an old notebook lying on a closet which I normally use as a server for various tasks. In order to issue commands, most of the time I connect via ssh, but sometimes I prefer vnc.

A few days ago I wanted to connect via vnc and notice it wasn’t working. However, I had no problems connecting with ssh. Still, I decided to get it down from the cupboard and plug a monitor into it to re-activate it again. (I assumed it had been turned off for some unknown reason).

Here, it should be mentioned that the battery is really bad and I just keep it plugged in, because at first I tried to power it up without the power cord plugged into the notebook. I was hoping that I maybe had 5min and also hoped that this should be enough. But no powering-up happened. I then plugged the power cord in, but still no reaction. This was about a week ago and the notebook has been plugged in the entire time. But still no reaction when I press the power button.

Is it dead now? Any idea as to why this has happened?

When I try to enable it via gsettings set org.gnome.Vino enabled true it returns No such key "enabled"

Is there some detail missing or does really nobody around here have any idea?

I’ve discovered a solution on the Manjaro forum. Since Upstream considers vino deprecated in of favour of gnome-remote-desktop , I had to install gnome-remote-desktop instead.

To enable gnome-remote-desktop I did the following:

Uninstall vino
Verify that gnome-remote-desktop is installed
Modify /etc/gdm/custom.conf and put WaylandEnable=true in the [daemon] section
Reboot
Enable screen sharing again.

Source: https://forum.manjaro.org/t/gnome-screen-sharing-breaks-in-3-36/131586/11