Return to Level1Techs.com

GNOME VNC black screen with cursor

This thread is a follow-up to this one here:

After getting vnc to work again, I still appear to have an odd issue with it. As the title suggest, whenever I connect I just have a black screen with a cursor, nothing else.
I tried setting [xdmcp] to Enable=true in /etc/gdm/custom.conf but to no avail.
I have this problem with or without a display attached, even though I am sometimes able to connect when a display is attached. Without a display I got an error message stating that the request has been rejected. Which is why I created a 10-headless.conf file in /etc/X11/xorg.conf.d with the following data:

Section "Monitor"
        Identifier "dummy_monitor"
        HorizSync 28.0-80.0
        VertRefresh 48.0-75.0
        Modeline "1366x768" 172.80 1920 2040 2248 2576 1080 1081 1084 1118
EndSection

Section "Device"
        Identifier "dummy_card"
        VideoRam 256000
        Driver "dummy"
EndSection

Section "Screen"
        Identifier "dummy_screen"
        Device "dummy_card"
        Monitor "dummy_monitor"
        SubSection "Display"
        EndSubSection
EndSection

Which also makes me wonder, is this supposed to work under wayland? Executing loginctl show-session 4 -p Type says Type=x11, but my /etc/gdm/custom.conf has the following data:

# GDM configuration storage

[daemon]
AutomaticLogin=alex
AutomaticLoginEnable=True
# Uncoment the line below to force the login screen to use Xorg
WaylandEnable=true

[security]

[xdmcp]
Enable=true

[chooser]

[debug]
# Uncomment the line below to turn on debugging
#Enable=true

So, I’m a little bit lost here and any help would be appreciated.