Return to Level1Techs.com

Thunderbolt User General Help Area

Hi,

the last two videos from @wendell have convinced me that there is the need for a more general Thunderbolt-related hardware thread.

My first pearls of wisdom regarding the latest Windows 10 versions (works fine with 20H2 and 21H1) and X570 and B550 motherboards with Thunderbolt 3 (unkown Titan Ridge revision) and Thunderbolt 4 (Maple Ridge).

Basic Thunderbolt etiquette:
(AMD UEFI terminology)

  • DON’T LET WINDOWS GET TO THE INTERNET
  • UEFI: Enable SVM, IOMMU and DMA protection
  • Thunderbolt motherboard UEFI security option: “User Authentication”
  • UEFI: Disable CSM
  • UEFI: Enable Secure Booting
  • Install Windows in UEFI-only mode on GPT-initialized drive
  • (On another computer) Download the latest Thunderbolt drivers from Intel
  • Decompress the driver folders
  • Manually install (right-click on them) all the .inf files from the decompressed folders
  • Reboot the system
  • Connect to the Internet, Windows will get the Thunderbolt management software from the Microsoft Store

Stuff I don’t know about myself:

  1. Can you find out the exact Thunderbolt 3 Titan Ridge hardware revision in Windows? If not, what’s the exact way to do this under Linux?

  2. Is there a clean way of updating Thunderbolt firmwares if the motherboard or AIC manufacturer is unwilling?

(Some new (?) security issues have appeared that require firmware updates)

2 Likes

Product recommendation for an external PCIe box with Thunderbolt 3 Titan Ridge chipset (no additional features like USB hubs etc.).

Successfully tested it with GPUs, HBAs, ethernet adapters, HDMI capture cards, NVMe SSDs…

OWC AkiTiO Node Titan: AkiTiO Node Titan - OWC Digital

Personally have used the Sonnet boxes and they work when they work. My first unit was a dud, not correctly detecting the sense pin of a Thunderbolt 2 to 3 adapter. But after that was resolved, it was smooth sailing.

Any people here with firmware update “conneggtions”?

For example Gigabyte with their GC-Titan Ridge (DSL7540) only offers version 50 with their “latest” firmware update package - while the listed issues require version 60 or later to be addressed :frowning:

I honestly wonder how many Thunderbolt issues would have been resolved by now if users would be able to get the firmware directly from Intel the same way you can with ethernet adapters with Intel chipsets*.

(*Only if a certain manufacturer doesn’t deploy a finished product with the chipset in debug mode…)

1 Like

I snipped this PowerShell command and guide a little while ago:
image

fun fact they say the razer core isnt supported by the m1 macs yet i used mine as a pcie ssd add on and usb hub LMAO

I have a Saturn Mantiz plugged into the M1. It has Ethernet, SATA slot and USB ports. Everything works and its recognized. I think the main issue is the lack of drivers for complex stuff like GPUs.

1 Like

Ethernet, SATA, and USB can all hang off a USB controller – and could represent the Thunderbolt simply routing all USB traffic through the same USB 3.2 Gen 2 10Gbps hub chipset – which is part of the Intel Titan Ridge Thunderbolt 3 reference design that many devices employ and which allows USB backward compatibility (e.g. the Plugable TBT3-UDZ dock.)
However, this scenario, while it will ‘work’, performance-wise it won’t exceed the 10Mbps capabilities of USB 3.2 Gen 2.

What do you mean PCIe SSD? Do you mean you put, say, a PCIe to NVMe card (something like this)in the Razer Core PCIe slot and it connected as a drive on the M1 MacOS (and tested out at NVMe speeds?)

That would be promising – and a sign that the M1 isn’t having problems with the PCIe I/O capabilities end. But, if you’re somehow just hanging an SSD off a USB 3.2 Gen 2 connection, at USB 3.2 Gen 2 (10Gbps) performance levels, it’d be less promising.

@jeverett

These model numbers are unfortunately “just” the general devices’ identifiers, there can be several hardware revisions of the 15EB for Titan Ridge Thunderbolt 3, for example something like 15EB.1, 15EB.2 or 15EB.3 - but no way for a customer to see these details.

My gut says this is because Intel doesn’t want to publicly acknowledge these fixes in hardware revisions to avoid justified customer complaints.
(No way for you to document that you got an older, more faulty revision)

But at least some nice findings:

  • ASUS switched from 5-pin to 13-pin motherboard headers for Thunderbolt 4.

This lead to speculation that maybe Thunderbolt 4 needs these additional pins requiring you to purchase new motherboards to be able to use Thunderbolt 4 (or to just be on the safe side to be able to get the latest hardware revision since Intel is so intransparent)

  • Gigabyte still uses a 5-pin cable for their GC-Maple Ridge Thunderbolt 4 AIC so there might be an easy drop-in upgrade path for existing X570 motherboards like the ASRock X570 Taichi :slight_smile:

Will test that as soon as the GC-Maple Ridge AICs become available in Germany.

m.2 → pcie adapter


fusion-io ioscale 2 1.65tb
image
wd black nvme 1tb
the pcie adapter was speed dependent on the drive
wd black i get the advertised 6gb/s
fusion-io i get 1.5gb/s r 1gb/s w
in the razer core i used crystal disk mark

all the issues ive had with things on thunderbolt hooked to the razer core v1 are based in driver for the device slotted in not that the core could not offer connectivity at correct speeds

this allowed me to use the hub and have a external eth sadly wi wish it had a second tb3 port for daisy chaining … might just keep it at the end of the chain then

the fiber 4gb/s card apple sends out for the old xserve raid san kernal panicked the m1 mini and caused a reboot loop till the device was removed

to use the fusion io card i needed to run windows/linux and load the sandisk drivers

mac os dropped a cpu instruction support that killed the drive on modern mac os but still very useful for linux and networked devices

i am waiting for my owc tb4 hub to ship should be mid late aug when that comes

i hope i can get them to work in my mac pro from 2009

i can get the titan ridge v2 card to take mac firmware (had to surface mount clip to flash)

basically keeps my old mac pro kicking still slower then my m1 tho

You are right the ethernet is under the USB hub that is connected to the thunderbolt 3 system. I need to test with the SATA and PCI-E cards to confirm but I see no reason proper Thunderbolt is not working considering the device tree:

Thunderbolt/USB4 Bus 0:

  Vendor Name:	Apple Inc.
  Device Name:	MacBook Pro
  UID:	0x[REDACTED]
  Route String:	0
  Domain UUID:	[REDACTED]
  Port:
  Status:	Device connected
  Link Status:	0x2
  Speed:	Up to 40 Gb/s x1
  Current Link Width:	0x2
  Receptacle:	1

TBX-750FA:

  Vendor Name:	TUL
  Device Name:	TBX-750FA
  Mode:	Thunderbolt 3
  Device ID:	0x501D
  Vendor ID:	0x168
  Device Revision:	0x1
  UID:	0x[REDACTED]
  Route String:	1
  Firmware Version:	44.1
  Port (Upstream):
  Status:	Device connected
  Link Status:	0x2
  Speed:	Up to 40 Gb/s x1
  Current Link Width:	0x2
  Link Controller Firmware Version:	0.40.0
  Port:
  Status:	Device connected
  Link Status:	0x2
  Speed:	Up to 40 Gb/s x1
  Current Link Width:	0x2
  Link Controller Firmware Version:	0.40.0

TBX-750FA:

  Vendor Name:	TUL
  Device Name:	TBX-750FA
  Mode:	Thunderbolt 3
  Device ID:	0x501E
  Vendor ID:	0x168
  Device Revision:	0x1
  UID:	0x[REDACTED]
  Route String:	301
  Firmware Version:	20.1
  Port (Upstream):
  Status:	Device connected
  Link Status:	0x2
  Speed:	Up to 40 Gb/s x1
  Current Link Width:	0x2
  Link Controller Firmware Version:	0.31.0

If I’m not mistaken Hector Martin’s (Marcan) work on his Asahi Linux and hypervisor project shows that the issue is lack of drivers and not PCI-E capabilities like some people theorized.

1 Like

My eye is twitching, and I’m having flashbacks to the Dell XPS 15 9550 I had which had a Thunderbolt 3 port that didn’t work with the Apple TB3-TB2 Adapter – even though my Intel NUC6i7KYK and Asus ThunderboltEX 3 worked fine with it.
Dell enterprise support merely said, “sorry, it isn’t compatible” – and I spent endless hours searching for firmware updates, release notes, or any sort of insight into what the actual hardware problem was that made Thunderbolt® hardware incompatible with Thunderbolt® hardware.
I had no luck, of course, and the worst was the official Intel online support forum washing their hands of any Thunderbolt support, and just pawning me off to the OEM (who stonewalled me.)

I always wondered if maybe all the hidden Thunderbolt answers are hidden behind the login of the Thunderbolt Developers section.

Imagine if Thunderbolt technical details – like pin outs, etc. – were actually published and people didn’t have to speculate and experiment…

… maybe that’s behind the developers door too.

I bought a Gigabyte WRX80-SU8-IPMI and a GC-Maple Ridge hoping to make a Threadripper Pro Thunderbolt 4 build. Initial word doesn’t seem too good:

When I finish my build I guess I’ll be able to test it out myself, and if worst comes to worst can fall back to the GC-Titan Ridge that Wendel used successfully.

Hmmm,
Get-PnpDevice -Class 'System' -FriendlyName 'Thunderbolt*' |fl
will give some additional PCI details, like this identifier for the Asus ThunderboltEX 3 in my current system:
PCI\VEN_8086&DEV_1577&SUBSYS_11112222&REV_00
I don’t know if SUBSYS and REV offer any good info through.

Looking in the files of Thunderbolt firmware upgrades, you can sometimes see hardware distinctions referenced, e.g. this from the TbtFwUpdate.exe.config file of the Asus ThunderboltEX 3 TbtFwUpdate_1.0.0.15_release

 <ChipGroup>
    <ChipSection>
      <ChipList>
        <Chip srcFwName="chip1_Fw.dat" vid="8086" pid="1577" targetNVMVersion="18" />
        <Chip srcFwName="chip2_Fw.dat" vid="8086" pid="15D2" targetNVMVersion="26" />
      </ChipList>
    </ChipSection>
  </ChipGroup>

Likewise, the pre-UWD Thunderbolt driver updates typically came with somewhat informative “Release Notes.txt” files:

Thunderbolt(TM) Software Release Notes
======================================
This document is the release notes for the Thunderbolt software version 17.4.77.400


Supported Operating Systems
===========================
  Windows* 10  64-bit

Windows Update references:
- RS3: shared product ID 1152921504607502549, submission ID 1152921504627611457
- RS4: shared product ID 1152921504607517008, submission ID 1152921504627695591
	
Supported Thunderbolt Controllers
=================================
  DSL6540/6340  Series - "Alpine Ridge"  
  JHL6540/6340  Series - "Alpine Ridge"  
  JHL6240       Series - "Alpine Ridge LP" 
  JHL7540/7340  Series - "Titan Ridge"     

Changes:
========
Version 17.4.77.400
  - Hotfix: Race condition between SW and FW while entering RTD3 and a device is connected at the same time (see fixed issue #2202117254)

Version 17.4.76.300
  - Toast message on device connection changed to "New Thunderbolt™ device has been connected. Click here to approve the device." 
    The notification time has been extended to remain around 25 seconds at the minimum.
  - Fixed MUP errors popped up with CVT2.0.1

Version 17.4.75.250
  - Implements RTD3 RCR:
    * When the platform is RTD3 capable (BIOS & FW) the driver will enable it automatically on each driver load.
      It would be reflected on the Thunderbolt controller Power Management tab. 
    * Changed FW Update SDK accordingly to expose RTD3 capability (including SDK API, documentation and sample)       
  - Fixed potential Bugcheck when resuming from Sx while Thunderbolt networking connection is active (see fixed issue #1604754624)
  - Fixed another corner case addressing issue #1604629561
  ....

Beyond that, it seems like Thunderbolt is like an intentionally dark technical area.

That’s great news. Thanks for the info.

Have you looked at the Sonnet Echo 11 Thunderbolt 4 hub? They released a “compatibility matrix” showing Thunderbolt 4 functional compatiblility with other Thunderbolt chipsets/OS, although I’m not sure exactly what it all means (and what in the matrix lines up with what.):
https://www.sonnettech.com/support/downloads/manuals/Thunderbolt_4_Dock_Compatiblity.pdf

1 Like

Sonnet hub isn’t really what im looking for i just need to take 1tb4 and turn it into 3 down 1 up streamtb4 ports and a usb type a

Though i would trust sonnet for matrix info

@jeverett Are you sure Wendell used a GC Alpine Ridge with the GIGABYTE WRX80-SU8-IPMI? I’m close to buying the board but I want to use my GC Titan Ridge AIC. There’s a guy at reddit which had a pretty terrible experience with Thunderbolt and that Board.

Sorry, my mistake – Thanks for the correction! I get Alpine and Titan mixed up. I corrected it above. Here’s Wendel’s video for reference:

Gigabyte WRX80 Threadripper PRO - FINALLY Thunderbolt! - Motherboard Review

I admit I thought the Secure Boot requirement Wendell mentioned seemed odd. I use Thunderbolt on my Thunderbolt 3 MacBook Pro without having secure boot enabled, so that’s not a baked in Thunderbolt 3 requirement. Does even Thunderbolt 4 require secure boot? I thought its new security was VT-d based.
(I do think some of the form factor/layout complaints of this board related to trying to shove 2-3 slot air-cooled GPUs are a bit off. There’s ways to have multiple GPUs in a workstation and it’s not with multi-slot GPU air coolers.)

I already bought a WRX80-SU8-IPMI and a GC-Maple Ridge (but not the rest of the build) and it’s past return time on the motherboard for me, so I guess I’ll have to give it a shot. I won’t cry too much if the Maple Ridge card doesn’t work (when its not yet included as an option in BIOS), and I have to fall back to Titan Ridge. When it comes to Thunderbolt 4 features, I don’t care too much about DMA attack protection on a non-mobile device which will be protected by my office’s physical security. I’m also not counting any unhatched chickens on how great the Thunderbolt 4 hub/multi-port feature will be (it’s still shared bandwidth and I’ve heard that eGPU will still need to be first in chain and won’t be good behind a TB4 hub.) So, working TB3 will probably be OK. It would be nice, however, to know exact BIOS setting requirement/limits and any incompatibilities between the BMC VGA/GPUs/Thunderbolt cards.