Return to Level1Techs.com

New build Gigabyte WRX80 + TR Pro 3955WX + Titan Ridge v2.0 problems

So I have it as Titan Ridge type and I enabled the other types. I have also enabled the L1SS along with boot with USB. The remote wake is set to the second setting (I don’t remember the name of it) and I have is as Native compatibility.

Maybe do some screenshots and I’ll compare. What’s it look like in device manager? The other person that had issues I did a screenshare so I could poke at it. … been doing a lot with thunderbolt for many years and doing stuff maybe as a poor man’s fabric…anyway we got his stuff working after a lot of teeth gnashing and it was mostly onboard vga and resource sharing. It’s in the x8 slot right? Try it in the top of second to top slot. Those are different root ports on the CPU

So in the beginning, I was getting errors in the Device Manager. Somehow the drivers were not properly installed on device attachment. Those went away after a while. I did not do any tweaking since I did not know what to do. Right now, device manager has no errors. I do have it in the second slot (x8) and that is also in the BIOS. I have not tried the top slot but I have a RTX 3090 in there and it is taking up three of the slots

Swap that around and report back pls :slight_smile:

The larger XL type cases with the 3090 in the bottom. That’s really the way to go

Ok, will do. I have the fractal design XL 7 case so it should work fine.

So I switched the components. After restart I got my devices recognized but if I add a portable TB drive, it does not. Also do you still recommend the legacy drivers for the TB or DCH?

No can use modern ones on this board without issue

Hello again. I guess I will stick with the Gigabyte MB and keep working on this TB issue. Do you know if TB4 Maple Ridge card works with the Gigabyte WRX80 board?

Thank you Tived. I have watched those videos and followed his advice. My system is not behaving as far as TB goes. Maybe I have a bad board, don’t know. Still working on it though.

1 Like

I hsvent tried Maple ridge but I’ll trade you my Titan ridge that worked for the peripherals I have if you want. Is that the controller you have? Is it set for Titan?

1 Like

I have both the Titan and Maple right now. I put in the Maple Ridge but in the BIOS the chipset is not available to choose.

On boot, the motherboard hangs on AA code and does not fully post when the Maple Ridge is installed. Also I think there is a massive USB issue with thunderbolt. Each time I restart, I have to goto the Device Manager and refresh new hardware for my TB drives to activate. Do you know any issues with USB and TB?

So refresh in dev manager is maybe not the right d3/hot setting.

Did you try moving the slots around? Any change in post code or behavior?

Today I will move it to another PCIe slot and see if the BIOS posts properly. It has a five pin header just like TItan Ridge. Also the Gigabyte MB only has one USB2.0 header which does not allow for checking possible header issues.

What do you think about USB matters in regards to TB?

Another interesting thing that happens is with the Apollo 8 UAD 2 thunderbolt; the device is initially seen by the TB card and you can see it on TB Control Center. After I refresh dev manager, I get the official connect since it is daisy chained to the Pegasus drive. I can goto the Consul for UAD and see that it is connected but I cannot choose the Apollo for sound output. It is not even listed.

By the way I installed Maple Ridge and got the bios to post. It wants PCIe Tunneling enabled in the bios. I am not sure what that is and where to look for it…

Not sure, myself, although am interested in your efforts as I was interested in a similar setup. However, if I were guessing, PCIe Tunneling might refer to how Thunderbolt 4 requires Intel’s Virtualization Technology for Directed I/O (VT-d) to protects against DMA attacks, like Thunderspy. On AMD, I believe that going to be called IOMMU. However, I don’t see any enable/disable toggle for that in the online BIOS manual. Closest things I see are:

CPU Configuration
& SVM Mode
Enables or disables the CPU Virtualization Technology. (Default: Enabled)

PCI Subsystem Settings
& SR-IOV Support
If system has SR-IOV capable PCIe devices, this option enables or disables single root IO Virtualization
support. (Default: Disabled)

Maybe those are relevant, although it may be just be a non-starter without specific BIOS support for Maple Ridge/Thunderbolt 4 chipsets.

Which firmware version are you using? Roll back to F3 if you’re on F4. They dropped some functionality with TB3 on F4 for some reason - I pointed that out to the Gigabyte team so they’ll likely bring it back in F5.

Sounds like you are using F4? Or did you set the BIOS to Native under the TB settings instead of Native + RT3 Cold? The Cold setting will get around having to refresh the Devince Mgr.

Universal Audio on a Windows box? Ugh… pure sh!t. You’ll have no end of headaches. RME or similar my friend.

I just tested the Gigabyte Maple Ridge v1.0 Thunderbolt AIC with my Lenovo ThinkStation P620. The Thunderbolt Control Center says PCIe tunneling is disabled and to enable it in the BIOS on my system as well. I saw in a presentation from Microsoft that Thunderbolt 4 requires Kernel DMA protection (IOMMU and DMA remapping) firmware support to be usable in Windows. My workstation does not have this support. The “GetControllerInfo” command from the Thunderbolt SDK says the controller is configured with “Security Level 5” which I believe to be a new security level with Maple Ridge to require Kernel DMA protection. Your system might not have Kernel DMA protection for Thunderbolt support either. Kernel DMA protection requires much more than just having the IOMMU enabled.

1 Like