Return to Level1Techs.com

[SOLVED] Ryzen build freezing, can't find the problem

Edit 1: RMA’d the board and just received the replacement yesterday. Reinstalled everything and it’s working perfectly for now. If anything changes, I’ll come back and update this post.

Edit 2, 01/21/18: It’s been about a week and a half and no more freezes or crashes. The chip is stable at 3.7/1.225V. So looks like the RMA did the trick. Best of luck to anyone else with the same issue!

Edit 3, 04/01/2018 (Final): This definitely fixed the issue. Haven’t had a single crash or other issue since getting the new board. Not sure what they changed, but it worked. Actually upgraded her chip to a Ryzen 1600X, OC’d at 3.8GHz, completely stable.

I recently built an entry level gaming PC for my daughter. I’m using a Ryzen 3 1200 chip and an Asrock AB350M Pro4 motherboard - I’ll list all parts below. The issue I’m having is frequent system freezes that completely lock the PC up, requiring a hard reboot. I’ve googled and asked around on reddit, but haven’t found anything that works.

CPU: Ryzen 3 1200 (updated chipset drivers using the AMD utility)
Motherboard Asrock AB350M Pro4 (bios version 3.30)
RAM HyperX DDR4 2400 RAM, 2x4GB - model HX424C15FBK2/8
SSD Samsung 850EVO 250GB w/ Windows 10 Home, fresh install
HDD WD Blue 2TB
GPU EVGA 1050 ti
PSU Cooler Master Elite V2 550W

New build, overclocked in BIOS to 3.6 at 1.200 volts, but this issue is happening running at stock speeds as well. Passes Prime95, AIDA64, Furmark, Cinebench, and Memtest without stability issues or overheating - has never frozen up during stress tests. But during use (both gaming and just regular browsing/YouTube) it randomly freezes up. Can’t get past 2-3 hours without it happening, have to hit the reset button on the front of the case. Occasionally will black screen with CPU fan going full speed, but this has only happened a couple of times

Done in attempt to diagnose or fix the problem: Ran Memtest from a flash drive for 9 passes, zero errors. Stress tested with the above mentioned programs for about 2 hours each, zero problems. Updated BIOS, chipset drivers. Reset CMOS. Erased both drives and reinstalled Windows fresh - twice. Turned off Cool n Quiet and C-states in the BIOS. Cleared virtual memory and set it to 12GB (1.5 times my RAM amount, per an online recommendation.)

Only thing I’ve found is the RAM I bought isn’t on the QVL on Asrock’s website, but I’ve never found this to be an issue on other builds. I’ve heard Ryzen can be finicky about memory, but it seems like this would have caused an issue during Memtest?

Hoping you guys have suggestions. I’m ready to call it a $200 loss and switch over to Intel :frowning_face: .

Just edit the title to say (solved) in front.

Definitely the motherboard, I’ve seen these issues pop up all over with people running the ASrock AB350 since it’s a cheap and popular board. I’ve stopped recommending it in builds for now.

Agreed. I had issues with its larger brother. Also decided to upgrade to the Killer X370 and it died after two days. Still waiting on replacement. Went with the Killer cause I got it for $20 CAD more, so $110 CAD. Great deal for an X370, but ASRock is not making me feel all warm and fuzzy. This build is my first hands on experience with ASRock.

So if I RMA the board, is the new one likely to start doing this as well? I know it’s an inexpensive board, but it’s in my 12 yr old’s PC, so I didn’t want to spend too much. That being said, I want the damn thing to work.

I don’t know, I would assume ASRock is aware of the problem at this point and what is causing it. Either way I would RMA the board and hope the new one doesn’t have the same problem.

It sounds to me It might be a heat problem. What is the name and model number of the case. You might want to check if the case is known to have poor airflow. My desktop got completely destroyed about a year ago by excessive heat (didn’t have enough fans in case) , than a huge power spike, because I was too cheap to buy a Unintorable Power Supply

^^ As a note to others regarding state of this thread.

And to once again state that such information is useful to others and thus one should not delete ones post after finding the solution, but rather document your steps towards solving the problem as best as you can for others to learn from. :slight_smile:

PS: Level1Techs forum ranks quite high on google search results these days. So a lot of people looking for a problem often come across our forum.

4 Likes

That’s a good point. Once I get the new board in and see if it solves the issue, I’ll come back and add an edit to let people know (I know it’s flagged as solved, but I figure the update would be helpful, as well.)

2 Likes

I have a feeling it doesn’t affect all these boards, but ASrock might just have quality issue where some boards are passing testing, but shouldn’t be. I’ve done stress testing on the CPU, GPU, and RAM for several days and no issues with the new board after the RMA.

please update with any resolve I have same board and cpu,
the long and thick of it is, my z270 i7 7700k build was tripping my d6 error code for gpu issues, got a new gpu and same thing (nothing like what I’m dealing with now) so as I sent that one back. I had the asrock ab350m pro4 and ryzen 1200 sitting around for another build. so I threw my g3 supernova 850w psu, gtx1080ftw hybrid, cooler and ssd and dominator platinum corsair 3000mhz ram and went to town. worked for all of 2 to 3 weeks. then HARD FREEZES, once in a while a black screen, sometimes it restarts. did all the same tests and fresh installs and everything to no resolve.

sounds like the board has issues RMA might fix it. using the 2nd agesa update might have broken it . so going back a bios version could help but make you miss a few changes. honestly just taking a stab in the dark.

Just got the new board back yesterday. After reinstalling everything, the system is working fine. Hopefully this fixed it. If the problems start again, I’ll re-update this post.

Good luck with yours!

Lol I just replaced the same board with a MSI B350M gaming pro for a friend’s build because of the same issue!

Thank god for amazon extended returns.

1 Like

Lucky you! I’m just crossing my fingers that this board doesn’t develop the same issue. I’m not updating the BIOS or anything for a few weeks to see if it settles in ok.

Any updates on this?

Yes, actually need to update the post. The new board is rock solid, haven’t had a hiccup since.

2 Likes

Thanks for providing an update on the issue! :smiley:
We always appreciate it when others share their experience and resolution with the community so others that come across it can benefit as well.

As part of this I have cleaned up your original post to make it a bit more readable. I hope you don’t mind.

1 Like

I appreciate it, actually. I’m pretty new here, and I’m not used to the formatting yet. Hopefully the post helps someone else out!

There is a bug that affects 1st Gen Ryzen CPUs that causes them to lock/reboot when reactivating powered-down cores that have been idling. This thread is well worth reading: https://community.amd.com/thread/225795