Small windows problems thread

About 2 weeks out, I figured I’d give an update…

The past few reboots have worked perfectly: logging in immediately lands me on the desktop with no delay. I didn’t reinstall Windows yet, but there was a Windows update since I was initially having this problem which may have been part of the ‘fix’. Not sure.

If this continues to work correctly over the course of the next few times I have to reboot I’m going to call it good and start prepping my 2nd drive for Arch - otherwise I’ll be using it as data backup while I do another Windows reinstall. :slight_smile:

Hello everyone.

I have a Dell XPS 15 9570 and I can’t find a way to force Windows 11 Pro to use the dGPU. In fact, in the NVIDIA control panel I already have everything selected for it to use it. However, there is no way. Whenever I hit “Apply” it just resets. I am attaching a picture.

Any other way to get it to use the dGPU, am I doing something wrong?

Thanks for the help.

You’re on the configuration for PhysX, which is a physics simulation engine for games.
And as pointed to by the arrow, it’s already running on the dGPU, the monitor is just connected to the iGPU because that’s just how laptops work.

When you run a game it will probably already run on the dGPU anyway because that’s how the driver is set up by default.

1 Like

Oh, right. Thank you very much! Would there be a significant improvement if the monitor was connected to the dGPU? If so, any other way to force it to use it? Frequently, just minimizing or maximizing windows costs it. Something that has never happened to me… Also, it barely -if ever- uses the dGPU. I don’t play video games on this laptop, for what it’s worth.

No.

The monitor is physically connected to the iGPU, there’s no way to force anything there.
That’s just how laptops work. It’s a cable from the iGPUs output pins to the panel.
The nvidia driver used to have a setting to always render everything on the dGPU, but I don’t know if it’s still there or where it is. I haven’t used a Laptop in years.
I don’t really get why you’d even want to force the dGPU tho. All it would do is eat more power and drain the battery and/or produce heat for no reason.

I don’t get why you want to force the dGPU then?

I understand, I still have a lot to learn… Thank you very much for the feedback.

Simply because lately the performance is not very good… And I thought it might be because W11 was not making use of the dGPU. Until a month ago I had been running Linux for about a year and I had disabled the dGPU so it wouldn’t give problems. From what you say, it seems to be due to some problem with the drivers… Any way to check if I have all the system drivers updated? Not only those of the graphics card, I mean.

Thank you very much for your help.

EDIT: used this software to search for drivers’ updates Snappy Driver Installer. Do you think is enough?

Never heard of it so I couldn’t say.

Generally device drivers are distributed via Windows Update so you don’t really need to check anything there. The only reason it’s recommended to update Graphics drivers manually is for game-specific fixes and optimisation in the drivers. But since you don’t seem to play, that has no relevance.

As for the performance issues, it could just be Windows 11 weirdness because W11 is even more of a mess then W10 was at launch. Can’t really help you with that though as I haven’t booted into Windows in like 2 years.

Just need to know what makes a wim valid for setup.exe. standard install.wim or a custom sysprep’d wim is fine.
Trying to have most of the installation files already on the disk before setup starts. Before making the disk image too unique for block level deduplication. Just need setup to add the bare minimun to the existing disk image and do the hardware registry witchcraft and bcd entries. Again I’m not trying to strip a wim down to nothing, I’m trying to split most of it to the disk in advance.

Super niche use case setup.exe has to run. Period. Microsoft doesn’t support this particular use case but the L1T community might know a trick or two. Thanks in advance.

I am having (and have been having for a long time) a minor and mildly annoying issue. my “committed” ram climbs up to obscene levels
image

pic related.

as you can see here, I am only using about 8 gigs currently, but that is because I closed chrome and repened it to only the L1 website.

Even afer closing all foreground applications, and waiting a few minutes, my commit charge is running up to almost 80 gigs. Yet acually used ram is still very low. Is this just a shitty part of windows memory management that I can do nothing about?

Solidworks complains because “your computer is low on ram” and I find the popups annoying. I would like a better way to “Flush” pages out of ram without restarting my computer

Does something on my PC have a memory leak and keeps asking for more pages?

Might want to look into rammap. It was a systernals app from back in the day but ms bought them up a while ago.

My $0.02 fwiw!!!

Hope this is the right place… Built a new 11900K system with a 3080, 32 gigs of Dominator platinum.

On occasion when I zip files up with v21 or v19 of 7Zip or Peazip, I get a BSOD with CLOCK_WATCHDOG_TIMEOUT. Looking at the dump logs I see intelppm.sys as the issue. I reinstalled this “driver” and nothing changes. There is no newer version of it.

I have tested my ram and stressed my PC with every stress/testing program out there and RAM and CPU test fine.

How do I get rid of this issue?

That’s always fun trying to troubleshoot BSODs on new builds when you don’t have a baseline yet. Usually I just start with the assumption that it’s a hardware problem and work through to eliminate possibilities/components. Unless you can get the system to BSOD on-demand it’s likely going to take a while to narrow down the problem. As for intelppm.sys (Intel Processor Power Managment) it allows Windows to manage the CPU’s power budget through Power Plans. So I’d start with focusing on the CPU and motherboard. I’m not sure what you’ve tried already but this would be my troubleshooting order:

  • Update BIOS to the latest revision and install the newest Intel chipset driver package directly from Intel’s website
  • Reseat your CPU
  • Disable Fast Boot in UEFI Setup
  • Change your Windows Power Plan. If it was on Balanced change to Perforamance and vice versa. I’d do this just to see if it makes a difference.

And if none of those steps worked then I’d strip the system down to a minimal state and try to trigger a BSOD again. Then you at least know what’s -not- the problem.

  • Disable XMP
  • Remove all but 1 memory module
  • Pull 3080 and run off the iGPU
  • Remove all drives except your OS
  • Disconnect all RGB and USB headers from the MB

And lastly I’d try a clean install of Windows.

Best of luck!

1 Like

Its funny cause I do everything on this PC including gaming. I can zip/unzip stuff for hours w/o issues the once in a blue moon I get a BSOD only when zipping files.

I did 90% of the stuff you listed but some things are tough because I work from home and cannot have my PC down for very long…

BTW, how do I find the latest Intel driver? The current one is from MS but I saw someone mention there is a Intel and a MS driver, but didn’t mention where to get it.

Ahh, I was under the impression this was a brand new build. Maybe go a different route with testing then. Phoronix test suite can do a 7zip compression benchmark or stress test. It actually uses 7zip binaries so it’s probably your best chance to trigger a BSOD on-demand. If you can get consistent crashes in Windows then you could try running Phoronix under Linux (might install and work in a live session?) to see if you get a kernel panic or lockup there too. That would at least rule out it being a software issue.

Easiest way would be Intel’s update utility. Install, check for updates, then uninstall.

Oh I used their utility and nothing came up… But I would like to switch the .sys file from the MS version to the Intel version.

It is a new build but its been in use for about a month…

I will try that software to test… So far I tried AIDA64, Memtest64 and x86 and nothing triggered anything… stressed the cache, CPU and ram

check to see if hpet is enabled. if not enable it (bios/eufi). it might be that the app your using wants a hardware clock that isnt available so is causing a bsod when its requested.

then run sfc/scannow
then run dism
DISM /Online /Cleanup-Image /ScanHealth
DISM /Online /Cleanup-Image /RestoreHealth (can have a long pause while scanning so let it finish)

this will clean any error’s in your o.s that may also be causing the bsod.

if you find lots of errors in the o.s. then i would suggest you look into your ram timings.
they may appear stable, but could be writing bad data back to the o.s. causing it to eventually bawk.

SFC /scannow doesn’t find anything… Still suggest running DISM regardless?

1 Like

I’ll check hpet when I’m not working

likely no need to run dism then :wink:

as you know the app is whats causing the crash.
enable hpet and see if it crashes again. if no crash then you likely have your solve.
if not then looking on the web it can be caused by lots of things.
from unstable ram to bad drivers.
in which case looking through the logs for other errors might help you pinpoint the issue.