Return to Level1Techs.com

Odd Corsair PSU Glitch? Relay kept clicking and LEDs flickered

Hi all -

I just experienced something really strange on my Threadripper box. I’m running an AX860i Corsair and the PC was off for about a day or so.

Powered it on, and it seemed to start fine. But then I got distracted with something on my other workstation, then noticed it had shutdown.

Second time powered it on, and the PSU relay kept clicking - on/off/on/off and the Gigabyte X399 LEDs would appear, turn off, appear turn off. There was a strange flickering sensation to it.

I then moved the power plug to a different socket on my APC surge protector; second time around same thing. I killed it was the PSU switch each time.

Third time - booted up fine and I’m SSH’d into Fedora right now.

Super strange… not seen this before for sure. Thoughts?

Sounds like the inrush current of the powerstages triggers overcurrent protection on the PSU.
It is not harmful to any component, just the OCP beeing stupid as a brick.

1 Like

That makes sense, hmm. Seems this OCP “issue” is sort of common - http://forum.corsair.com/v3/showthread.php?t=149802

I haven’t changed the rail settings, although I should check on that. Need to install WIn10 on the TR4 box first.

This is totally weird now. I had the box run for 3-days straight, no issues. Just switched out the RAM and installed 2x kits of Dominator Plats. Booted up several times, and spent about 40 mins in Fedora 26 (Gnome).

XMP applied automatically and the RAM was running beautifully at 3200 MT/s.

Then… it suddenly shut off with the relay going ‘click’. So I tried to power it back up, OCP loop. tried again. Same thing
again. same.
again. same.

Scratching my head now. Each time, I turned the power off at the PSU as well. Letting it sit for about 20 mins before I try again.

Depending on how the current sensing circuit is done, there may be some IC failing open circuit meaning the relay opens up killing the system. Time to replace the PSU.

Luckily I have another brand new AX860i (For another build). This PSU isn’t that old either, got it back in Nov 2016. I’ll swap them out and see if that helps.

Seems I’m really not alone here - http://forum.corsair.com/forums/showpost.php?p=913788&postcount=40

Having left my box off for about 20 mins, it booted up fine. Back in Fedora. It ran for a similar duration as the last time and then just shut itself off again.

This certainly isolated short-circuit protection, so I’m leaning towards OCP (over-current protection) and as you said, an iffy IC or my AX860i being overly sensitive.

I’ve ordered another HX1000i, but I will try my second AX860i as well later this week.

Could an unstable RAM OC cause random shutdowns? I had trouble keeping it running at 3200MT/s, but now dropped it to 2933MT/s.

I found that at stock 2133MT/s the shutdown issue went away…