Gaming, on my Tesla, more likely than you think

That is a problem with the video card memory mapping in the motherboard or I’m pretty sure that’s the problem. I’m no expert at this as i only started playing with these type of video cards a few months back. I think you left a full rig layout and items installed in another post, but would be best to refresh everyones memory so we can better help. Another thing I have found out with my playing around with these type of cards is not all are equal. Some I have personally messed with had to have a modded vbios made for them to work in older motherboards such as x58 chipset MB. The 2x K20 I have has K20m clearly posted on the top.
Don’t quote me on this as I do not know for sure but some don’t have the M? if that is the case it could be a 64bit BAR only video card. This I can’t say for sure as both of mine ran in a 32BIT BAR right out of the box in a x58 MB. I’m mostly thinking out loud so I could also be way off base with my thoughts here.

Edit: If its a newer motherboard and the card needs 64bit bar you’ll need to look in the MB bios to see if Above 4G is enabled.

I was running an “ancient” Intel second-gen system. I am now upgrading to ryzen 2. I will update you after the new motherboard and CPU arrive.

On an older MB “if the card is looking for 32bit bar” you can try disabling Lan, com ports and other things in the MB bios to see if it will free up enough resources to let the video card work.

I upgraded my system to:
A Ryzen5 2600 & b350 MB

My primary GPU is a GTX 1060(plugged into PCI-E 3.0x4). The Tesla K20 is plugged into the PCI-E x16 Slot on the MB. I did a fresh install of Windows 11, Disabled the auto driver update in DDU. I installed the GTX 1060 Driver first(and restarted). After that, I installed the Tesla Driver(and Restarted).
I’m still getting errors in the Device Manager:


After restarting nothing changes. Here is the error I get while trying Nvidia-smi:

Check your HDD format it must be GPT. You can check with disk management in Windows.
Be sure the “above 4G decoding” is enabled in MB bios?
The reason the 1060 isn’t working is because of the Tesla driver.

My drive is GPT & above 4G decoding is enabled. Without it, the system won’t boot.

Seems there was something else in MB bios that had to be enabled on some boards, but it has been a while ago I watched those videos and I just don’t remember.
Also, you can try disabling the 1060 in the device manager. Again disabling in bios anything not in use such as Lan network “use Wifi if you have” com ports and anything using resources.
I had one rig I was having problems be as simple as disabling the video out card then it allowed the other to set up, then re-enabling the video out card it took a different resource’s address and they both worked. Each case can be different, troubleshooting is the only way.

Try changing which slots the cards are in, play around with the order they’re installed

For anyone here who may be Interested, I recently designed a 3d printed mount/duct that uses the blower from a dell optiplex for cooling these tesla cards. The part uses the mounting holes on the back of the card, and the fan slots in without any modification. I made it for the M40, but presumably it should work with any tesla that uses the same shroud and power connector arrangement.
If anyone here has access to a printer and is looking for a better way to cool their card, I hope this is of help to you

As a side note, the cable on the optiplex blower uses a non-standard pinout and is fairly short, so you would need to repin the connector and likely need an extension cable.
Tesla_Blower_Duct.stl (670.1 KB)

2 Likes

Those optiplex blowers are great, there at least 2 different versions though, the bigger one can be ran at slower quieter speeds and still cool well

That’s a great-looking shroud and fan setup! If I didn’t use so many cards in one rig I’d try one of those.

I personally used the ones that take a 40mm fan on that same end of the card. I also found that these M40, K40c, and K20Xm seem to cool better if the air is forced threw the card rather than pulled. I’ve tested both ways. I could use a few more as most of my cards I made my own out of cardboard and duck tape. lol

Good Job!

The M40 has a dual 40mm fan shroud, those others are K40’s.

So… I read some more online and found someone say his code 10 went away after switching the PSU. My PSU setup is kinda sketchy (650W PSU, but using dual molex to pcie adapters caus I lost the original cables). The right voltage are at every pin, but I will still buy a new PSU and check if this will fix my problems.

That makes me ask if there is a 8pin + 6pin both connected to the k20m?
In one case of mine, I found I wasn’t getting the power diverlery to my M40 causing the same problem. But then again a M40 uses a Y split cable 2x8pin to one 8pin on the card.
Try swapping the cables around if that is possible. Check all Molex connections and all others while you are at it. I’ve seen some of those Molex be hard to get in good for a good connection.

Edit: I got to thinking and remember reading somewhere that an 8pin has to be connected to the K20m, so I tried looking it up and this says yes it must be a 8pin connected at minimum for the card to work. Dual 6pins are not enough, but one eight should be.

This is what you would need with the PSU you have now. If you have already ordered a new PSU, not needed, but could save you some money as the 650W you have should be enough.
Edit: Max power draw for that card is 285W if I remember correctly. Correction 225W
Your GTX 1060 if 6GB 120 W maximum

Both connectors were connected. I ordered dual 6 pin to 8 pin adapters and will try them as soon as they arrive.

You only need one Dual 6 Pin Female To 8 Pin Male adapter. You can plug a normal 6-pin in the other with only 6 pins. The card will run with only the 8-pin connected, but best to use both 8 and 6 when under heavy loads.

OK, I finally got it working!! It was a broken GPU… I ordered a second K20 and It works perfectly!! Thanks for all your input guys!

1 Like

Too bad it was a bad card. Hopefully, it still had an open warranty left?
How is the new card doing?
Edit: for anyone interested here are a few tests I ran on a mod v-bios for the Tesla M40 vs the stock v-bios.
Edit2: oops on wrong PC. lol GPU1 in last SS is the mod.



I also forgot to say the above mod v-bios have not been tested in a 32-bit BAR motherboard.
So if tried in a 32-bit only case, please report your results. Thanks
I do have an MB HP Z400 with an M40 running in a 32-bit bar I could test, but if it doesn’t work
I would have to do a lot of work getting everything back working, moving video cards around
from rig to rig can be no fun sometimes.

Well this mod v-bios didn’t work in 32bit BAR in the HP Z400, but I had a spare HP Z620 unused sitting around I moved the card to
and it works perfectly after the regedit edit. Installing DooM Eternal now for some FPS testing.
I will update you on how that is working later. BTW I’m using a Quadro K2000 as display out
with a bit older driver 474.14 so both cards use the same driver. I will check later for a newer
version that will work with both. I will also later on place in a second Tesla M40 to this same rig.
If any questions please ask I will try to answer them.