Even's stunning BSD adventure - The BSD challenge blog

Why hello there!

I decided to take part of the L1T BSD challenge, so here goes! Come and witness the carnage!

If I learned something from the last Devember challenge (in addition to basic Python programming), it was the realization of how well peer pressure worked as a motivator for me, hence this thread.

I’ve decided to use GhostBSD for this challenge. Not a fan of MATE, but I’ll try to use it for now and see if I get used to it. I may switch to FreeBSD later but right now I want to have easy-to-install BSD OS to start with. I will use my old Asus laptop as a testbed before trying to destroy my partitions and nuke my primary workstation dual boot BSD with Windows10. Not sure if dual booting BSD is a thing but let’s find out!


I’ve been interested about BSD systems for quite some time now, mainly Pfsense and FreeNAS. I want to build new NAS to replace my old Linux file server at some point, and FreeNAS seems to be the way to go. Also, Pfsense gives so much possibilities to tinker and play around with networking, so I’m also considering in building a Pfsense box in a near or distant future. Both of these are based to FreeBSD, so in order to learn the system better, I might as well try using something similar as desktop OS to familiarize myself with the “Unix way of doing things”. :smiley:

Some stuff and questions about Pfsense for those who wana know:

something something Pfsence hardware

If anyone has good recommendations for a motherboard for the Pfsense I’m on all ears. Key words:

  • miniITX,
  • reliable,
  • CPU with AES-NI support (to make sure it’s compatible with Pfsense)
  • affordable (100€/usd maybe),
  • multiple nics (3-4 built in) or pcie so that I can ad nics if needed,
  • some regular I/O available (USB, display output),
  • available in the EU/low shipping costs to EU.
  • 16/32GB storage for the OS
  • does not neet to include RAM, I can source one 2gb stick of ram somewhere if needed.
  • passive cooling, or otherwise pretty much silent operation
  • low power consumption, AFAIK Pfsense won’t need any extra powerful hardware or lots of ram?

X86 Singe board computer works too, if it has 1-2 sata ports. I’m thinking of adding 120gb SSD in there to act as a cache.

But this thread and my challenge is not about FreeNAS or Pfsence! I’m planing to use BSD as a daily driver. Yes, I know, BSD is at it’s best when used in servers, but hey, I know people run BSD on their workstations. I want to try that too. If I get around at building the NAS or Pfsence router then I’ll just expand this challenge to cover even more BSD stuff. :slight_smile:

I probably forgot something but I’ll update the OP later.


You can do it!



Thanks bro! :slight_smile:


Booting to Live session from USB stick wasn’t exactly straight forward, but the installer is now running :v:t2:




Hello, we are live and in!

My Asus U36SD does not output higher than 1080 resolution through hdmi. Bummer. I need muh 1440p pixels REEE!


I see a freshports tab. Are you going to compile things from sauce?


Not yet at least. Going to try that at some point tough. Just googled ghostbsd how to install neofetch and that was first hit. :smile:

Going to see if I can get following applications to work/installed:

  • Spotify
  • Discord
  • Dropbox

I’ve just completed a GhostBSD install as well. From what I can tell the Linux modules are loaded into the kernel by default and the linux_base-c6 package is already installed.

It’s should just be a case of getting the right libraries setup so you can use the Linux binaries.

See here: https://www.freebsd.org/doc/handbook/linuxemu-lbc-install.html


Thanks, have to look into that later. I got side tracked, installed KDE but didn’t even test it. Currently watching both Finnish parliamentary election results and Ice Hockey Women’s World Championship FIN - USA finale. :finland: :us: :sunglasses:

Do you like GhostBSD? Currently only thing I don’t like is MATE, but let’s see if installing KDE was as simple as I imagined it to be.


I doubted that openbsd had neofetch even in ports, so i just git clone, make install :wink:

It’s just a bash script anyways. Nothing to port really. Had to install bash, tho.

People who don’t /usr/bin/env sh for scripts, smh.


Yeah, I had no idea how sudo apt-get works in FreeBSD, so I found out that as well. :smiley:

I did install openRA from ports, but it crashed. :confused:

I don’t have any scripts at all. If you whack me, please not the face.

And we lost. :sob:

Well, time to go to bed.

J/K, I don’t care that much about ice hockey, or sports in general. :wink:


America won? Booo.


Night night


The answer is pkg install neofetch
And you can do pkg search neofetch if you’re not sure about something.


would be interesting to know if its in the repos of ghost bsd it isnt in the repos of omniOS. at least the last time i could search with pkg because the DNS would work :roll_eyes:


Ooh nice, have to try that when I get home.

I expected Free/GhostBSD, or BSD in general, to be much more work than what it ended up to be. Granted I haven’t done anything special with it yet, so pain might just be hiding behind the next corner. :stuck_out_tongue:

I also have to take a closer look if I can dual boot GhostBSD with Windows on my workstation. 5400rpm hard drive and 4gb of ram on my Asus laptop does not offer the smoothest user experience.

Was omniOS based on Solaris? If I’d go the Solaris route my choice would be illumos or OpenIndiana. :thinking:

Something I forgot to mention earlier, GhostBSD live image uses fish as a default shell, but the installer asks you what shell you want installed. At least fish. zsh and bash were available. Since I’m disgusting normie I chose Bash


Shamelessly plugging my own BSD Thread


omniOS is based on illumos (a descendent of OpenSolaris), while GhostBSD is based on FreeBSD.

er that ended up being a reply to the wrong person


Well, got KDE installed but after trying to log in the screen just flashes and returns back to login screen. Didn’t bother to figure out that yet so I tried to fix screen tearing. pkg claims the latest nvidia drivers are installed, but I can’t open the control panel for it for what ever reason.

There’s a slight possibility that the graphics are actually handled by the integrated Intel GPU, since this Asus laptop has that nvidia optimus thingy or what ever on it. All linux distros usually can detect both GPUs but they only use Intel (or that’s what I think), so wouldn’t be surprised if BSD follows the same path.

Today was bit busy day so I’ll try to troubleshoot this more tomorrow.