Asrock X570d4u, x570d4u-2L2T discussion thread

should be my last update here since my build is stable now. I cannot fix the boot postcode 01 issue but it is not a big deal that it does not affect the system running. Sharing my build:

CPU: 5950X (PBO2 curve -10, override +25)
MEM: Micron 32G 4 ECC UDIMM @2933 XMP stock (MTA18ASF4G72AZ-3G2BZTG)
PCI-E: RTX 2080TI, BCM57810S
SSD: 2
2TB GEN4
HDD: 8*18TB
CASE: FD NODE 804

I have adjusted MemVref setting to 235 in AMD PBS menu. Although I am still getting code 01 when on cold boot. It won’t stuck that code when in hot / warm boot (at least i tried to boot continuously 5 out of 4 are succeed).

Just for reference, it might not be helpful for you.

Hey data_destroyer, i want to make my x470D4U run 1,35V VDDIO but i cant find the resistor on the Board witch i have to change. Its a bit diffrent to yours. How do i find the right one?

Has anyone managed to get HW alerting emails working on the X570D4U?
Or has no one else bothered, seems remarkable ungoogleable.

I have a working network (though the UI only ever talks about eth0 and eth1, and doesn’t mention
the out of band dedicated port). Anyone understand that?

All I want are temperature and fan failure alerts.

1/ On the main settings I have set a Primary SMTP server, my one can do non secure port 25. Tried this by name and IP.

2/ Set and email address on my “admin” account.

3/On to Platform Event Filters → LAN Destination Configuration. Set LAN channel 1 and Lan destination 1 with this “admin” account as “BMC Username”. Set a Subject and Message.

4/ On Platform Event Filters → Alert Policies, Set Group 1, Enabled and “Always send alert to this destination”, LAN Channel set to 1 and Destination Selector set to 1. Tried both “Event Specific Alert String” and having this unset

5/ On Platform Event Filters → Event Filters, “Any Severity” set, Tried “Event Filter Action Alert” on both settings, “Alert Policy Group Number”.

Have tried “Raw Data” (if you unset , this dialog wants a lot more details, IPMB Channel number or “SlaveAddress/SoftwareID”.

Then set “All Sensors” and “All Events”.

Then lots of stuff around Event Trigger and Event Data and Mask. Which are far from unclear what these should be.

The BMC manual is very unhelpful on all this, and have seen Alerting inconsistently work in the UI when I change some of the lower thresholds i.e the messages on the UI sometimes show alerts (not always). But it never ever sends and email, have tried SNMP traps and doesn’t seem to send them either.

Anyone got email alerting working and can share screenshots of how to set this up?

Has anyone had success with NVIDIA Connect-X 5 or 6 SR-IOV on ESXi?

Hey all, just got my x570d4u up and running with the latest BIOS and BMC (1.5 and 1.39).

Looks like the remote BIOS is still scuffed, but the remote viewer lets me access it with only a bit more work, so not too worried. System inventory is working, which is great!

I’m using some ram that I didn’t see mentioned in here that POSTs great, so yay more data (and it’s pretty cheap to boot - 128GB brand new for $363 shipped after the micron “first order 10% off” code)

Specs:

  • 5900x with a Noctua NHD12L (dual fan) and NM-AM4-UxS mounting kit to rotate the cooler to the correct direction
  • IC Graphite Thermal Pad (like 2-4c worse than decent Thermal paste, but Zero mess, fuss, or dry out ever, and is reusable)
  • 128gb ECC (4x32) of these: Micron 32GB DDR4-3200 ECC UDIMM 2Rx8 CL22 - MTA18ASF4G72AZ-3G2R
  • Samsung 980 pro 2tb NVME pcie 4.0 drive

I’m currently running the ram at 2666mhz because I haven’t tweaked it at all, hoping to get up to 2933, as people have reported moderate difficulty getting 4 dual rank sticks to 3200.

EDIT: I tried using both OC Tweaker and editing ram speed/timings inside AMD overclocking, OC sets my VCCM to 1.78v(?!) and the system immediately fails to post, so I have to do a CMOS reset on the bios to even access it again, and “Enabling” an overclock to 1467MHz (with or without 16h timings) doesn’t persist on save (f10 or save and exit from the menu), putting everything ram related back to Auto.

I was able to set the processor to Eco mode, so it’s not failing to save everything, just the ram timings/overclock setting. I tried 2800(1400) and 2400(1200)mhz as well to see if it was from going “too high” and both fail to save. Anyone else having weirdness like this? it’s not like 2666MHz is bad, but if I could get a bit more speed (and more confused why I can’t save it at all…).

Screenshot of Proxmox output for dmidecode -t memory showing size speed and function:

I’ve been following along in here for a few months, glad to finally have everything working (although my Sliger 4U case wont get here till end of Feb… currently it’s a bare server just sitting around).

Hey,

Glad I’m not crazy - having very similar issues with a recent similar build

  • X570D4U latest bios 1.50
  • 5800X3D
  • Non-ecc Corsair 2x32G 3200MHz kit

Configuring memory OC with this board is very frustrating, because it seems like if the motherboard ever stops POSTing, there’s no way remotely reset the bios (Unless you can do this via that Asrock software…? Couldnt find anything on the webui)

Basically, my first clue this board was going to be annoying was simply trying to enable XMP - it wouldn’t post.

I resorted to polling with ipmitool sensors remotely to get an idea of what the motherboard was doing - if we can trust the sensor readings reported, at least. I was getting the same ‘1.78v’ for VCCM.
I noticed other sensors like CPU vcore were weird too, so I tried setting some fixed voltages to see if I could get the board to boot with anything to work. but no luck.
So I thought if XMP doesnt work, maybe manually configuring timings, speed and voltage might - I can’t get anything above the JEDEC defaults to stick. Either it doesnt actually apply the setting, or it wont post.

I’ve tried another kit of corsair non-ecc memory, basically the same as the other except 2x16GB, with similar results. I’m ordering some ECC memory similar because eventually I’d like this to work with 128GB

5 days ago I contacted asrockrack support about these issues, but no reply yet.

The webUI is an insult to UIs everywhere haha. I got it “working” on Edge and Chrome (fails completely on Firefox), but it’s mostly just pages missing contents, and not showing options that are set in the BIOS proper.

Only way to “fix” a stuck BIOS that I know of is pull the battery and jump CMOS… glad my mobo isn’t in a case yet!

Are you able to get any ram changes to stick? I couldn’t get above or below JEDEC to do anything other than waste my time.

The weird thing is apparently the board is hardwired to 1.2v, so I’m not sure how VCCM could hit 1.78v, unless something changed since earlier posters realized it was a fixed resistor controlling the voltage…

Is it OK that X570D4U does not show that memory is ECC on BIOS main screen?

Does it mean that it threats the memory as non-ECC, or it is just a design choice?

For comparison, X470D4U with the same memory (KSM32ED8/32HC - not in QVL for both):

I would love to know the answer to this too. On Linux dmidecode only shows ECC for the CPU caches and doesn’t mention it for the memory DIMMs I have. (“Samsung - M391A4G43AB1-CWE 32GB PC4-25600 DDR4-3200MHz ECC” for what it’s worth).

Thought I might have to enable ECC checking in the BIOS but can find no reference to it in the BIOS or under the BMC (or any alerting that might be for ECC errors).

Looks a bit like it might just “support” ECC DIMMs and not do any error checking…I do hope not.

Let me know if you find anything out!

I was going to contact ASrock support on this, but I contacted ASrock support about my IPMI monitoring issues a week or two ago and not heard anything except the autoresponse. Let me know if anyone has anymore luck with them.

I have ECC memory on my server too. The BIOS page is something like you too, not showing the ECC keyword on the main page. I think you should check the ECC functionality on OS level. Mine is recognized by the OS and should be enabled.

``# dmidecode 3.3
Getting SMBIOS data from sysfs.
SMBIOS 3.3.0 present.

Handle 0x0010, DMI type 16, 23 bytes
Physical Memory Array
Location: System Board Or Motherboard
Use: System Memory
Error Correction Type: Multi-bit ECC
Maximum Capacity: 128 GB
Error Information Handle: 0x000F
Number Of Devices: 4
``

And also don’t expect Asrock staff will reply. I sent my email 3 months ago and no replies ATM.

Arghh. Running with your command only shows:

Handle 0x000F, DMI type 16, 23 bytes
Physical Memory Array
Location: System Board Or Motherboard
Use: System Memory
Error Correction Type: None
Maximum Capacity: 128 GB
Error Information Handle: 0x000E
Number Of Devices: 4

This isn’t good!

Pulled the trigger on the X570d4u non 10gbe version for £380, don’t tell the missus!

This thread is amazing by the way, such knowledgable people sharing their experiences which I’ll no doubt refer to as I start to piece my system together bit by bit.

I’ll be running ESXi 8 so IPMI and temp sensors is a must for me.
With this in mind, which memory is best for this board? I need 32GB modules as I want to upgrade over time and the modules must have temp sensors and be visible in IPMI. Bonus would be the memory running at 3200mhz out of the box (anything on the QVL list)?

CPU I am not decided on yet and since i’ll be running ESXi, not to bothered whether the CPU has iGPU or not, so probably more cores is preferable so 5900x?

My priority for the build is silence and ECO for this build so need to choose wisely. Cheers!

Just sharing my experience of BIOS 1.70, It’s complete crap and I would not recommend it.

I went from 1.40 to 1.70 on one of my machines and could no longer maintain 3200Mhz on my RAM + Fabric. Tried various different options but no joy and even needed to use the CMOS jumper each time I applied the same settings as I used before. On 1.40 I can set them both and it just works.

Will remain on 1.40 for the forseeable and would recommend it for anyone else using struggling to get 128GB to 3200Mhz or whatever your DIMMS are rated for.

Followup; I got some of the Crucial 32G ECC kit for my X570D4U and it’s actually behaving. It automatically configured it to use 2666Mhz timings

2 Likes

Has anyone managed to passthrough the SATA controller in ESXI? I added the device to passthru.map and tried numerous reset methods but nothing works.
Thanks.

ECO mode gone on the latest firmware for anyone? I cant find it at all? I can see an “EffficienyModeEn” Option that seems to do nothing, I even set the cTDP control to 65 to try and manually set it and that also appears to have done nothing (temps and clockspeeds at load the same as stock)

Only when accessing storage devices, nvme or SATA - always slight coil whine.

I also have coil whine when accessing NVME (it’s the only thing plugged into my board to access!), contemplated doing the “wick some superglue into the coils” fix but I’m shoving it in a case in my rack shortly which should effectively negate the sound, it’s just when open air like it is now that it’s noticeable for me.

1 Like