ASRock X570D4I-2T

Asrock released some days ago the 2.50 bios and 1.90 bmc…

Well as stupid as i am, I’ve updated immediately :person_facepalming:

Be warned!

Booting takes forever! Like 1 minute…
Rebooting (from linux or proxmox) doesn’t work at all, it stays powered on and freezes on the end of the shutdown, where it should reboot actually.

Fml, im so pissed rn, i mean since I’ve buyed that board, it had always issues.
I mean as a Server, if its once powered on, it runs forever without issues, if you have ecc ram…

But the actual server things, for example bmc never worked, i mean it’s 2 years now, what’s the sense of bmc if it doesn’t work.
For example, you have the inventory, that never showed anything, or no, let me say it differently, nothing works except remote console and some super basic features like setting a static ip for bmc or shutdown…
Remote bios is a joke…

But now this:

  • Bmc finally works with 1.90, it shows the inventory like it should, almost everything works now. I didn’t tested remote bios, but according to the user above it works now either…
    But that’s after freaking 2 years…
  • But the 2.50 bios is now a pain in the ass, absolutely broken piece of crap…
    Now we have a broken reboot, a boot that takes 2 minutes or longer and the best is, you can’t disable the dedicated GPU now.
    Even if you change to onboard vga boot, it still boots on the discrete GPU.
    Why is this bad? Because try to enter now the bios over Bmc with remote console… Good luck…
    It somewhat rarely even boots vga, but thats 1 of 5 times… And 1 of 5 times means you sit there for 30 minutes to enter the bios with this crap boot speed now…

That worked flawlessly before with 2.29, or at least i think i had 2.29 before :person_facepalming:

However:

  1. don’t upgrade to the 2.50 bios, but upgrade to 1.90 bmc, since bmc is finally working now!
  2. Don’t ever buy any asrock rack products.
  • if you need kvm, get a pikvm! Consumes the same power as the inbuilt nonworking bmc, is a lot cheaper then a board with bmc and it’s fast as hell and works reliable!
  • i have now 2 servers based on x570 boards (mainly msi x570 itx something) that costs nothing, compared to that asrock crap, with pikvm… It boots as fast as hell, supports ecc either… Tho it only has 2 slots and 1gb instead of 10… That sucks either, but there are boards with 10gb. Just my usecase where they stay, they don’t need 10gbe, because I can’t get a 10gb connection from my provider.

However, my opinion and sorry, i had to get my anger out somewhere, about that asrock crap.

Cheers

1 Like

Small update:
i have flashed the new bmc and bios over bmc before…
After reflashing the bios manually (not through bmc), it works… Finally :tada:

Reboots are working now, boot times are okay now either.
It’s still slow, because of configuration of pci and whatever, but it’s not comparable to before.
It boots now in 30 seconds or so, instead of 2-3 minutes.

I think the bmc flasher stucked somewhat in the flashing process? Because for me that looked like on every boot the bios gets flashed over and over again, that’s why it took so long and reboots didn’t worked…
I don’t know, i think that the bmc flasher is broken simply.

Cheers :v:

After updating my system to the latest versions of the BMC & BIOS, the remote BIOS configuration tool is now working for me as well. However, I initially updated the BMC through the IPMI interface and found that the remote BIOS tool still did not work. I then re-flashed the BMC firmware back down to 1.80.00 and then up again to 1.90.00 using the socflash method and, after waiting for the BMC to come back up, I found the remote BIOS configuration tool was up and running.

Ah… I’ve always been using their beta bios and haven’t had to use socflash in awhile.

Did the remote bios configuration tool not show up for you? or it showed up but you weren’t able to use it.

I do find their firmware/bios update via the BMC not as stable as say… Supermicro.

Btw, if you guys haven’t seen this.

Basically if you turn on the Keep Share NIC Link Up option in IPMI, the first port will be limited to 100Mb/s.

It does affect this board too.

Thanks for taking the time to share your experience. I will give the new BMC a shot and hold off on the BIOS update. It took me forever to get the socflash method to work last time, it didn’t “find the device” until I got lucky mucking around with the hardware. I dedicated one board to lab experimentation and run a Supermicro for the stuff that needs to work. Though the Asrock support team is excellent, this board is trouble, and I even had to send one back on warranty for a failed 10 Gb nic.
I still have this board in my main workstation and love having dual 10 Gb in the mini-ITX format. Also, getting the Oculink working with U.2 nvme was probably the worst part and was only resolved when Asrock released their cable (nothing else I tried worked, it was a lot of wasted time).
With a few tweaks and functioning BIOS/BMC, this board would be close to perfect in the small form factor. Oh well.

After updating the first time, clicking the “BIOS” link in the top right of the navigation bar would direct me to a page that failed to completely load (it did not throw an error like the previous BMC version did). More specifically, the page header loaded in but the page itself was white and none of the BIOS menu options were populated on the left side of the screen.

What non server AMD boards officially support ecc?

As soon as I can get this board in the UK I’ll be installing esxi 8. Does the ipmi report back nvme and memory/sodimm temps as well as cpu motherboard etc? Looking for some recommendations please. Thanks.

The IPMI itself does have that data.

Here’s a screenshot:

1 Like

Thanks for that. What memory modules do you have please? I want to make sure that the ones I get have temp sensors.