Return to Level1Techs.com

Asrock Rack XMP

Before I started this project I had a stable system running a threadripper 3970x, 256gb of 3600mhz RAM (8x32gb), and an Aorus Extreme motherboard. All was well, and I ran with the default “Profile 1” XMP profile, which ran at 3600mhz and 1.35v.

A bit of background, this system is a VFIO workstation / server / lab and lives at the office. I used to run ESXi, but am in the process of switching to Proxmox to match my lab at home.

Since the pandemic started I may go months at a time without going into the office. This prompted me to finally cave and go buy a TRX40D8-2N2T server motherboard. Really this whole project was to get true OOB access via an IPMI interface so that I could do offline maintenance on the box.

This board has been great so far. The one problem that I’m having is that the system won’t boot if I enable the XMP profile. The system won’t post and I get a diagnostic code of “Ad”.

Have any of you tried enabling XMP on an Asrock Rack board? I reached out to Asrock a few minutes ago to see what they say. Their business product support is pretty good, I expect to hear back from them tomorrow. I’m curious though what other’s experience has been with XMP on these server / workstation boards that use consumer CPUs.

There’s one mention about lack of XMP profiles on another of ASRock Rack’s boards here, probably suggestive of most of their server board lineup:

It’s definitely likely that their support might provide you with a modified BIOS and/or advice, though. Let us know what you hear back!

8 DIMMS with dual rank DIMMs on TRX40? Should be supported up to 2666 speeds or maybe 2933. You should get the table in your manual. Max is 3200, but only for selected configurations. Overclocking isn’t supported by anyone. Often works regardless, but server boards like to be “within specification”