Return to Level1Techs.com

Aorus Master x570 Perfect UEFI Settings

Seems the new AGESA will be dropping in conjunction with the 3950X which makes sense.

Given that the 100+ features/fixes is part of an MSI marketing slide, not so sure about this one. I suspect there will be a number of additional items, not least additional menu items in AMD part of the bios however, I also reckon MSI marketing may have gotten a little over excited about the number of changes :slight_smile:

Bios F10a (AGESA 1.0.0.4 B) was released for the x570 master today.

https://www.gigabyte.com/Motherboard/X570-AORUS-MASTER-rev-10/support#support-dl-bios

IOMMU groups with F10a: https://pastebin.com/raw/gUxhRCBs

2 Likes

Thanks a lot for this. I was looking for this information. If you don’t mind, I will quote your reply to that thread, in case anyone else is going through it and doesn’t stumble across this thread.
A question though. I see 2 separate IOMMU groups for USB controllers. Does this mean that I wouldn’t need a USB PCI-E card ?

Blockquote
IOMMU Group 23 08:00.1 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD] Matisse USB 3.0 Host Controller [1022:149c]
IOMMU Group 23 08:00.3 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD] Matisse USB 3.0 Host Controller [1022:149c]
IOMMU Group 35 0e:00.3 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD] Matisse USB 3.0 Host Controller [1022:149c]

Yes but it may be trial and error to find which ports. Every now and again I find these go to headers on the Mobo which I haven’t used! Haah
So I have to order a USB header

From my testing IOMMU group 35 is the white port labeled ‘bios’ and the blue one next to it. Group 23 are all the other USB ports it seems.

Despite the good groups now, there seems to be a bug in the bios/agesa and passing through the USB controller in group 35 will freeze the system immediately. I spent an hour or so troubleshooting this and all I managed to get was hard freezes (no logs, no nothing) the moment I launched any VM with this USB controller attached. With one of the ports connected to it being labelled ‘bios’ (for the flashback feature) maybe there’s something odd going on with it.

1 Like

With trial and error and some cheating:

https://pastebin.com/raw/at9WttTc

:grinning:

2 Likes

Welp that’s going in the next how-to. Nice work

Wait…does this mean using USB PCI-E card can be avoided ?
Also, the USB-C on RTX 20 series cards can be passed through, right ? Wish Navi also includes USB ports on their upcoming cards.

Awesome…Btw, doesn’t this MB has USB 2.0 as well as 3.0 ports ? Why group the USB controllers together, I wonder.

Can you please also test whether this x570 Aorus Master MB has rdrand (random number generator) issue or has it already been patched through BIOS update including the microcode fixes? This wouldn’t take long :slight_smile:

Referenced article: https://arstechnica.com/gadgets/2019/10/how-a-months-old-amd-microcode-bug-destroyed-my-weekend/ (MB in this article: Asrock Rack X470D4U)

Testing tool: https://cdn.arstechnica.net/wp-content/uploads/2019/10/rdrand-test.zip

Screenshots:

I’m still trying to figure out what’s going on with the USB controller, but I’m fairly certain something isn’t right with the bios. Hopefully an update will fix this.

Here’s the rdrand tests:

rdrand

%./amd-rdrand-bug
Your RDRAND() does not have the AMD bug.
%./test-rdrand
RDRAND() = 0x59ec388e
RDRAND() = 0xdaf49ed6
RDRAND() = 0x86526968
RDRAND() = 0xc8ead9c0
RDRAND() = 0xd05d6866
RDRAND() = 0x94d2e4a1
RDRAND() = 0x105ae9e2
RDRAND() = 0x7c16d022
RDRAND() = 0xe2affffe
RDRAND() = 0x44685466
RDRAND() = 0x859d5334
RDRAND() = 0x5fff5202
RDRAND() = 0x9b914309
RDRAND() = 0xe1003e92
RDRAND() = 0xb74408be
RDRAND() = 0xeca33bdd
RDRAND() = 0xbe03f3e7
RDRAND() = 0xb6a6d490
RDRAND() = 0x6407c410
RDRAND() = 0x231a1566

The author of this article misunderstands how one off bioses work… this is technically an Enterprise product which takes a long time to qualify. I agree it’s frustrating to wait so long for an update but an assumption made by the author – that any new bios made after the fix was known would have the fix – is never a safe assumption.

Even our own users here were told the update had the fix, but it didn’t.

I didn’t have any proems with Steve’s build but only because I verified what changed I the fixed bios posted here.

All consumer boards that have the abb+ agesa and newer smu will have the rdrand fix. It’s not the date that matters, but the agesa, for this particular issue.

It is a bit disappointing it was fumbled but this is not a typical in the Enterprise. I’ve ordered over a million dollars of kit that wasn’t actually fully usable for 3 months because we were an early adopter and the stake holders decided the payoff of being an early adopter was worth the risk.

2 Likes

Thank You - Much appreciated.

For those struggling with PBO bug on Agesa 1.0.0.4, maybe this can fix it:

Settind EDC to 0 my cpu back to 4650mhz (ryzen 9 3900x). thanks.
This F10A bios is lagging as hell… this issue is only mine?

How do you mean laggy? Mouse stutters when in Bios screen?

When you move up and down (between bios options) with keyboard, there is a delay

NEW BIOS F10c
EDIT: Download link seems broken…

Go to the Asia site when that happens

Also F10c needs to set PBO limits manually to 0.

For a while I had a similar issue and fixed it by plugging keyboard/mouse into different USB port. Kinda weird I know however, it worked … so that was nice :slight_smile: