Return to Level1Techs.com

2950x random gui crashes and reboot on Fedora and Manjaro


#1

Hi guys need some help here. My new rig’s crashing left right and center!

So here are the parts :

cpu 2950x
MB MSI MEG CREATION
RAM GSkill Ripjaws V 3200 32Gb 4*8gb
GPU RX 590
PSU Corsair rm850w
SSD 970 evo

Here are the issues

Either in fedora gnome or manjaro KDE the computer randomly crashes / freezes or reboot and all error messages are around Xorg or Wayland crashes, today the entire manjaro gui broke leaving booting in cli directly… I haven’t been able to find a stable set up for 5 days now.

PS I just did a fresh install of manjaro kde and I’m already experiencing troubles as update won’t go through sending timeout messages.

Every thought will be appreciated.


#2

Please see my PSAs regarding issues I have encountered on AM4 Ryzen. I do not have any experience with TR, but maybe they are useful.




#3

Thanks for your answers but I checked all my UEFI parameters and the kernel log and it appears that my crashes are not related to yours. I really thinks they are related to a graphical problem because it’s always sending messages about xorg crashing or X11 ou sddm having disappear… I got a black screen a lauch after login 10mn ago and right now the screen is frozen again in the middle of a system update and there is no particular error code on the motherboard just 00.


#4

Do you have a spare GPU you could try?


#5

Can you disable pcie aspm? And what bios version?


#6

I have the latest version from the msi support page

Version 7B92v12 Release Date 2018-11-15 File Size8.66 MB

gonna try disabling pcie aspm when I got home from work thanks for the tip


#7

got a rx 570 same outcome!


#8

new developement I came back home 15mn age the computer won’t even turn on now the power switch on the motherboard lights red normally but nothing happens when I press it or the front I/O power button either.


#9

I took the build apart and put it on a test bench with just the bare minimum still got light on the power button but nothing when I press it. I tested the psu on a other computer it worked do you think the motherboard’s dead?


#10

Are you sure the CPU is seated properly? From what I heard the TR4 socket is a bitch, especially the Foxconn sockects have a reputation of being a complete pain in the ass to properly close.


#11

this could cause the motherboard to not turn on? this suddently?


#12

I reseated the cpu and the computer turned back on but I keep getting freezes on my new manjaro install


#13

I cannot find pcie aspm in my bios :frowning:


#14

so now the case change a little bit no more freezing but more random rebooting I tried changing the kernel but no effect. Maybe the cpu is still not seated really tight in the socket?


#15

Yep it’s not in there. I got mine out now too.

Can add pcie_aspm=off to the kernel line tho.

Make sure both atx12v 8 pin power is installed well on both ends? Clipped in good? Un and replug?


#16

Yep everything’s pluged in properly. I’m starting to loose my mind a little bit here. I keep getting reboot and frozen screens… I logged in for 45mn about hours ago tried to set up the distro a bit but I couldn’t find any new package I installed even though pamac was saying everything’s right. So I tried to go back to fedora burnt a newly downloaded image on to a flash drive but couldn’t even get to the live os and only got a blinking cursor at the top of my screen. Maybe the cpu is still out of position I’m waiting for new thermale paste to arrive and redo the install completly.
Just another dumb question how do I add the line to the kernel? lol
Again Many many thanks for your help


#17

For giggles enable pbo and set CPU to like 200w or 300w? This changes a bunch of stuff in the power delivery algorithm

Pcie_aspm: It’s in your grub file permanently or at boot on the kernel selection screen just arrow down to a line, hit e to edit and add after the end which probably has splash/quiet on the kernel line


#18

Already tried to re-seat the cpu?


#19

Also welcome to Manjaro really.
Maybe you could try to use the terminal for updating instead of pamac / octophi.


#20

I re-seated the cpu allready and updated through terminal. The thing is I don’t really know which crashes are hardware related and which are distro related.