Return to Level1Techs.com

PSA: The ASM1061 SATA controller on the x370 Taichi is probably garbage

amd
linux

#1

On the X370 Taichi you have 10 SATA ports, 8 is presumably provided by the X470 chipset, and the remaining 2 by an ASMedia ASM1061 SATA controller.

The 8 native ports seem to work fine, but the ASM1061 might be a complete heap of garbage. Still investigating, but the controller seems to randomly lock up or glitch out when under sustained heavy load, resulting in a dropout of all SATA devices connected to it. Does not seem to cause kernel panics, but this essentially make those 2 SATA ports unusable.

I will update this thread when I can confirm that the problem was indeed caused by the ASM1061 controller, but at this point I have strong suspicion.

PS: fogot to add, but once the ASM1061 locks up, it seems to remain FUBAR until system restart


2950x random gui crashes and reboot on Fedora and Manjaro
#2

If it is the ASM1061, get into contact with ASRock and maybe they can put out a BIOS update.

Also, thanks for the PSA.


#3

Update:
I have moved one of the HDDs off the ASM1061 controller, to a regular port, and so far it seems to have solved the issue.
I am reasonably confident at this point that the problem is indeed caused by the ASM1061.
This is strange, on the X299 Taichi there is also an ASM1061, but I have yet to see issues caused by it.


#4

This is just my experiences with it, but in general, I found anything related to AsMedia to be absolute garbage to use, I have generally avoided using USB ports and sata ports that rely on an asmedia controller. Once I started doing that, my experiences with PCs in general have improved.

Once again, this is just what I’ve experienced so far using devices with an asmedia controller, it could be totally different for someone else.


#5

Update 2 : still no issues. At this point I consider the disk problem solved, and for a lack of a better explanation, I am going to blame the ASM1061 for the disk dropouts.