Yoga 920 screen no longer working

Hello, I need some help. So, context; I was trying to upgrade the SSD in my 920 Pro as Uni requires me to install Matlab, creo, and Ansys. I wanted to install what I can on a Fedora installation, as I wanted to make the switch from my Ubuntu to a KDE environment. I had a spare 500gb m.2 SSD laying around from a networking course I took last year, so I thought I’d throw that in there; that ought to make things much roomier. As mentioned, I was dual booting with Ubuntu and Windows. Now, I like Linux but don’t love gnome’s scaling on this tiny screen; unfortunately, I couldn’t get fractional scaling to work. Regardless, I took to performing open case surgery, but I forgot to bring my medical license… Once I replaced the SSD, the UEFI/bios wasn’t recognizing it. I suspect that this is due to the type difference, where the original SSD is NVME, and the one I’m using is M.2. So, I realize that I’m going to have to flip the drive for another 500 GB NVME, and so I placed the original back in. This is where the unfixable part comes in. It seems that due to the many insertions and removals, the ribbon cable decided it had had enough. Also, I may have made a rookie mistake when taking it out the first time. I noticed that some of the other ribbon cables had little latches, so once the cable is in, it locks it down into place. I assumed the cable for the screen was the same, and tried to remove it, this then, unfortunately, broke the little white piece of plastic that appears to hold it in place. Initially, I thought nothing of it because the screen was working the first time I booted the laptop with the M.2 SSD in, but once I got to the final stage, it didn’t wake up. I plugged in my monitor using a USB-C to HDMI cable, and it displayed windows, not the usual grub menu; I believe that may also be another issue, windows also got fed up with grub.


  • Tried to replace SSD with a larger one;
  • May have broken the ribbon cable that connects to the screen;
  • Grub is no longer showing up; and,
  • I’ve performed an illegal surgery and have body parts scattered over my desk.

Some images of the body parts:

Plugging this into windows gives me a “drive not initialized error” then “device not ready”; using a live fedora I get “drive structure needs cleaning”.

I truly hope someone can please help me revive this thing. All the nightmares came today, and it looks as they’re here to stay…

Added the helpdesk tag.

Good luck with this OP. I hope for the best.