XMP ram profiles: just a commercial BS?


I’ve assembled many PCs, and each end every time - since XMP profiles are available - not once the XMP profile worked out of the box without the need of further tweaking - downclocking, overvolting, etc. Latest example are two 3600 sticks that at the XMP settings are higly unstable, and even at 3400 gave some error; but with all the other RAM stick I had the same experience.

That is making me finally wonder: are the default XMP profiles unstable by default? Are they supposed to work only with manual adjusting, like overvolting? Or is it that I’ve just been unlucky with my builds? Are they just commercial BS to sell more?

Is there someone that could run their memory with the XMP profiles with no further tweaking and with no error after an extensive RAM test?


1 Like

That is very odd.
Each of the last 12 systems I have built, which had XMP, worked reliably with it. I have heard of the occasional person where the XMP didn’t work, a few of them got Better timings on lower voltage than the XMP, but it’s rare.

On the other hand, if it was guaranteed, then it would not be XMP, it would just be the default speed…

not saying you are wrong, just that I have not had that.

perhaps others could chime in with the mix of good- and bad- xmp experiences? Would be nice to get a broader set of experiences…


No, they generally work without much fuss; especially the ones that have been QVL’d by the motherboard manufacturer. Out of curiosity what brand modules and MB’s are you building with?


I’ve build about about 40+ builds and only had one where for some reason it just didn’t want to work with XMP, it was a AM3 AMD system with Corsair DDR3 RAM. For all others it worked like a charm without issues.

I did have two systems where the RAM just wouldn’t work with the CPU at all and the funny thing is those were both AMD ThreadRipper systems.

But XMP is an overclock in the end so it is not guarenteed to work, and from all I know most often than not it’s the memory controllers that for some reason are incompatible with the RAM.
It’s silicon lottery there too.


I have also had a few systems where the ram would not work at all. sometimes bad ram, sometimes just plain not working with a CPU

(as in, I’ve not just been really lucky. but my bad luck has not coincided with XMP. For me.)

Xmp generally works as long as your CPU’s memory controller can handle it and your motherboard’s pcb can

More pcb layers generally mean higher the ceiling for ram clocks

Also something to note is the more ranks a stick of ram the more stressful it is for the memory controller but like channels, increases the bandwidth your ram provides

More ram sticks also is more stressful on the memory controller, because. More sticks means more ranks


I’ve had XMP not work a couple of times, but only on pretty extreme memory kits, HyperX Predator 4266 DDR4 and more recently a GSkill TridentZ5 6400 DDR5 kit.
For most “normal” memory kits I’ve had XMP/DOCP has worked flawlessly.

I’m running a 5800X, mb is an Gigabyte Aorus Elite 1.0 X570 and the memory is 2x16GB G.Skill Rip Jaws 3600MHz CL18-22-22-42 1.35V F4-3600C18D-32GVK; I’m no expert on ram overclocking but I believe the system should be capable of handling 3600mhz memory, am I wrong?
I did a test yesterday with memtest86+ at 3600 and in 51 minutes I had 83 errors…

For those running without issues: have you stress-tested it, like with memtest86+ or other similar tools, or it’s just that the system “runs fine”?

In the meantime I’ll do some other tests…


This pretty much, it’s never really guaranteed to work flawless.
In most cases when the said memory kit is on the motherboards QVL list,
it should kinda work without much problems.
However technically we still talk about a OC profile.

This is also one of the reasons why i personally don’t care about,
overclocked benchmark numbers on gpu’s or cpu’s.
Because those numbers don’t really mean much.
It’s a matter of silicon luck mostly.

In this case i would recommend to run the same test on JDEC memory speed.
To see if you still get weird errors and experiencing stability issues.
Because it could also just be a bad memory stick of course.

You probably just have bad ram, that’s cause enough to get a replacement, hit them up for a rma

I’ve found CPU and/or mainboard, being the point of making/breaking XMPs potential
Small example of recent rig, being my 1600AF [Zen+], simply refuses to go past 2666
And this is with multiple stick set arrangements [GSkill, Crucial, etc.] - not remotely fazed at all
I can put in the same sticks, into a basic x299 board; having the sticks happily jump towards 3200

Ok, but there’s a big difference between “never really guaranteed to workl flawlessly” and “never works”.

I had the ram run the whole nigth through memtest86+ without error at 3200, so I wouldn’t call it a “bad memory stick” - i.e. one that gives error even at nominal speed.

What really ticks me off is that at the end they’re selling something that never works as it’s supposed to work, like running a 3600 ram at 3600mhz - and unless someone shows me that there’s an intrinsic limitation in other parts of my systems that prevent and prevented the memory to work at the speed it was sold, to me it’s fraud. I can understand if on a single case you can’t run the memory at the XMP speed, but I never ever got the ram to run with the XMP settings…

You seem very insistent that it is definitely the memory that is the issue, but many others here have tried to convince you to look at other pieces of the puzzle and I am going to have to reiterate their sentiments completely.

Memory speed and performance is NOT determined by just the stick itself. The memory controller on the CPU is a key component in the memory system, as are the copper traces embedded in the substrate/PCB. It is possible that the traces connecting the memory were good enough to pass QC, but not capable of reaching the full supported speeds on one or more of the DIMM slots. It is also possible that the memory controller just isn’t that good either. However, this is all just speculation unless your going to actually attempt to troubleshoot the issue.

  1. Have you tried a different memory kit to rule out bad DIMMs?
  2. Have you tried using both DIMMs seperately in every different slot to see if it is a mobo issue?

For reference I am currently using two kits of 2x16GB 3600 CL18-22-22 (Team Group T-Force Vulcan Z, single rank SK Hynix) with a 10900KF on a Z490 Unify. Obviously with those parts quality isn’t an issue (or at least shouldn’t be), but I’ve used one click XMP since day 1 with zero issues on either one or both kits.


Well i get that it is pretty frustrating but like @E-Wasted also pointed out there are more pieces to the puzzle like the said board and memory controller in the cpu etc.
It could very well be that your particular board and the said,
memory kit is just not a happy marriage.
Or It could also be that it just needs more manual tweaking before you get there.
You have to understand that there is allot of difference in regards to quality of memory kits.

So yeah maybe just try a different kit and sell the current one?


I’m insisting on the ram beacuse this happened also on my older systems, and at this point it seems a bit simplicistic to just say “it’s not the ram anyway” without further testing. And i’m also insisting on the ram because it’s the ram that’s marketed as 3600-capable, not the MB nor the CPU.

My system is also not a low end one: maybe is not as top level as yours, but at the same time I dare to say that it’s better than the average system out there; so I also think thay with my parts quality shouldn’t be an issue, since I’m not doing any extreme overclocking.

I would also like to point out that, as of now, nobody answered to my question if they thoroughly tested their ram with memtest86+ or an equivalent tool, or if they’re just saying that the ram runs fine because they don’t see any apparent issue.

For example, can you run some extensive test on your system and thewn report back your results:

  1. download memtest86+ 5.3.1b - windows automatic USB creator here http://www.memtest.org/download/5.31b/memtest86+-5.31b.usb.installer.zip
  2. run at least a complete pass with the default settings - the more passes the better, 8 is recommended but it takes a long time. I suggest running the tests overnight.
  3. run at least a complete pass with SMP enabled (hit F2 right before the start of the tests)

@MisteryAngel and everybody else, if you want to also run the tests I would really like to see your results.

I did some XMP tests with a spare system (Ryzen 1700/Asrock x370 pro) and here is what I’ve found (note: 1 pass with memtest86+, more passes might give some errors):

  1. 2x4GB G-skill Ripjaws F4-3200C16D-8GRK
    a) in the “recommended” slots, SMP disabled: OK
    b) in the “recommended” slots, SMP enabled: FAIL
    c) in the “not recommended” slots, SMP disabled: FAIL
    d) in the “not recommended” slots, SMP enabled: FAIL
  2. 2x8GB Crucial Ballistix BLS8G4D30AESBK.M8FE 3000-15-16-16-35 1.35V
    2a) in the “recommended” slots, SMP disabled: OK
    2b) in the “recommended” slots, SMP enabled: FAIL
    2c) in the “not recommended” slots, SMP disabled: OK
    2d) in the “not recommended” slots, SMP enabled: FAIL

The 3600s always fail - which suggests me that the kit is of bad quality and if I can I will return it.

My conclusion, looking at those results is that the speed at the XMP profile can be achieved ( i mean: the memory passes a thorough testing without errors) under these conditions:

  • you have a pretty high spec system
  • you put the memory in the recommended slots
  • the system is not under heavy (memory?) load
  • there is full moon
  • the planets are aligned

This ultimately confirms my opinion that the rated XMP speed are more of a wishful thinking (or commercial BS) than a real possibility for a system under heavy load. Of course I’m open to change my mind if people shows me otherwise, but until then I stand to my opinion.


Like others have been saying, I would normally be inclined to blame other components for the failed memtest results. Also, what specific tests are they failing on?

I’ve had one instance of bad memory (thanks, Patriot), and it wasn’t just something that would show up in test programs. There would be general system and application instability which made things just crash quite often. In that case, the memory was just bad in general, at any clock. It was especially prevalent at when the CPU was being taxed, and errors would come up in the Windows Event Log quite a lot, too.

1st gen Ryzen was pretty spotty with memory controller stability at 3200/3000MT/s, and as such AMD only validated to the most relevant JEDEC standard at the time.

My inkling with your current setup would be the board or the memory, because the newer AMD chips handle memory speeds way above that pretty solidly.

Unless you’re buying extremely fast memory, the actual XMP/DOCP profiles aren’t overclocks on the memory side of things. The chips are binned according to their capabilities, and rated as such. As DDR4 has matured, manufacturers have continued to validate increasing speeds. You can be buying 3200 kit now, and end up with memory that was intended to be used at 3600 with no voltage increase.


Allthough XMP profiles should pretty much work out of the box in most cases.
Sometimes you can run into a motherboard and memory kit combination that,
just doesn´t play well with eachother.
The Ryzen 5000 series cpu´s should not have any issues with 3600mhz memory speeds indeed.

A quick thing to check that I didn’t see anyone say so far…
Even if the XMP profiles settings are all applied correctly it’s worth double checking the actual voltage.
Most DDR4 XMP profiles, for example, will call for 1.35V. However in the one or two systems I have seen with memory issues after enabling XMP the system was reporting a lower voltage during operation.
I was seeing 1.23V and 1.28V actual for the 1.35 setting, but luckily in both cases (Z390, X470) there was a memory offset voltage option and I could just boop in another 50mV and then everything was fine.

1 Like

What might’ve happened is that your RAM kit is not on the QVL of your motherboard. This could lead to instability when applying the XMP profile because the motherboard is guessing sub timings that might not be the ones the kit requires to run properly at the rated speed.

I’ve had issues with some Corsair LP DDR3 RAM on my 4790K but, a mobo and a RAM swap with QVL RAM after (even faster XMP ones) I’ve never had issues and the system is still running to this day with the same kit.

On my current system I’m running Trident Z Neo 3600C18 2x8GB, a Ryzen 7 3700x undervolted and an Asus Crosshair VIII Impact. I’ve had issues with two RAM kits on this system running XMP (they’re certified to run by G.Skill on my motherboard) and just sent them back. Now I finally got a stable kit that’s working at the rated speeds without issues.

All of this to say that I’ve had my fair share of issues with XMP, but managed to cycle through a couple kits and get it working properly. So I don’t see why you wouldn’t be able to do the same. It’s a pain, but that’s how it is when you’re looking for convenience.
If you want to start from scratch you can always use 1usmus tools and tune your memory manually.

Yes, but memtest86+ didn’t report issues with my first defective kit. I’ve had to use AIDA64 RAM stress test. That one immediately showed issues.
The new kit passed AIDA64 and I’ve never had issues with it ever since (to be honest a few days ago one kit just didn’t load the RGB module on it and reset all my lights settings lol).

1 Like

Not that I can assist/help much with the information but it would probably be helpful to know what BIOS version you are on as well. Some of the AGESA do better or worse with memory to my knowledge. I believe most of the recent releases have stabilized the previous issues.

Also your memory is not supported based on the QVL list for the motherboard. On Gigabyte’s page for your motherboard under Support → Support List there are the Memory Support List. 5800X is Vermeer and that particular G.SKILL is not listed for having support so that could explain the XMP failures as well.

If you get further into the weeds… Some people can tell you based on it being Samsung vs Micron etc. may have better/worse support and which AGESA made it happen for them. But right now you technically fall in the “not guaranteed” category.

Edit: Interestingly though… G.SKILL say that they support the motherboard. But ultimately I would think the motherboard manufacturer would be the trustworthy list over the RAM vendor. But for what it is worth I’ve never had XMP issues in my past experiences. I also haven’t thoroughly benchmarked either to look for errors but no rampant BSOD or instabilities to throw a red flag.