Return to Level1Techs.com

X570 Aorus Master audio issue with Linux

I’ve tried a few different kernel versions and distros but can’t find one that works with the built in audio on the board. I can get audio output to HDMI devices, or USB headsets no problem but nothing out of the line out port on the motherboard (No issue on w10 with the audio). Any ideas?

Currently running Manjaro on 5.3.6-1 kernel

does audio work any better booting from Live ISO USB ?

try bypassing playback in Pulseaudio by playing audio direct to ALSA hardware
(there is speaker-test command if can’t do it with an audio player)

suggest post information from inxi- Fxxz and alsa-info.sh --upload to Manjaro forum for assistance

If you plug something into the rear line-out, it’s correctly recognised as plugged in there, but the actual audio seems to get routed to headphones. I use pavucontrol to switch output to headphones as a workaround.

I didn’t file it as a Manjaro bug since I’ve seen it across the board of distros and kernels (4.11 was initial support I believe for the ALC1220) not sure exactly where on the stack the bug is to report to :confused:

try bypassing playback in Pulseaudio by playing audio direct to ALSA hardware
(there is speaker-test command if can’t do it with an audio player)

no luck it wouldn’t work either, though I am not experienced with that tool

aplay -L sounddevices.txt (1.6 KB)

inxi -Fxxz systeminfo.txt (3.1 KB)

alsa-info.sh

If you plug something into the rear line-out, it’s correctly recognised as plugged in there, but the actual audio seems to get routed to headphones. I use pavucontrol to switch output to headphones as a workaround.

It’s properly recognizing the port being plugged and I can select between front or rear for output and input. This did have me do some more thorough hardware testing with interesting results.

  • Rear speaker out (line out) won’t work at at all on linux (with any device)

  • Front panel out works fine (with both 2.1 speakers and headphones)

  • Rear mic in works fine

  • Front mic in works fine

  • Don’t have the setup to test the rear 5.1 or 7.1 ports

  • USB audio works

  • HDMI audio works

  • DP audio works

So for whatever reason the rear line out is just borked on the linux driver or audio stack?

I haven’t yet tested if disconnecting the front audio connector fixes the issue (Front panel connector is from a Lian Li 011-Dynamic) but since input works on both and it sees the ports I don’t think that’s going to be the solution.

I have the same issue (x570 Master) and from what I have been able to find out its an issue with the ESS Sabre DAC
Probably going to have to wait for a patch as there are no workarounds that I have been able to find that work (for me at least)

Is the an open bug for this with the ALC1220 and ESS Sabre DAC that I can bump or supply info for?

I couldn’t find anything when I searched around though the weekend. I did manage to find some discussion of it around the ALC882 along with a kernel patch from System76.

https://patchwork.kernel.org/patch/9552671/
https://patchwork.kernel.org/patch/11089187/

Maybe @wendell has some insight on a workaround or place to start for a fix

from data shown in alsa-info
rear green jack socket is mapped to line out:

  Pin Default 0x01014010: [Jack] Line Out at Ext Rear
    Conn = 1/8, Color = Green

and ALSA mixer for ‘Line’ showing as muted and level=0

Simple mixer control 'Line',0
  Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 31
      Mono:
      Front Left: Playback 0 [0%] [-34.50dB] [off]
      Front Right: Playback 0 [0%] [-34.50dB] [off]

suggest go to alsamixer -c 1 and:

  1. to locate ‘Line’

  2. increase level

  3. M change muted state [MM] to unmuted [OO]

  4. sudo alsactl store to save level settings

1 Like

I’ll try that this evening when I get home.

I did see on the bugtracker that a new defect has been posted for it since my weekend search

https://bugzilla.kernel.org/show_bug.cgi?id=205275

There is another bugzilla report that explains more about managing dual audio codecs

https://bugzilla.kernel.org/show_bug.cgi?id=195305#c2

For making the stuff properly working, you’d need to create a UCM profile.
With the patch above and with the latest alsa-lib git version, you can create a UCM profile like:
/usr/share/alsa/ucm/HDAudio-Gigabyte-ALC1120DualCodecs/HDAudio-Gigabyte-ALC1120DualCodecs.conf

And there the PCM streams for the headphone and for the speakers can be defined, as well as the jack control to allow PulseAudio automatically switching between them. Ditto for the microphones.

I do not have any hardware that requires Use Case Manager
and would not want hardware that requires Pulseaudio