Return to Level1Techs.com

X570 Aorus Master audio issue with Linux

I’ve tried a few different kernel versions and distros but can’t find one that works with the built in audio on the board. I can get audio output to HDMI devices, or USB headsets no problem but nothing out of the line out port on the motherboard (No issue on w10 with the audio). Any ideas?

Currently running Manjaro on 5.3.6-1 kernel

does audio work any better booting from Live ISO USB ?

try bypassing playback in Pulseaudio by playing audio direct to ALSA hardware
(there is speaker-test command if can’t do it with an audio player)

suggest post information from inxi- Fxxz and alsa-info.sh --upload to Manjaro forum for assistance

If you plug something into the rear line-out, it’s correctly recognised as plugged in there, but the actual audio seems to get routed to headphones. I use pavucontrol to switch output to headphones as a workaround.

I didn’t file it as a Manjaro bug since I’ve seen it across the board of distros and kernels (4.11 was initial support I believe for the ALC1220) not sure exactly where on the stack the bug is to report to :confused:

try bypassing playback in Pulseaudio by playing audio direct to ALSA hardware
(there is speaker-test command if can’t do it with an audio player)

no luck it wouldn’t work either, though I am not experienced with that tool

aplay -L sounddevices.txt (1.6 KB)

inxi -Fxxz systeminfo.txt (3.1 KB)

alsa-info.sh

If you plug something into the rear line-out, it’s correctly recognised as plugged in there, but the actual audio seems to get routed to headphones. I use pavucontrol to switch output to headphones as a workaround.

It’s properly recognizing the port being plugged and I can select between front or rear for output and input. This did have me do some more thorough hardware testing with interesting results.

  • Rear speaker out (line out) won’t work at at all on linux (with any device)

  • Front panel out works fine (with both 2.1 speakers and headphones)

  • Rear mic in works fine

  • Front mic in works fine

  • Don’t have the setup to test the rear 5.1 or 7.1 ports

  • USB audio works

  • HDMI audio works

  • DP audio works

So for whatever reason the rear line out is just borked on the linux driver or audio stack?

I haven’t yet tested if disconnecting the front audio connector fixes the issue (Front panel connector is from a Lian Li 011-Dynamic) but since input works on both and it sees the ports I don’t think that’s going to be the solution.

I have the same issue (x570 Master) and from what I have been able to find out its an issue with the ESS Sabre DAC
Probably going to have to wait for a patch as there are no workarounds that I have been able to find that work (for me at least)

Is the an open bug for this with the ALC1220 and ESS Sabre DAC that I can bump or supply info for?

I couldn’t find anything when I searched around though the weekend. I did manage to find some discussion of it around the ALC882 along with a kernel patch from System76.

https://patchwork.kernel.org/patch/9552671/
https://patchwork.kernel.org/patch/11089187/

Maybe @wendell has some insight on a workaround or place to start for a fix

from data shown in alsa-info
rear green jack socket is mapped to line out:

  Pin Default 0x01014010: [Jack] Line Out at Ext Rear
    Conn = 1/8, Color = Green

and ALSA mixer for ‘Line’ showing as muted and level=0

Simple mixer control 'Line',0
  Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 31
      Mono:
      Front Left: Playback 0 [0%] [-34.50dB] [off]
      Front Right: Playback 0 [0%] [-34.50dB] [off]

suggest go to alsamixer -c 1 and:

  1. to locate ‘Line’

  2. increase level

  3. M change muted state [MM] to unmuted [OO]

  4. sudo alsactl store to save level settings

1 Like

I’ll try that this evening when I get home.

I did see on the bugtracker that a new defect has been posted for it since my weekend search

https://bugzilla.kernel.org/show_bug.cgi?id=205275

There is another bugzilla report that explains more about managing dual audio codecs

https://bugzilla.kernel.org/show_bug.cgi?id=195305#c2

For making the stuff properly working, you’d need to create a UCM profile.
With the patch above and with the latest alsa-lib git version, you can create a UCM profile like:
/usr/share/alsa/ucm/HDAudio-Gigabyte-ALC1120DualCodecs/HDAudio-Gigabyte-ALC1120DualCodecs.conf

And there the PCM streams for the headphone and for the speakers can be defined, as well as the jack control to allow PulseAudio automatically switching between them. Ditto for the microphones.

I do not have any hardware that requires Use Case Manager
and would not want hardware that requires Pulseaudio

Same problem here. I installed Pop OS this evening and no audio being received from the speakers but USB headset works fine.

My problem with sorround 5.1 on X570 Aorus Master on Ubuntu 18.04.3 LTS is the Front left and right speakers are muted. I fix by unmuting Headphones with alsamixer.

There’s a bunch of good information in this thread, thanks so much for all the great ideas, I’ll try them tonight. Fingers crossed!

One thing I’d like to share: The “Rear Speaker Out” apparently only works in 4+ channel mode, even in Windows.

I was confused because I couldn’t get any sound from that port until I looked at the diagram on page 22 of the manual. The diagram clearly shows that for 2-channel rear output, “Line Out” is the only way to go.

(I would include a link here, but I’m not allowed. You can find the manual on the Gigabyte website.)

I guess I should have looked at the manual before assuming. Hopefully this helps clear up some confusion as I’ve seen it mentioned elsewhere when searching for a solution to this problem.

Hello everybody,

I created a kernel-patch which completely fixes the line-out problems of the Gigabyte X570 Aorus Master by applying a workaround/quirk that repairs the DAC/mixer connection path. The patch is based on 5.6-rc2 and is proposed on LKML [see: https:// lkml .org/lkml/2020/2/23/22] in the hope that it will be included in Linux 5.6 (a little late for that) or 5.7. If you are on Linux 5.5 you can use the this [see: https:// pastebin .com/tbYXxAcy] patch.

Have a nice sunday,
Chris

EDIT: Sorry for the broken links - new users can’t create real Hyperlinks…

2 Likes

Just wanted to say thanks for making the patch, it seems to work well. I got it to work once, but ran into trouble compiling the kernel and haven’t double checked it again.

Once more into the breach!

I’ve got a fresh Manjaro install up and running with the patch and it seems to work fine with nouveau so far. I might try to narrow down the incompatibility with the closed source drivers this weekend, if I have time.

As a sidenote @gladiac , it looks like your patch has made it into kernel 5.6-rc5:

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/diff/sound/pci/hda/patch_realtek.c?id=v5.6-rc5&id2=v5.6-rc4

I had been using a USB soundcard to route around this issue for my dual boot setup. Once 5.6 comes down onto my Aorus Master system I will test the fix with a modern-ish nvidia card (1080 ti)

Thanks for the patch @gladiac!

It works great for me since I’ve upgraded to the 5.6 kernel (I’d never managed to get the audio working on line out before that, even though I’ve tried messing around with it in alsamixer and hdajackretask).

On the other hand line out stops working yet again whenever I have something plugged in to the front panel headphone jack (it seems to behave similarly as it did before the patch).

If I’m playing some audio on line out and I plug a jack in on the front panel, it detects that just fine and reroutes audio to that as I’d expect normally. However, even if I select line out manually (while the headphones are still plugged in to the front panel jack) I get no audio whatsoever. It only works if I remove the headphones from the front panel.

Digging around in the kernel source tree (checking out alc1220_fixup_clevo_p950 and stuff) didn’t really help either, as I can’t really understand what’s going on in that file (patch_realtek.c) other than those parts seems to remap audio pins or something like that. Certainly not enough to go try and to poke around with it though.

Did anybody else notice this behaviour? Any tips?

No issue since at least Linux 5.4.3.
Previous issue was like static noises when watching a video in fullscreen.

HDMI out and Line out are working OK.