WRX80 Motherboard


Can i please ask for some help with a pc i am building

i have been lurking in #hardware in libera since freenode collapsed - and those guys are wonderful but thought i was ask here for extra help

I have a WRX80 sage motherboard - here is the history of the current situation

1.) when i installed the cpu - it did not “click” with the screw being inserted - but the computer has booted to bios
2.) hard drives are not being detected - i am using an icydock with a samsung nvme 980 pro (boot order wont allow me to select it)
3.) i have swapped the graphics card and the icy dock around to test to see if this changed something - it did not (not detecting it)
4.) i removed the icy dock and installed the m.2 directly onto the motherboard - and its still not detecting it (not detecting it)
5.) i have inserted a usb stick into usb slots on motherboard - that was detected
6.) i managed to flash the bios to the latest version from 0211 to 0701 - and did all the above again - no changes
7.) i have tried turning on CSM - but when i reboot the board goes into F3 bios

i wanted to link videos to youtube and pictures but the forums wont let me

I wouldn’t rely on the boot select menu for an indication the drive was detected or not. Does it say “No NVME Drive Found” under Advanced → NVMe Controller and Drive Information in BIOS?

Hello and thank you for the reply -

the forums are restricting me to max 5 uploads per post and only 2 uploads as a guest so posts are slow

The drive is being detected by the motherboard so it’s not a hardware related problem. If Windows setup isn’t detecting the drive you’ll need to load the storage drivers. On the “Where do you want to load Windows” setup screen click “Load Drivers” at the bottom. Can can find them on the included CD or download from Asus’ website. Should be called AMD RAID RAID driver and will almost always be a small zip file if downloading.

hello - thank you for the reply - it is appreciated

when i press f8 on boot - there are no drives for boot order - but the bios is detecting the hard drives

so are you saying i should just try and install windows via usb? and that should fix it?

thank you again

the first picture shows the f8 boot order

even with the drive selected

its not detected - i would have thought the drive would have been detectable even if the OS was not installed on it

That was the case with legacy BIOS boot modes but UEFI works a bit different. If the drive doesn’t contain a valid EFI partition it won’t show up in the list for most motherboards.

I’m assuming your Samsung 980 is blank. If that’s the case then yes, move on to installing your OS :slight_smile:

my apologies for a delay in replying - its because i look after disabled and blind people - and there is one of me and 50 tasks to complete each day - do I do not always get the chance to check the forums

I tried installing a linux distro onto the computer - but the board froze and said F3 as the bios message when i had the USB stick in

i will try and install windows 10 tomorrow

while i am here - the results of the linux installation can be seen here

the process freezes - black screen

Also is there anyone that has this board - can you tell me if the bios load time takes forever? im talking at least 30 to 60 seconds

goes straight into the bios - that to me seems unusual as it should go to a black error screen saying “insert bootable drive” (or something similar)

1 Like

shameless bump - sorry

I don’t have that board, nor a threadripper platform so I can’t offer you any first hand suggestions based on experience. But anyone trying to help is going to need more details. Can you try to answer a few questions?

  • Is this new hardware?
  • What OS are you trying to install?
  • Is the live boot environment responsive and usable? Or does the system freeze prior to booting into a GUI?
  • Please explain the steps to reach the black screen.
  • If you hit ESC while on the blank screen does it display any text?
  • Is that the only linux USB you’ve tried?

Thank you for the reply.

Please find answers below.

1.) Yes, this is new hardware
2.) I tried to install Ubuntu desktop - latest version
3.) my machine is crazy - first time i put in the USB stick - it went to a black screen - now that i tried it again - it booted into ubuntu live…
4.) NA
5.) yes

i have never known a bios/motherboard to take so long to boot

is that normal for new hardware?

is there anyone watching this thread that has a wrx80 mobo

I have a WRX80 board from Lenovo and using 20.04 with no issues to speak of really so far

Not at my desk atm but when I am I’ll check the forum again and see if I can try and help in anyway


I appreciate every persons help

I managed to load windows 10 onto the computer! - so that to mean - indicates that the CPU was seated correctly - i hope

is there anyway to test that?

its sooooo odd -

1.) to me it takes so long to for the motherboard to go through the bios screen - im thinking that is because of the cpu type

or maybe im just out of date

2.) stuff has changed alot in the last 10 years - windows seems to have gone backwards - for example - drives are supposed to show up in the f8 menu but dont

and hardware has gotten slower

maybe in time -

Yes it takes about 30-60sek to Show Post Screen, the More RAM the longer First Post .

As I recall, after powering on the ASUS WRX80, the IMPI (Intelligent Platform Monitoring Interface) spends a full minute (or two?) chatting with the BMC hardware (Baseboard Management Controller). So we have at least a 60 second wait before the actual BIOS setup can begin.

PS: this delay is described on page 1-23 of the manual (see 29. BMC LED).

Thank you for the replies - yes it takes about minute or more -

this is a screenshot of my screen - why does the memory differ? shouldnt it be a full 512 physical available?

and just a note - moving from windows 7 to windows 10 is not a joyful experience

everything is so …weird to me

Can anyone here tell me if they use a icydock pcie express removable m.2 to boot too

because i can boot to the m.2 on the motherboard, but when i take it out and try to boot from pcie - the board freezes and goes into F3 bios code