Return to Level1Techs.com

Wine/DXVK/Proton gaming latency and microstutter

steam-play
#1

I’ve been playing with Wine (and later, Steam Play) gaming for a few months now, and I’ve noticed a fairly consistent problem. Even if Steam or DXVK is reporting respectable framerates, there’s a noticeable amount of microstutter and input latency. This is affecting the way I play games on Linux.

For example, on Windows I usually play Fallout 4 with free aim, instead of auto-aim (a.k.a. VATS.) But under Linux, the lag is bad enough that I usually resort to VATS.

This can be remedied somewhat by lowering graphical settings, or eliminating graphically “heavy” mods. Even though the framerate may not improve by that much, that still seems to improve the latency and reduce the amount of microstutter that I experience. But given a choice, I’d rather have greater graphical fidelity without having to sacrifice fast input.

I’m just theorizing, but I think this must be because DXVK introduces a delay when converting graphical calls from DirectX 11 to Vulkan.

Don’t get me wrong; just being able to play DX11 games on Linux seems almost miraculous. But if it’s possible, I’d like to find a way to eliminate this extra latency.

0 Likes

#2

Well the only game I currently play under Proton/DXVK is Warframe.

At the moment there isn’t much you can do about shader cache compilation stutter but this improves as you play. I had bad micro stuttering in the game with FPS of about 120 but this went away if I enable vsync. Vsync added a lot of input lag but this was a necessary evil. After updating DXVK to the newest release found here:

The micro stutters are gone and I’m running at a smooth ±120FPS with vsync off and input lag feels low. The state cache added in DXVK 0.8 is probably what fixed the micro stutters for me.

0 Likes

#3

I’m already on DXVK 0.90, and under Fallout 4 at least, the lag and microstutter is still present after >1 hour of playtime. I will try turning off vsync to see if that helps…

0 Likes

#4

Are you seeing it on any other games or just FO4? Also what GPU.

0 Likes

#5

Dude, frametime problems is the first thing I thought of when I heard of proton.

Thanks for reporting on it.

0 Likes

#6

Turn off compositing. Your DE’s compositor can cause microstutter.

2 Likes

#7

@FurryJackman Bingo. Turning off compositing made a huge difference in both microstutter and input lag.

The irony is that I chose XFCE as a DE because I thought it didn’t have compositing. But I was wrong.

0 Likes

#8

From my experience its impossible to disable the compositor in Wayland+ Gnome essentially making proton useless. Seeing as how lookingglass nests its windows within Wayland I’m wondering if it suffers of the same issues. I wonder if @Wendell can chime in and tell me whether the compositor induced mirostutter/input lag is also present in Lookingglass.

ALSO: Sorry about the necrobump but there’s no other topics about this on the internet.

0 Likes

#9

Hmm, i’m not sure if wayland suffers the same Problem at all. And even if it did, how would this make proton useless? The majority of Linux users (or at least a large part) are still running X. Basically only Gnome and KDE have switched to Wayland on non Nvidia Systems. And even then you get an XSession with all of those.

0 Likes

#10

I’m currently using Wayland + gnome. Everything is latest version on Arch. When I play games using Proton I get upwards of 120FPS on my old 290x but the input lag is VERY noticable. I get some microstutter with UE4 titles but I feel its more a dxvk/Unreal issue as games that use other engines do not suffer from this. All the same I’ve come to the conclusion that its Wayland’s fault from this thread. Unless you have another possible suggestion?

0 Likes

#11

You could easily test this. XFCE shouldn’t bring to much dependencies if Gnome is alread installed. Install it and disable compositing in the Settings. Then you’ll know.

And i don’t think it’s wayland’s fault. It a limitation of DXVK in tandem with a compositor. So, unless DXVK finds a workaround, you as the user can choose better gaming, or a nicer Desktop. Or you just install i3/openbox or any other wm that you use for gaming and let your Gnome session be for everything else.

0 Likes

#12

Yeah I’ll give her a test in a bit. I’ll report back with results. Good looking out brother :love_you_gesture:

1 Like

#13

So as it turns out gnome on X11 automatically disables the compositor for any fullscreen application. Whereas xfce was trash. So literally just switching to gnome on X11 fixed it and made everything buttery smooth.

0 Likes

#14

Muffin, the Mutter fork for Cinnamon is completely inconsistent when it comes to this. Especially for Wine games. I just switched to KDE cause there’s a compositing switch in that DE.

0 Likes