Return to Level1Techs.com

Windows Games on Steam for Linux. [Proton client Testing grounds]

Just thought I would go ahead and add my experiences.

The first game I tried out was DOOM (2016). It ran flawlessly as expected, and it’s really nice to have DOOM running with the native Steam client for Linux. The Windows Steam client running in Wine has a lot of issues which are not present when running the game this way. Very nice.

The next thing I tried was A Hat in Time. This is a game that I have gotten running in Wine before, but I was always unable to get the audio working correctly. Unfortunately running it using this method doesn’t seem to help much. The game boots up and runs OK (there is a bit of stuttering when I first load up the game but after running for a few minutes it seems to clear up), but the audio is totally hosed. None of the volume controls in the settings work, the music is way too loud, and I can barely hear the sound effects or voice acting at all. It’s a shame. (P.S. If anyone has any ideas for fixing this issue in Wine or Proton please let me know)

The next thing I tried was a visual novel called Lucy -The Eternity She Wished For-. I picked this one up a while back but still haven’t played it because reasons. A friend of mine really wants me to play it so I figured I would try to get it running so I can. Everything works OK except fullscreen mode, which seems to change the screen resolution to something that the computer cannot understand because the majority of the game window gets cut off and the only way I could close the game after enabling fullscreen mode was to kill Lucy.exe from MATE System Monitor.

And finally, I gave STEINS;GATE a shot. I tried both with and without the Committee of Zero patch and the game ran on both, but there are a few drawbacks. For one thing, the volume was way too low and I couldn’t hear anything at first. I was able to fix this by loading up pavucontrol and boosting the volume for Game.exe. Additionally, the game would pick up some of my peripherals and treat them as controllers if I didn’t have an actual controller plugged in. As a result the menus would be buggy and not really work at all if I didn’t have a controller plugged into my computer. I was able to fix this by plugging an XInput compatible controller into my computer and restarting the game (I used a MAGIC-NS adapter with a Nintendo Switch Pro controller). The controller must be connected when you start the game, but you can play with the keyboard and mouse once the game loads. Aside from that, everything appears to work, but I didn’t play through the entire game or anything (yet!).

That’s all I really had time for today but I plan to try out some other games in the near future. It’s so nice to see Valve implement an official Wine implementation, especially since getting Steam running inside Wine seems to be not only really buggy and broken, but the support seems to be getting worse and worse with each Steam update. I do wish there was a bit more flexibility, however. Having the ability to run winecfg, run an arbitrary application in the game’s wineprefix, etc, would be quite nice. Perhaps it’s something they’ll work on in the future.

3 Likes

This is probably because of the DRM

1 Like

Thanks! It’s helped. I removed the GPUPRO driver and installed clang-8. Games now starts! :slight_smile: GOODBYE WINDOWS!!!

4 Likes

Your probably right, wouldn’t be surprised if many games won’t run with proton because of this, might be worth going though a list of known games that use something like denuvo DRM and see if any of those work too.

No Mans Sky does not run? Interesting…The GOG and wine+steam version is characterized as Platinum on Lutris…

It’s a big ask, but I would really like to see some FCAT frametime graphs for this, to see the actual performance implications.

So ive been poking at proton and found a way to launch winecfg directly.

WINEPREFIX=/home/dje4321/.steam/root/steamapps/compatdata/APPID/ ~/.steam/root/steamapps/common/Proton 3.7/dist/bin/wine winecfg

Replace APPID to whatever the appid for the steam play game you are running

Screenshot_20180822_150059

4 Likes

I tried out Far Cry 3 and 4, neither of which work. It looks like Uplay is gonna stop you from playing any Ubisoft games for now. I feel it’s worth noting that Uplay (and both of these games) do work nearly perfectly in an esync patched wine. I also tried using WINEPREFIX=/media/storage/coltondrg/steam/steamapps/compatdata/298110/ winetricks corefonts to install corefonts, which fixes Uplay on wine, but it doesn’t seem to improve anything in Proton. (Note that when I installed corefonts using this method, the wine on my computer from the Arch repos was used instead of Proton, but obviously I went back to using Proton to actually attempt to run the game)

2 Likes

ubuntu 18.04 lts
ryzen 3 1200
1070 zotac mini

divinity os2- NOT working crashes on launch
rebel galaxy - working
mgsV -working
star wars shadows of the empire -working
Danger Zone -working
call of duty mw2- NOT working crash on start
assassins creed 4 black flag -NOT working no uplay error
mirror’s edge -NOT working crashes on start up “file missing” error on install
Fallout 4 -working
star wars battle front 2 2005 classic -working
GTA San Andres -working
will test more

@GeNerator this is the games i have tested so far and my list if you want

1 Like

This looks great, I will post my results when I can give them a try.

Ah, so winetricks DOES work with the dummy prefixes made from Proton.

Remember that Valve can’t include the corefonts package in Proton due to copyright issues.

2 Likes

It sounds like this may be a solution to your problem in the long term.

Edit: Here is a discussion about the issue.

Just tested another game, Cat Quest.

https://steamdb.info/app/593280/

Runs perfectly even with controller input, but also suffers from the crash on exit many Unity games exhibit.

Very close to a whitelisting candidate.

1 Like

export DXVK_HUD=fps,frametimes

Make that an environment variable and DXVK has built in frametime tools.

Or, if you prefer user_settings.py:

"DXVK_HUD": "fps,frametimes",

Installing xact just made the game crash at startup for me on wine, I haven’t tried it on Proton. Fingers crossed for that FAudio thing.

Is that really surprising? I can’t think of a good reason it wouldn’t work.

As for including corefonts, I understand that. Maybe they could have some sort of open source implementation that would replace corefonts with other fonts so it wouldn’t prevent those applications from running? Maybe they could implement some sort of winetricks support? Maybe they could have their own method of automating the download in a similar fashion to winetricks. Whatever they end up going with, I think it would be very wise to get it working somehow, because there are a lot of applications that require corefonts to run in wine. Either way I doubt my issue with Uplay is directly related to corefonts anyway. Unless somehow winetricks didn’t work, I got the same result both before and after installing corefonts, so there must be something else blocking it.

That result, by the way, was a blank Uplay window that appears to do nothing for Far Cry 3, and an invisible Uplay window (it only renders a shadow where the window should be) which I cannot interact with (clicking the mouse on the shadow just focuses the window that’s behind it) for Far Cry 4. As I said before, the game does work in wine, so perhaps I could somehow use the Steam dlls from Proton in my normal wineprefix so I wouldn’t have to have the Windows version of Steam running in order to play the game? An experiment for another day perhaps.

Metal gear soild 5 works

2 Likes

i have added to the list.

1 Like

damn dude came here to post this, just got done playing it

1 Like

lmao i just did the “metal gear scene” in afghan to see how it would handle in there online is weird but working not bugs so far plus your windows save is still there too!

1 Like