Return to Level1Techs.com

Windows Games on Steam for Linux. [Proton client Testing grounds]

Just tested Prey. It runs really well. Video recorded.
Fedora 28 and Mesa 18.2.0-rc4 drivers and Proton Beta.

I am testing Doom 2016 next.

1 Like

So …

Doom 2016 with Fedora 28 an the following drivers:
OpenGL version string: 4.5 (Compatibility Profile) Mesa 18.3.0-devel
Running with Steam Play Proton Beta.

OpenGL performance looks to be on par with the performance seen running the AMDGPU/PRO Drivers on Ubuntu 16.04LTS.

Vulkan Performance is terrible.
I see 3 FPS using the same DOOM Settings on the same test scene.
The Vulkan performance is much worse than the OpenGL performance.

You may question - why am I running Mesa 18.3.0-devel?

Because those drivers were installed along with an OS patch update…
I will try to roll back to 18.2.0-rc4 drivers next.

Bye.

I can’t seem to get mine to work on setup it keeps saying to specify the location of part 7 even though I have it pointing ot the right directory. It’ll just throw the error “The file could not be located in the installer’s folder. Please make sure that the file is in the correct folder, or specify its current location.” Did you have this happen?

Monster Hunter: World works!

Volumetrics make it a slide show and a few particle effects are broken, but if you turn those off, it’s completely playable.

2 Likes

Brilliant News.
If it is really working well on Steam Play Beta already on Linux that could get much interest right now.
The more AAA games we can get tested the better.
Any chance you could record a video of your testing and put it on Youtube so we can see it?
Obviously Steam would have to Whitelist it first.

1 Like

Failed to roll back to Mesa 18.2.0-rc4 drivers.

Asked for help/advice here: The small linux problem thread

This might be a problem with Vulkan performance on the Mesa Drivers and Vulkan though.

I note, for example, that Wolfenstein: The New Colossus only manages ~ 10 FPS, running on 18.2.0-rc4 drivers.

As a cross check I will go and install Wolfenstein: The New Colossus on Ubuntu 16.04 LTS / AMDGPU/PRO installation and see how that performs in the meantime. Doom ran great on that. It looks like the MESA Vulkan performance is very poor. It looks like something is broken. It could of course be something on my Fedora 28 installation.

I am back in Ubuntu 16.04LTS on the same PC. I am installing Wolfenstein II : The New Colossus. This will be interesting to see if this game starts running the Proton Beta and how it’s performance compares to running it on Fedora 28 with the Mesa 18.2.0-rc4 drivers and Proton Beta.

I understand these AMDGPU/PRO are meant for ROCm / Compute applications. This is an experiment. Doom runs really well on these AMDGPU/PRO drivers.

I’m sorry but need help. I’ve ctrl F’d to see if anyone has mentioned anything about doom 2016 problems on steamplay, but I don’t see anyone has started a topic about that here on level1techs.

My system:
O.s. = mint 18.3 cinnamon 64 bit with kernel 4.18.5 courtesy of Ukuu Thanks Wendell!! :smiley:
4790k cpu
16GB ram
rx580 8GB vram sapphire nitro+ vid card
acer 144hz 1440p rez ips monitor
dime a dozen sata gen 2 or 3 ssd 120GB with nothing but all updates ( except wayland) installed with Steam installed and updated and Doom 2016 successfully downloaded and installed straight from Steam store/client

I can’t get Doom 2016 to even launch.

I tried both original 3.7-3 and 3.7-4 beta versions)…and no matter how I “phrase” the vulkan coherent command +r_renderAPI_1, +r_renderAPI-1, +r_renderapi_1, +r_renderapi -1, +r_renderAPI 1, +r_renderapi 1, +r_renderapi -1, or leave it blank… - it never even launches into the opening intro dev credits.

It immediately crashes within 7 seconds. With one of two errors “FATAL ERROR: wglCreateContextAttribsARB failed” at the top in the white background part of the DOOM Console window

then below that in blue background with yellow font :

"Configured log listener print-redirect tags
Added structured log listener print-redirect
Added structured log listener mp-cloud-gobbler
2018-08-29T19:38:40.122-05:00 LOG: Process started
Added structured log listener aws-kinesis-logger
Winsock Initialized
------ Initializing File System ------
Current search path:
- C:/users/steamuser/Saved Games/id Software/DOOM/base/
- Z:/home/motoryzen/.steam/steam/steamapps/common/DOOM/base/
------ File System initialized.
------ Command Line ------
Z:\home\motoryzen.steam\steam\steamapps\common\DOOM\DOOMx64.exe +r_renderapi_1
2018-08-29T19:38:40.124-05:00 LOG: Command Line: Z:\home\motoryzen.steam\steam\steamapps\common\DOOM\DOOMx64.exe +r_renderapi_1
------ CPU Information ------
1 CPU package, 4 physical cores, 8 logical cores
4600 MHz Intel CPU with MMX & SSE & SSE2 & SSE3 & SSSE3 & SSE41 & SSE42 & AVX & HTT
32768 kB 1st level cache, 262144 kB 2nd level cache, 8388608 kB 3rd level cache
15984 MB System Memory
initializing resource container gameresources.resources
initializing resource container gameresources.patch
idLib::SetProduction( PROD_PRODUCTION )
------- Initializing renderSystem --------
PreliminaryRenderSetup
—registered window class
—registered fake window class
—registered context window class
X…WGL_EXT_swap_control_tear not found
unknown error: 0x578
FATAL ERROR: wglCreateContextAttribsARB failed
Dumped console text to C:\users\steamuser\Saved Games\id Software\DOOM\base\ErrorLog_08-29-2018__07-38-40pm.txt.

idRenderSystem::Shutdown()
Shutting down OpenGL subsystem


FATAL ERROR: wglCreateContextAttribsARB failed

*************************** "
Please help :frowning:

Hmm… I have been having a few issues of my own running Doom 2016 after some of the latest updates. So I have been scouring the Steam github for Proton (as well as contributing a to a few small solutions to issues that I have found myself) .

First of all, you might want to take a look at your video drivers to see if they are the latest. I do not have an AMD graphics card, so I cannot tell you what drivers you should be using. MESA, or perhaps the AMD open source drivers? Maybe somebody else here can help you with that.

Another common issue is the lack of vcrun2015. You can try installing this with winetricks.

sudo apt install winetricks

Then run this command:

    WINEPREFIX="path to your steamlibrary/SteamLibrary/steamapps/compatdata/379720/pfx" winetricks vcrun2015

replace “steamlibrary” with the directory to your steam library.

I would also suggest checking out this thread, this post in particular:

https://github.com/ValveSoftware/Proton/issues/217#issuecomment-417100620

Right but are you using Dualshock through Steam? Configuring the controller through SDL variables works perfectly but if I set them through Steam (which renames the input device paths on Ubuntu for wathever reason) the proton games do not honor those settings. I can’t even force off the controller off because Steam removes all the device nodes from /dev/input.

Make sure you set the CPU performance Governor to performance, because the default in 18.04 is powersave and that murders Vulkan performance.

Hey can you please share the workaround?

1 Like

https://github.com/ValveSoftware/Proton/issues/37#issuecomment-415833819 I found it here.

1 Like

Your CTRL + F skills need work.

DOOM uses opengl by default, you have to enable Vulkan in game.

Specifically:

# AMD
sudo apt install mesa-vulkan-drivers mesa-vulkan-drivers:i386

OR

# Nvidia
sudo apt install libvulkan1 libvulkan1:i386 

Please read the article in its entirety.

https://level1techs.com/article/gaming-linux-updated

So I have been stuck on Windows thanks to games, I still am due to Battlefield and Destiny and Rainbow SIx Siege. I have opened up steam, some games are working, some are not. Do i Need to enable the 3.7-4 beta of proton?

Here is what I see when I try to launch Wolfenstein II in the Ubuntu 16.04 LTS with AMDGPU/PRO. It hangs.

FYI before and after I ran that test I double checked that my Vulkan Environment is o.k. and I ran a couple of tests.

I ran via:

I compiled and ran Hologram:

I also tested that Doom still runs great. I did not generate another video because I ran out of time. I pointed to the video of that further up this thread anyhow.

I am running out of time to test this any further for a while.

I need more information/ investigation regarding rolling back my mesa drivers and how I can work with https://copr.fedorainfracloud.org/coprs/amartinz/mesa-git/ on my
Fedora 28 installation. How I can remove thise mesa drivers, and how I can get the Fedora installation back on to main Fedora 28 mesa repo. I will ask for help on the The small linux problem thread.

Sorry if my questions seem simple but I have just moved from Windows to Ubuntu full time. I am ~ o.k. working within the standard Ubuntu/Fedora distros, but using 3rd party Mesa repos or downloading, compiling, and installing driver packages from https://mesa3d.org/ is outside my previous experience in Linux.

Thanks for your understanding.

I will summarize my testing results and post them to this forum as soon as I can. I need to get back to working on my main projects.

Thanks again.
Bye.

you probably wont see any huge benefits

Wolfenstein II runs great on my system but i do have nvidia so that might be why, There does seem to be a lot of that games that don’t run on AMD but do on nvidia and also the other way around. Oh and i’m also running 18.04 not sure if that matters that much though.

1 Like

I can capture video if anyone wants to see that as well.

1 Like

@colesdav

you could use this.

1 Like