Windows 10 oddities (need help)

Now I've done the regular trouble shooting before anyone asks.

So I've had a few odd things happen with Windows so here it goes

Issue #1: CPU locked at 2.5ghz (mobile chip fyi) and I cannot edit the CPU governor via power settings E.I. maximum and minimum state options do not show up anywhere in the advance settings to change this, works on my desktop and worked with 8.1 on my laptop but is missing in 8.1

Issue #2: CPU hyper threading/turbo boost not working, again on my laptop both are enabled in the bios and working in Linux but are absent in Windows 10 which is REALLY weird, googling this will not bring the issue that I'm having due to google thinking I want to disable it in bios or something

Issue #3: right clicking the task bar application icons text and icons missing, so you know when you right click firefox or windows explorer or even steam icon on the task bar a bunch up option pop up in a context menu? well the text and icons will be missing at times and its really frustrating since I have to manually restart explorer.exe.

Windows install info, fresh install from an ISO downloaded from MS them selves.

googling doesn't seem to bring up my issues so I'm asking here, I would switch to Linux but I'm forced to use windows for classes since I require Visual Studio (not my choice either)

oh and GPU switching doesn't work with Nvidia optimus (more of an nvidia thing though) once it switches to Dedicated (NVS5200M) its stuck until I reboot.


1) Your windows 10 version (pro? home?, are you using 8.1?)
2) How do you know its not working? Not showing and not working are 2 different things.
3) not sure if i understand that one, can you make screenshots, and explain whats going on - step by step.

- put this into your folder path:
Control Panel\All Control Panel Items\Power Options

This will lead you to power options.

  • Task Manager doesn't show Threads (HT but cores only / overall)
    right click change graph to logical processors.

you can get aida64 trial version and see how many threads are available.

Did it come with your laptop or did you update?

@Streetguru I did a fresh install of 10 Pro.

2 only two cores are showing up in task manager and the performance is very sluggish, not to mention my vms can't see them and during start up I can only use a maximum of two cores (where hyperthreading on windows 7 8 and 10 on my desktop/other computers can use the hyper threaded cores) as for the CPU frequency I know its stuck since CPU-Z doesn't showing it changing 2.5ghz all the time, with windows 8.1 it would go down to 0.8ghz when idle and work at 2.5ghz when under load and show boosts up to 2.9ghz. As for power options, I have been into the control panel power options and done the advanced options, its not showing next to CPU cooling settings nor in any of the power settings (PCI-E USB etc) I've even tried using regedit to manually change it.

as for the last one, when you right click an icon on the ask bar (right next to start menu) you should get close, unpin/pin, the application name, then some options all with a tiny icon to go with them, randomly the text and icons wont show up. I can still high light where they should be, and clicking it will still get the desired result (ie clicking where close should be will close the program)

sorry if I'm not being descriptive enough, normally I would do a fresh install of Windows but right now I'm swamped with assignments and I have to work full time and my issues are so weird that even google isn't showing them

for reference my laptop is a T430s with a dual core ivy bridge i5 (which does in fact have hyper threading) and an NVS5200m GPU.

Well then just try installing 7 onto it, or run a Live Linux Distro and run some tests to see if it's the hardware, might just be an issue with older hardware and windows 10

everything is working, I would go back to linux but I 100% need visual studio for my school work. Preferably I would like to work with debian and vim but fml :(

It doesn't run in WINE? You could just do a virtual machine, or again install 7, what's wrong with 7?

Visual studio runs bad enough on windows, don't think wine would work period, as for 7 I don't have a product key and it slow to boot.

check for latest bios updates for your laptop, and latest drivers provided on the manufacturer's website.

it may not be 'ready' for win10. Complain on laptop manufacturer's forums.

1 Like

hmm I'll do that!

Do you have an SSD?

And what do you mean don't have a product key for 7, didn't you buy 10? I mean if you have a valid key for 10, you could always just head over to the place where everyone gets free software and grab a windows 7 ISO

I got 10 through my school, also I'm doing MASM assembly with low level windows intergration and relying on ASM libraries for windows, I really can't be messinga round with linux

Well just find windows 7 free somewhere

Also this just came out

1 Like

well getting my laptop drivers isn't going to happen anytime soon.....

their website shat the bed

just did a bios update, didn't do anything :/

well if it didn't happen already it won't happen at all (drivers)

you should start complaining on their support forums. This will be fastest way to resolve it.
(but be prepared that they will simply ignore you.) if that happens do it with microsoft live support.

1 Like

I think I'll try that, its only for the semester then I'm going back to Debian, Windows 10 has been too much of a pain and destroys my battery life.

Thanks for the help though

open run command and type


click boot, advanced config and select number of processors

that worked for me on 7 when i had the same issue with not all the cores loading (i tend to swap cpu's out or even motherboards+cpu without reinstalling windows)

I have already done that, since I like to use maximum amout of cores during boot for best boot times