Windows 10 1903 does not let you create a local account*

Continuing from this post since it was locked.

Came back to work this monday (small shop/workshop) after three weeks off and now apparently (saw it first hand on tuesday) on fresh installs like from a USB key, when a system gets access to the internet during the installation there is an update that changes the installation routine to mandate using or making a Microsoft Account during this clean install.

While looking around for the common “hidden opt out” all that was left was a cute little text that described how one could, graciously, move over to a Local Account only after the installation was done. After you had proceeded with an existing, or made a new Microsoft Account to be able to finish the installation…

So far the only way out is to disconnect the internet connection and back the setup routine a step or two, or better yet never allowing the machine to connect in the first place. Unfortunately, then everybody loses the chance of taking advantage of some security or compatibility update that could otherwise have been infused at an early stage.

I made some quick searches during the day but didn’t find the internet in an uproar yet, so I thought I’d share this observation. If there is some sanity left in the world they should be forced to roll back this travesty.

Oh, and this behavior was seen with 1809 and 1903 images, USB keys created over a month ago. The change is entirely coming from the online component as far as I can see.

I had a client today with brand new Surface Pro 6. She went through the initial setup and connected the surface to internet right after picking the language and keyboard language options. Then she sent me an email saying it is asking her to login to Microsoft account. I called her and told her there should an option to create offline/local account she looked everywhere but it wasn’t there. The only options was to login with MS account or create a new MS account. She turned it off and tried again same thing happend. Then I remembered this post from @mkk and told her to switch it off, walk away from the office far enough where the wifi signal does not reach and try again from there. And magically the offline account button became available. No conspiracy here just typical malicious behaviour from microsoft.

So all of you who were denying it are wrong. Now go back and unlock his thread.

1 Like


Give it a nonexistent email and fail the account login .
Then you should be able to skip the account process. They are trying their best to hide the opt out.

Tried that didn’t work.

I have not done a fresh install this month :frowning: Might be time to revisit this.

@AnotherDev showed he could set a local account twice in that same thread.

1 Like

I haven’t seen this yet despite loading Win10 a few times the past month. I wonder if MS is selectively doing this like they selectively decide whom to send out their feature updates to. Incidentally I think it’s Surface devices that have had their updates more often than not due to some serious update bugs… so maybe it’s related?

His VM probably had no access to internet. Hence he was given the option.

Either way, I am not making this up. If it was a user error I would not bother to write this up.


That’s not it either as everytime I’ve loaded it has been with Internet access and I’ve been fine.

Have you considered that the client wasn’t paying attention the first couple of times? When you click “Create a Microsoft Account” doesn’t the menu change? I don’t know because I’ve never signed in with a Microsoft Account.

Btw, still no proof just an anecdote and technologically inept client :upside_down_face:

Lmao. I had Internet connection on the bare metal. The Ethernet was plugged in. I also had network activity on the VM.

Do I have to make a video?


It’s offering to sign in with M$ account.


Installing updates because there’s Internet.

1 Like

The last one I did … I did connect to internet and the install process did gate everyting into account sign in but all you had to do was fail account login. Then the install process would move on to local only.

I will go get the latest media creator and give it a look.

1 Like

Yes I considered that several times. I was on the phone with her for 15 min trying to help her find the offline account. I don’t think she is that blind. And she found the option right away after she moved out of the wifi’s range. I doubt that was coincidence.

I was 100km away from her. How was meant to record the evidence.

Fret not, I’m making a video right now. My YouTube channel needs some click bait.

L1news talked about the local account option not popping up all the time.

1 Like

If it’s not the device itself that causes the installer change it might be literally the media. When you’re installing from a VM you just directory attach the ISO. If you’re installing from usb you’ve had to burn it…


All my installs have been in VMs, not that means anything, but perhaps we can establish a pattern?

Maybe it happens only on certain devices. I dunno.

Ya … something.

Are you on a network that filters/blocks domains?

I’m not and I’m fine installing in a VM.

No, I’m not even using pfSense anymore. Just the shitty router AT&T gives you.

1 Like

I was more going on the quote, saying people are wrong when somebody has documented proof in the referenced thread is a bit bold.

But that’s neither here nor there since it seems like folks are working on figuring out if account creation is selective or otherwise.