Return to

Why can't Intel 530 Graphics run 4K @ 60Hz?



I am having an issue where xrandr refuses to output 3840x2160 at any frequency above 30 Hz. I have gone through the process of creating a new xrandr mode (arch wiki) and adding it to the mini displayport output that services my monitor, but when I issue the command:

xrandr --output DP2 --mode 3840x2160_60.00

I am greeted by this error message:

xrandr: Configure crtc 0 failed

This mini displayport is associated with CRTCs 0 - 2, however adding the --crtc 1 or --crtc 2 parameters only results in similar error messages.

The cables are all 18 Gbps capable and tested. I don't see how this issue would be with the hardware, as I know that on Windows the Intel HD 530 is capable of this output.

Does anyone have any bright ideas as to how this xrandr issue could be fixed?


What display port type are you using?


From my motherboard manufacturer's webpage:

1 x Mini-DisplayPort, supporting a maximum resolution of [email protected] Hz
* Support for DisplayPort 1.2 version.


Since it worked fine in Windows and not Linux, it seems like a software problem. Not a hardware problem.

Edit: just saw this was said in the op already. First response threw me off. Lol.


Your hardware should be able to do 4k 60hz, so it's most likely a software issue indeed.
I just asked for the port due to not all 500 series and up chips tend to be put with outputs capable of that.


Try these settings:

xrandr --newmode "3840x2160_60" 534.010 3840 3982 4027 4064 2160 2170 2180 2190 +hsync +vsync
xrandr --addmode DP2 3840x2160_60
xrandr --output DP2 --mode 3840x2160_60


Sorry to dig this up, but it's the only solid lead I have in an issue I'm facing.

I'm using a Club3D adapter from DP 1.2 to HDMI 2.0 which can do UHD 60Hz. The context is: Intel i3-4160 (HD 4400 graphics), Samsung 65KS7000 TV, Ubuntu 16.04.

By default I only get the 30Hz video mode available. I used cvt to get mode lines for [email protected] both with reduced blanking and without, but when applied with xrandr, they both failed (also tried some 59Hz variants).

The only thing that worked and got me to [email protected] was the mode @nakamura specified.

My issue now is that I get a couple of flickering horizontal lines at the very bottom of the screen. Also, every now and then, the lower 1/8-ish of the screen seems to fall slightly out of sync. Is there a way to tweak that mode in order to get rid of those problems and still have the 60Hz?


Just in case you should update your tv firmaware, but I suspect is the driver/software.

What driver are you using ? I believe xorg auto dectect and uses the modeseting driver (xf86-video-modesetting) for intel graphics cards unless you specify the driver in /etc/X11/xorg.conf.d/20-intel.conf , have you tried both intel and modesetting ? have you tried any settings in screen flickering section of the archwiki ?


Thanks for the reply!

The TV firmware is up-to-date.

The graphics driver is Intel's (lshw -c video says driver=i915). I don't have a /etc/X11/xorg.conf.d dir. I do have a /usr/share/X11/xorg.conf.d dir, but nothing to do with the intel graphics in there.

I put those i915 parameters from your link in /etc/default/grub - no success.


Haven't used the lshw commnad so I not sure if really gives the name of the xorg driver. You can verifiy wich driver xorg is using and other thing checking the log in /var/log/Xorg.0.log but given that you don't have the /etc/X11/xorg.conf.d there is a good chance that is using the modeseting driver. Have a look at the log file.