Vfio passthrough on LGA2011 dual socket systems?

Hi guys

Recently picked up a dual socket LGA 2011 mobo (Intel s2600cp) which I used in my new build with 2x Intel 2670, 64gb reg ECC DDR3 and a GTX G1 gaming 970 from Gigabyte. Before anyone asks the motherboard has a built in graphic adaptor but I have also tried with a gt 1030.

So I’ve tried to setup PCI express passthrough using this guide (Ubuntu 17.04 -- VFIO PCIe Passthrough & Kernel Update (4.14-rc1)) aswell as some other but to no success was wondering if anyone else has any luck. I’ve been trying for about 2-3 weeks with no avail.

Any input anyone gives thank you in advance it is much appreciated :slight_smile:

1 Like

try asking here

(discord invite link to the https://www.passthroughtpo.st VFIO support community)

My guess is that it probably has something with NUMA settings, but you’ll have to be more specific about what didn’t work

Sorry didn’t know where to start to be honest

This part here is generally where it has been falling apart. Everytime it will come up with the nouveau drivers instead. (Yes I did change the binary drivers to nvidias in settings)

I’ve got work now till 6 hours from now I’ll be on my PC tomorrow to check stiff

you have to blacklist/modprobe out nouveau as early as possible

(also, ubuntu isn’t ideal in general for passthrough because of apparmor and kernel patching wackiness)


follow this instead, it’s a much more complete guide, and it’s generally pretty distro agnostic other than the differences in updating initramfs (dracut vs mkinipcio vs. whatever ubuntu uses)