Urgent help needed to recover photos on ssd

So I wanted to install eos on my SSD, but as I was making my way through the installation process, I remember I had some important files/images on there and did not back them up. Now, I did not start installing, nor did I format, however, once I exited the installation and logged back into windows, I could no longer see my SSD in "My computer".

Please tell me it is still there and there is a way to backup my files.

The image is basically where I got up to, but as I mentioned above, I did not click install. http://imgur.com/n4Fvva8

So I'm able to "try elementary os without installing", open up files and click on the SSD in the left panel, but then my laptop freezes everytime: http://imgur.com/KhQV8hh

Any solutions? :( Eagerly awaiting your advice. Thanks in advance.

Have a look at testdisk on Linux. You should be able to recover the partition and if not atleast recover the files.

My suggestion would be o try sysrescurcd. Is the SSD the 1TB drive? or the 128GB dirve? It says its already mounted.

Your best bet it to mount it on the command line and see what happens.

To do this run lsblk to list the drives, pick he ssd (lets say its /dev/sda) and run mount -t ntfs -o ro /dev/sda /mnt it will be mounted to /mnt as read only

It might be the case that it wont mount because it was mounted by windows and not unmounted properly.

testdisk as @Dexter_Kane suggests is also useful to recover partitions. and photorec (part of testdisk i think) can recover photos from drives regardless of if it can be mounted or not.

But I didn't install the linux OS - I cancelled the installation. Will I be able to run testdisk? If so, how?

I really appreciate the help Eden, but I am a complete novice when it comes to this sort of thing. I'm a photographer before anything else so what you're saying sounds very intimidating and complex to me :/

Could you break it down step by step? Can we set up a remote access session?

It's a 128GB drive.

Another avenue to consider would be to boot into elementary.
STOP whatever you are doing, and if you have the means save a bit for bit copy of the entire drive (dd) to another drive.
(This is a good step for any of the above answers too)
Launch your terminal, run fdisk -l
identify which drive is your ssd (by size usually), perhaps its /dev/sda ... are there any partitions on it? is it blank with no valid table?
I would then connect another drive of comparable size to your set up (you need a place to put all your recovered files, and you need to account for everything your going to try to recover)...
What your looking to do is called File Carving.
I like the fast file carving of Scalpel, the install is simple... connect to the internet and run 'apt-get install scalpel' in your live boot OS
then uncomment the files you want to try and recover in /etc/scalpel/scalpel.conf
finally you run the scalpel command while sitting in your newly added drive directory.
I have never run scalpel on a drive without a partition table, one may be required but I'm not certain, lemme dig for this piece of info out for you and test it while you figure out how you'd like to proceede

I tested scalpel to answer my own questions and left the evidence here: https://forum.teksyndicate.com/t/file-carving-scalpel-test-results/94081

Thats to low level @Try_Angle for @mohammedzismail's purpose.

@mohammedzismail you can use sysrescuecd http://www.sysresccd.org/Main_Page

its just a live cd/dvd like elementary OS but has a bunch of system secure tools.

It normally opens a commands line when you boot it up.

probably the best thing to do it just run test disk from that command line (the command if i remember right is litterally testdisk), from there its a curses (CLI) UI thats reasonably easy to follow, it will show you disks and partitions, you can try and repair it.

The other method is to try and manually mount the parition instead of clicking on it, elementary OS may not be giving you the error message if it has one, whereas the command line will.

To do that on the command line window run lsblk as i mentioned. This lists the disks you have in a format like this

[[email protected] a]# lsblk
NAME                                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda                                             8:0    0 111.8G  0 disk  
├─sda1                                          8:1    0   200M  0 part  /boot/efi
├─sda2                                          8:2    0   500M  0 part  /boot
└─sda3                                          8:3    0 111.1G  0 part  
  └─luks-12d7e8ec-2033-4ad9-822e-b6864701e596 253:0    0 111.1G  0 crypt 
    ├─fedora_jupiter-root                     253:1    0    50G  0 lvm   /
    ├─fedora_jupiter-swap                     253:2    0   7.6G  0 lvm   [SWAP]
    └─fedora_jupiter-home                     253:3    0  53.5G  0 lvm   /home
sdb                                             8:16   0 465.8G  0 disk  
└─sdb1                                          8:17   0 465.8G  0 part

Yours will be a little different from this.

But you can see sdb and sda are separate disks, the 111GB is my SSD.

Since its windows its likely using NTFS for its partition, they are listed with a number. If your ssd is your OS disk it will have at least two partitions, you want to mount the second one, you would do that by running

mount -t ntfs -o ro /dev/sda2 /mnt

That mounts the second partition of the first disk to the /mnt directory (you can open it in the file browser)

Let me know if thats more useful. Try testdisk first.

I'm sure it's all very useful mate, but like I said, I'm completely lost with all this info. Can we please setup a remote session for you to try these steps?

Perhaps the answer is found on this thread? https://forum.teksyndicate.com/t/urgent-installed-eos-on-ssd-with-data-on/80095
LOL... must run.

If you think that setting up teamviewer or ssh is going to be easier than running either of those two commands then go for it. Let us know once you have something set up.

Should I go into the ssd (try eos before installing) and start a room on appear.in?

Isn't that just IM?

Ah yes. (see novice -_-)

So I have to install teamviewer on eos? Is that possible if I have not yet installed the system? Remember, I cancelled the installation before it started.

If it is, is there a chance the installation will overwrite some of my files?

Yes you can install it on a live cd, but my point was that it will be easier to just try what people have suggested.

1 Like

I've looked at what they've more than once and honestly it's way over my head. I'm very new to this. I mean if we skype, I could do it myself if you walk me through what it all means - as I'm doing it.

If you get teamviewer working I'll have a go.

Ok, so i just tried to run eos via the usb and it kept crashing. Is there anything I can do in Windows?

I don't know.

Try making the USB again, it might be corrupt. Or try a different distro. I'm not sure if you can install teamviewer on systemrescuecd but that will have the tools you need to fix the disk. Otherwise try ubuntu.

And I don't FULLY understand your situation other then you need helps again. It really helps us to help you if you try some of the suggestions (for each word you don't know google it) and than tell us where you get hung up. :)

If you can still get your Live Linux boot going again...
* You can install in chrome / chromium (if its not already installed) and use the Remote Desktop App to connect to one of us
https://support.google.com/hangouts/answer/1660627?hl=en

If you get something setup let us know. We will be all ears to help you further your progression!

Not entirely related but looks pretty cool! http://guac-dev.org kinda like a web gui front end for your remote desktop managements. I can think of a lot of home rolled applications for this.

@mohammedzismail is this the second time you've overwritten the SSD or is this the same problem from may and you just haven't resolved it yet?

About the solution I suggested. Sysrescuecd has a fairly easy to follow guide on how to make an iso or usb stick of their distro, you did it for eOS, its a similar procedure, the rest are just a couple of commands, the best thing to do it give it a go.

Others may help remotely but that may or may not work on a live disk.

Your other options, if this is particularly important data it to take the drive to a data recovery specialist rather than you doing it, if your really not confident in doing it yourself. We also dont want to help remotely and accidentally destroy your data.