Unpopulated dimm slot on laptop motherboard

So, I’ve got a laptop motherboard that clearly has the pads for a second ram slot… Could I just add one and it work?

I don’t recall seeing any unpopulated surface mount stuff near the second slot, or on the opposite side.

Anyone know or ever tried adding a second slot?

I could see them trying to save some $. A nickel or quarter seems a bit crazy to try to save just to skip a dimm slot, but figure 100k boards…it could add up.

Do you mean there is a spot for the locking mechanism to be added to the motherboard, or just an unused RAM dimm slot next to the already populated one?

Missing slot. Pads but nothing soldered down. Uploaded pic and edited for clarity.

After some quick (albeit not complete research), it seems that physically it would not be impossible to add. But the BIOS for the laptop motherboard may be specifically designed for the single RAM slot that it has.

My experience with laptop motherboards is that there is little information outside of the user manual, and that will make it challenging to complete a project like this without first hand knowledge of similar projects in the past.

I will keep researching though, I am intrigued now.

… well I jacked a ram slot from another junk board and put it on there. Didn’t power on.
However after removing the slot I added I found out the flat flex ribbon from the power button had came loose from the power button daughter board. Some Flux and burnt fingers later the flat flex is reattached and the power button works, machine is fine, windows installed and awaiting drivers and updates in the AM. But I already tossed the ram slot I had transplanted and I really wasn’t in the mood to remove another ram slot today. I don’t have any quikchip and had to get creative with hot air and a razor blade to get the slot off without mangling the pins.

I’m just wondering if anyone knows if it’s a waste of time.

It’s my sister in laws laptop, well one her son is donating to her after I replace the failing drive and reload windows Only has 4gb of ram , I’ve got some 4gb ddr3 floating around to get it up to 8 but no slot to put it in and wanted to give it a go.

It’s a Celeron n2380 I think… should support dual channel, 8gb ram at least according to the Intel ark.

It’s not super important, but being able to mod cheaper boards with extra ram slots, or adding m.2 slots that are unpopulated on the board (those probably will require some extra hw by the look of things) would be a handy skill to add to my bag of tricks.

Necessity (or trying to be thrifty) is the mother of innovation and such…

Do it for science!


Seconded, no harm in learning. And we can learn from our experience also

I’m curious about the outcome as well. I can almost smell the flux, but I know that’s a little too tricky for my skills. Best of luck if you can make it happen.

if you have an oscilloscope, can you probe some of the pins to see if there’s any activity?

No scope unfortunately. That’s pretty high on my tool to-acquire list.

Alrighty… I guess imma bite the bullet.

Donor board, slots removed and cleaned up

The patient is ready. Hold on to your butts.

1 Like

I’m gunna be honest, do it for my notes. It might work.

Actually eagerly awaiting this

1 Like

Are the RAM slots intended to face out in opposite directions or one will lay over the other and a little offset?

1 Like

Pretty sure it’s supposed to be opposite facing, there isn’t room in this laptop for the shingled ram, that’s more of a Dell thing.

Well… it’s installed. It posts, but doesn’t detect the ram In the bios.

So, imma finish eating lunch, reassemble it, and look for bios updates, check cpuz and see if it happens to show up once in windows

Tl;Dr: probably not as simple as adding the slot.


The fact that it posts means youre already doing better than I would have.


Tried to touch things up, rechecked stuff with a magnifying glass, assuming i goofed something up - and now it doesn’t post at all…even after removing the freshly added ram slot :frowning:

I may poke at it next week once its had time to dry off in the event theres alcohol under some bga chip causing issues, may try to dig up a schematic/boardview to do some troubleshooting, but still, twas fun learning/trying

No biggie, I’ll be donating the SiL another newer recycled machine.

-probably final post, updating the TL;DR: yeah, probably not.


I really hope you try again the the future until you figure out how it works, we need more tinkering and self discovery of what the typical person can do with tech. Good on you for trying!


Too bad it didn’t post, that was some impressive soldering!

1 Like

Does the CPU actually support >4GB RAM? I have a Core i7 laptop from 2013, and mobile Intel parts of that era are limited to 4GB of RAM.

yep, according to Intel the Celeron N2380 supports 8GB. Either i goofed something up, there’s some bios lockout, or there’s missing components to enable the slot.
Probably a combination of the first and third IMO

1 Like

… Maybe some Dell-tier hardlock, forbidding such add-ons [outside of their facilities]?