Ubuntu14.04 screen resolution

Hi all linux noob here.

Right so graphics card= Nvidia 780 EVGA ACX Cooling

Driver = NVIDIA binary driver- version 331.38 (proprietary,tested)

Monitor= sony bravia TV hooked up through hdmi

the resolution im looking for = 1768 x992

 

In the screen monitor setting I only have 3 options none of which are even close to a suitable resolution.

Sorry if this a dumb question but any help would be appreciated, ideally given in the form of idiot proof instructions  step by step.

 

Looking forward to your help

Regards

Tony

Try checking the nvidia x config manager or whatever it's called

cheers for the reply. how do i do that?

try

sudo nvidia-xconfig

in the terminal.

Hi i made progress of what the last guy said about nvidia settings i have a "workable resolution" but still have issues 1 the bottom slightly cuts off 2 the screen moves when i hit the right edges.

after doing the sudo nvidia x config i get asked for password, but it wont allow me to type, what now?

  "after doing the sudo nvidia x config i get asked for password, but it wont allow me to type, what now?"


If by that you mean that you type on your keyboard, but no characters appear on the screen, that's normal behaviour so people won't see the length of your password (knowing that makes password cracking easier). What you type is indeed registered and it will be checked against your password as soon as you press enter.

still no joy i cant get the resolution at all does anyone know a terminal route to solve this?

 

try

 

sudo xrandr -s <x-res> x <y-res>

TTT, have you considered GPU scaling may be turned-on? Might be something to look into, if you haven't already.

 

I have not how would i do this? its really hard because i have not got my screen set up correct

Right so still no joy. But maybe a breakthrough someone can help me with.

[email protected]:~$ xrandr
Screen 0: minimum 8 x 8, current 1280 x 720, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1280x720+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1920x1080      50.0 +   60.1     60.0  
   1280x720       60.0*    59.9     50.0  
   720x576        50.0     50.1  
   720x480        59.9     60.1  
   640x480        59.9  
DP-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
  1176x922_60.00 (0x2c4)   89.5MHz
        h: width  1176 start 1248 end 1368 total 1560 skew    0 clock   57.4KHz
        v: height  922 start  925 end  935 total  957           clock   59.9Hz
  1768x922_60.00 (0x2c7)  134.5MHz
        h: width  1768 start 1872 end 2056 total 2344 skew    0 clock   57.4KHz
        v: height  922 start  925 end  935 total  957           clock   60.0Hz
[email protected]:~$ cvt 1176 922
# 1176x922 59.95 Hz (CVT) hsync: 57.37 kHz; pclk: 89.50 MHz
Modeline "1176x922_60.00"   89.50  1176 1248 1368 1560  922 925 935 957 -hsync +vsync
[email protected]:~$ xrandr --newmode "1176x922_60.00"   89.50  1176 1248 1368 1560  922 925 935 957 -hsync +vsync
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  39
  Current serial number in output stream:  39
[email protected]:~$

Basically trying to enter new mode for the HDMI TV INPUT i have actually got further than this but can't figure out what it wrong with this input atm. Come on I can do this with your help.

 

yeah mate got this.

[email protected]:~$ sudo xrandr -s <1176> x <922>
bash: syntax error near unexpected token `1176'
[email protected]:~$

cheers man any chance i could get you back in the arena on this?

Oh, sorry for not replying earlier, I have never had the need to set a custom resolution, so I cannot tell you for sure what works and what doesn't.

However, I have found a wiki page about how to change your resolution: https://wiki.archlinux.org/index.php/Xrandr , scroll down to "Adding undetected resolutions". The Arch Wiki is generally rock solid, it could work for you.

The xrandr -s command only works if the resolution is detected in the list you get by using the command xrandr. The wiki page tells you how to add a new resolution to that list so you can set it with xrandr -s. Read the page carefully.

EDIT: Out of curiosity, I tried to change the my display resolution. I did change it to your resolution, but I couldn't see a thing, my screen was full of artifacts. I followed the steps in the wiki, but this command is wrong:

  $ xrandr --addmode default 1768x992

Instead of default you need to add the current port for your monitor, in your case HDMI-0. The command should be like this:

  $ xrandr --addmode HDMI-0 1768x992

Then:

  $ xrandr -s 1768x992

Like I've said, I got a screen full of artifacts, but the resolution was changed (perhaps it isn't supported by my monitor). Maybe it works for you.

Oh, and the "$" before each command means that you type what comes afterwards on the command line, you don't actually type the "$".

Man your a legend i got the resolution accepted. BUT PROBLEM NOT SOLVED. argh. The resolution seems to look correct-ish but i noticed when i boot into windows my hdmi cable changes the tv to 1080i/50.

but in linux  720p/60.

THE problem I think lies here. any ideas for the next move?

btw the dimension of the bravia tv are:

width 57.75cm

height is 32.5 cm

Here are commands I used for forcing Ubuntu to run desired resolution and refresh rate (I've put those lines in "rc.local" as script, or copy whole "rc.local" to other location, and add to sturtup applications):

cvt 1152 864 90


xrandr --newmode "1152x864_90.00"  127.25  1152 1232 1352 1552  864 867 871 913 -hsync +vsync


xrandr --addmode VGA-0 1152x864_90.00


xrandr --output VGA-0 --mode 1152x864_90.00

 

You need to use (obviously) different values for resolution and output (instead of VGA-0, as suggested in above post).

Just use copy/paste after CVT command (see from example), everything except logon screen will run at resolution you prefer.

90 is refresh rate, when you use CVT (and other commands) last number must be your refresh rate (most likely 60).

I don't understand, what exactly is the problem? That the resolution changes in linux between restarts? leipero is right, you need to do a startup script for it to work across restarts, that's what I got from the wiki.

Or is it that you get different resolutions in linux and Windows? If that's the case, that's how operating systems work, each operating system controls the resolution of the monitor. You need to find a way to set a custom resolution in Windows.

Man i just cant get the code to take at all here is the situation.

DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1920x1080      50.0*+   60.1     60.0  
   1280x720       60.0     59.9     50.0  
   720x576        50.0     50.1  
   720x480        59.9     60.1  
   640x480        59.9  
DP-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
[email protected]:~$ cvt 1768 922 50
# 1768x922 49.86 Hz (CVT) hsync: 47.47 kHz; pclk: 109.75 MHz
Modeline "1768x922_50.00"  109.75  1768 1864 2040 2312  922 925 935 952 -hsync +vsync
[email protected]:~$ xrandr --newmode "1768x922_50.00"  109.75  1768 1864 2040 2312  922 925 935 952 -hsync +vsync
[email protected]:~$ xrandr --addmode HDMI-0 1768x922_50.00
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  39
  Current serial number in output stream:  40
[email protected]:~$

Howver i did find a downscaler button in the x config that allows me to get pretty close just by using a slide bar to scale down at 1920 1080. BUT this option doesnt exist in kali so i need an actual command option to work.

Am I doing something wrong?

Hi

am i typing it in wrong im getting this

[email protected]:~$ sudo xrandr-s 1768x922
[sudo] password for tony:
sudo: xrandr-s: command not found

 

HI mate I cnat get it to work heres the script:

[email protected]:~$ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1920x1080      50.0*+   60.1     60.0  
   1280x720       60.0     59.9     50.0  
   720x576        50.0     50.1  
   720x480        59.9     60.1  
   640x480        59.9  
DP-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
[email protected]:~$ cvt 1768 922 50
# 1768x922 49.86 Hz (CVT) hsync: 47.47 kHz; pclk: 109.75 MHz
Modeline "1768x922_50.00"  109.75  1768 1864 2040 2312  922 925 935 952 -hsync +vsync
[email protected]:~$ xrandr --newmode "1768x922_50.00"  109.75  1768 1864 2040 2312  922 925 935 952 -hsync +vsync
[email protected]:~$ xrandr --addmode HDMI-0 1768x922_50.00
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  39
  Current serial number in output stream:  40