Ubuntu MSI R9 390 Help

Hello,

I am a new ubuntu user who has installed Ubuntu on my primary system which is a gaming/workstation I have the R9 390 and I have experienced countless black screens with unresponsive lockups in 14.04 15.10 and 16.04 I have been reluctant to make a post as I was hoping for the issue to be solved but now I have no choice the system is unusable. after about 20 minutes my whole system locks up and the screen goes black. I have the Hawaii firmware on board because I cannot find the Grenada firmware I know that the cards are very similar but not the same. I also know that there are hundreds of posts like this all across the internet I just need help with my specific case. I have posted this on the Ubuntu forum and I have tried about 5-10 different solutions even reinstalling from scratch. I am at a dead end and I am asking for help

Best Regards

scott

Question 1: Have you intalled FGLRX as your GPU driver
Question 2: Why ubuntu.

You might have better luck with Suse or Netrunner Rolling.

Grenada and Hawaii aren't just similar, they are literally the same gpu. That's the reason. Also as aremis said, have you installed fglrx? And when your system locks up, can you still enter a terminal using Ctrl+Alt+F1-6?

1 Like

Here is what you can do, if your lockscreen is not responding - I have the same issue from time to time.

  1. press Ctrl+Alt+F2 to leave the frozen lockscreen
  2. log in
  3. restart the xserver
  4. log out
  5. press Ctrl+Alt+F7 to enter your new lockscreen

I'll write a guide for that and link it here.

2 Likes

I have a Gigabyte 390x and have been through EVERYTHING you have. I found all the solutions too.

Also don't use FGLRX, use the new Hybrid Vulkan driver. FGLRX is depreciated, that means its dead.

Allot of the problems you suffer are due to BROKEN power/performance state code. In particular 'auto' states are broken for the 290/390 series of cards last time I checked. My 390x is in the workshop getting fixed (for past month).

1 Like

http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Beta-Driver-for-Vulkan-Release-Notes.aspx

Its called GPU PRO driver. DKMS module so should work with all those Ubuntu versions. You don't need AMDGPU from what I am told as its a separate thing.

Important to point out also that the Open-source drivers don't support Vulkan yet, and only OGL4.2 is currently in the bleeding edge version of them (you won't find it in normal Ubuntu repos).

PS. I do have a bit of code I use to fix the powerstate issue (black-screen/crashes) if you want it. However I have not fully messed with it for running at startup (before X starts). I'm waiting for my 390x to return to me before going back to Linux (using 4870 as backup).

https://forum.teksyndicate.com/t/ubuntu-lockscreen-not-responding-to-inputs-how-to-make-it-work-again/100130

1 Like

Answer 1: when I was using 14.04 a few months ago I used the FGLRX drivers hoping for better stability than that of the AMDGPU and Radeon, but to no avail. I read on the Ubuntu forum that 15.10 has seen better improvements so I migrated my install to 15.10 to get the same results even after removing the FGLRX and doing a complete fresh install out of frustration I still had nothing that was usable. I migrated then to 16.04 Beta 2 a few days ago and for the first few power cycles I saw no issues at all everything worked perfectly there were no stability issues and I was happy, Then all of my issues returned.
Answer 2: well that is a bit of a long answer, I was first introduced to Linux a few years ago when a older man that I had known for a few years one day gave me a flash drive before he died and he told me that he was passing on to me the joy of learning that that usb had given him. I booted it up and it was a really old version of Ubuntu 10.04 on a Flash drive, I played around with it for a few weeks and as school started up I put it in a drawer and forgot about it until this past summer when I moved out and went to college. I found it again and it reminded me of that old man and how happy he was to pass it on to me so I brought it with me and thought nothing of it. I then began to explore more into what Linux was through my computer science classes and realized what an amazing gift was given to me on that flash drive, it was the gift of a constant challenge the gift of learning, the code of so many programmer before me was on that flash drive and it was a sand box to learn in. I started playing around with other distros such as arch, arch was so interesting and I quite like it. I ran into the same issues with my GPU in arch as I am now so I abandoned the distro and play to return one day as a more advanced user with more experience and wisdom, I then moved to Debian, Debian also did not support my hardware and I found it a bit clunky, but don't get me wrong I think it is a great distro, I just wanted to be closer to the bleeding edge than Debian, next up slackware, I thought slackware was interesting, but not for me at this point I needed something easier. Someone suggested Gentoo and I checked it out, but again a little more work than I was ready for. I stumbled upon linux from scratch and Completed the entire book. Granted my system never once booted, but I had learned so much from that and I also learned that as well I thought I had known the command line I still needed a good X server for the time being to get more comfortable. This is where I landed back again with Ubuntu, I am not a big fan of unity at all I prefer Xfce4 because it gives me the look and feel that I like more, but MATE is not bad as well neither is Gnome. I love the idea of linux and I want to move around in this community and find different distributions and learn how to be the best programmer I can be and give back to the community that has given me the chance to learn. I have come to Ubuntu because of it being an easy distro to get used to Linux in. I have many VM's of Suse linux and other Red Hat forks, I am just not ready for them yet.

Scott

1 Like

I am aware that the GPU chips are basically the same, The system reads them both as Hawaii, but thank you for the correction. On instillation of the fglrx drivers in both 15.10 and in 16.04 the system actually crashed and burned. Trying to use Control alt and any of the functions keys gave me no TTY socket to log on with and even if I waited a few seconds and typed pretending that I was logging in I was unable to blindly log in.

Hello,

I would greatly appreciate that :) PM me with more details?

Just as a point, please put some space in long posts like this @[email protected]

1 Like

You use this even though the 390x is not officially supported, according to the compatibility list? No major problems? Maybe I should try this.

Only got the 390x back today, and only just got home now. I asked the AMD guys over at phonorix and they claim it works for 390x fine so, will see.

here is a script I use to resolve power state issue. This method works on AMDGPU, you may find radeonsi slightly different, refer to your videocards "/sys/class/drm/card0/device/" path to ensure certain functions exist, you can open them in gedit to get a idea at what the current states are for your card.

Edit the below as you see fit! Keep in mind to STOP crashes and such on bootup you will need to execute these before X window starts up. There are a few ways to do that but I can't remember them off hand sorry.

#!/bin/bash
# The below two lines only need to be ran once.
#sudo groupadd perf-applet
#sudo usermod -G perf-applet -a <username>

# My AMDGPU Powerstate fix for 390x
sudo chown root:perf-applet /sys/class/drm/card0/device/power_dpm_state
sudo chown root:perf-applet /sys/class/drm/card0/device/power_dpm_force_performance_level
sudo chmod g+rwx /sys/class/drm/card0/device/power_dpm_state
sudo chmod g+rwx /sys/class/drm/card0/device/power_dpm_force_performance_level
echo 'high' > '/sys/class/drm/card0/device/power_dpm_force_performance_level'
echo 'performance' > '/sys/class/drm/card0/device/power_dpm_state'

#FAN CONTROLl 
#**(you don't need this unless your videocard is overheating and the default fan control sucks).**
sudo chown root:perf-applet /sys/class/drm/card0/device/hwmon/hwmon0/pwm1_enable
sudo chown root:perf-applet /sys/class/drm/card0/device/hwmon/hwmon0/pwm1
sudo chmod g+rwx /sys/class/drm/card0/device/hwmon/hwmon0/pwm1_enable
sudo chmod g+rwx /sys/class/drm/card0/device/hwmon/hwmon0/pwm1
echo 1 > /sys/class/drm/card0/device/hwmon/hwmon0/pwm1_enable
sudo echo 255 > /sys/class/drm/card0/device/hwmon/hwmon0/pwm1


echo "Powerstates changed"
1 Like

I would like to confirm again today that after having three more lock ups last night at I was unable to get the Control + Alt + Function 1-6 to open a new TTY screen in fact I was no longer even able to ssh into the desktop from my laptop.

I bought the card originally because I wanted to have better performance than what my R9 270 could give me and at a price point that I would be ok for a few years with upgrading as I am a college student. Everyone keeps telling me that the chips under the heat sink are literally the same, but if they are the same than why don't the drivers function the same? I realize the 390 uses HBM and has more of it where the 290 uses GDDR5, but what major differences could there really be?

R9 390 does not use HBM, just uses 8gb of GDDR5. Yeah, I cant answer that question about the differences between the rebrands. Like you, I have had a lot of problems with my card. Mainly to do with screen tearing.

Hah Hah, I only just now remembered that I went through this and found a way. Sorry!

I did fix the problem with the blackouts. I made the default graphics adapter the iGPU, and disabled the PCI ones. (You need a CPU with an integrated GPU). Then booted and installed Ubuntu like normal. Intel drivers are top notch compared to AMD's, so it was fine to boot, install and update everything.

I could then install the propriety AMD ones. If I recall right, I just installed them from the additional drivers utility. Easy peasy. I need to go through that whole rigmarole every time I want a fresh install.

Tearing is still an issue though, which why I still primarily use windows. I have spent a lot of time trying to fix this. I mean a LOT. Hope its not an issue with you. I try again every few months to check on the progress of AMDGPU and projects like it.

I am sorry to hear that you are suffering with this card like I am. I am using 16.04 right now the the AMD propriety are actually depreciated and are on the very of being killed off by AMD there will be a few more updated through into the summer of 2016, but after that they are going to be dropped off and no longer supported. :( I have an i5-6600 and I had flawless performance using the I-GPU, but When installing the propriety drivers in 15.10 and in 16.04 both have completely crashed the system to the point where the only option was a fresh install.

Riddick is trying the new drivers from AMD, so I might have to do the same. That's the next step I would say. Just because fglrx isn't supported doesn't mean there's no alternative I would think.

I tried that solution last night and the download failed every time I tried it I tried the direct download I sshed into my off sight server and did a wget and nothing worked I think the link is broken currently.

I just downloaded it just now and its fine. Try again.