Return to Level1Techs.com

Ubuntu 18.04 – VFIO PCIe Passthrough wont boot from physical disk (ssd) (solved)

helpdesk
pciepassthrough
ubuntu1804
#1

Hello,

I’m running Threadripper 1920x with GTX970 host GPU and 1080TI as guest GPU. OS is Ubuntu 18.04 LTS with kernel 4.19.1.

While the pass through of the GPU seems to work fine the VM always boots into the EFI shell. If i try to exit the shell and try to boot the hard drive from the boot menu it flickers and does nothing.

I was following this guide: Wendells Ubuntu 17.01 Guide
and [Elementary OS 5.0 (BETA) - VFIO PCIe passthrough guide / tutorial]

VM config of the disc:

<disk type='block' device='disk'/>

  <driver name='qemu' type='raw' cache='none' io='native'/>

  <source dev='/dev/disk/by-id/ata-Samsung_SSD_750_EVO_500GB_xxxx'/>

  <target dev='sda' bus='sata'/>

  <address type='drive' controller='0' bus='0' target='0' unit='0'/>

</disk>

I also tried this config:

  <disk type='block' device='disk'>

  <driver name='qemu' type='raw'/>

  <source dev='/dev/sdb'/> 

  <target dev='vdb' bus='sata'/>

</disk>

As far as i can tell app armor is not the problem as its not throwing any errors i think.

Any idea what i am doing wrong?

0 Likes

#2

modify the bus to ‘virtio’
<target dev='vda' bus='virtio'/>

0 Likes

#3

Well it wasnt the bus type but i figured it out. For some reason my windows was still on mbr instead of gpt (wth) and i could convert it and it works like a charm now.

Thanks.

0 Likes