Return to

The small linux problem thread



Does anyone know how to hack mdadm onto an initramfs without update-initramfs?

I’m trying to put Solus on an MD mirror… I like Solus, but the installation options are really limited.
Might go back to Fedora.


thx Mastic_Warrior! But wouldn’t that mean I will have to update symlinks each time kernel gets updated?

edit: ok, I’ve taken the plunge and did a test on my system as I concluded the chance of bricking my system is low :smiley: (well, and even if the fix should be easy).
All worked like a charm - at least on OpenSUSE I didn’t have to create symlinks (I guess they are already set up) and simply put vmlinuz and initrd in my menu entries.
My menu entry appeared and works - iommu is enabled. The only (minor) thing I’ve noticed is that in my menu localized characters (Polish) do not appear correctly (so “Wczytywanie początkowego dysku RAM…” is displayed with gibberish instead of “ą”).


Most Debian based and RPM based Distros do this when upgrading kernels, or building a kernel source using their packaging tools. So that was awesome that you did not have to do that.

In regards to Grub, I don’t think that it supports UTF encoding yet so non-ASCII characters are treated as raw bytes,


Not a problem, happy to do it. Despite my frustrations, I still prefer working on a GNU/Linux operating system.

Although, I do find one thing incredibly confusing. I’m not sure how to add an application to dmenu in i3. I’ve created aliases for the JetBrains programs I use, but I always have to run from Terminal and Super + Shift + Workspace to move the IDE over, and leave the terminal running. If possible, I’d like to be able to just Super + D and enter the alias or program name.

Anyone have experience doing this? Everything I’ve found online points to deleting the dmenu_cache, but I’m wary of doing this…


I have never tried it. This is the most that I could dig up.


My understanding was that it would search your $PATH. I never had a problem, so I would check to be sure that you’ve got a symlink (or launcher script) in your path first.

In fact, it does:


I am new to Linux and I’ve stumbled upon a script that does what I want and works perfectly, but I cannot understand what exactly all of the parameters are doing.

To be precise, I cannot understand what the “-printf %P\0” is for. I’ve read the man page of find a couple of times, but still cannot understand it.

find -name “*.txt” -type f -mtime +365 -printf %P\0

Thank you!


I was wondering if there was anything equivalent to the HWinfo GPU VRAM error reporting system in linux. looking to OC my memory, but i’d prefer to have as little errors as possible and bar VMs and stuff like that, is there anything that would come close to that?

Thanks in advance!


It may help to tell us what the script does or present a copy of the source code. Just by looking at the man page. You are going to need to learn how to use cat, |, and grep so that you can readily find information in a sea of information when dealing with documentation and output in the *nix world.

From the man page


Uhhhh, well nothing like a desktop app at least for AMD. I don’t have NVidia cards so I’m not completely sure?

For AMDGPU you have terminal commands to change clocks and it just does it. However OC’ing on AMDGPU is a bad idea because it’ll OC or UC the card for you to get the best performance out of it at any given time so setting a hard clock just makes the system perform badly.

For nvidia… I think you just have the ability to change the clocks that are programmed into the bios of the card? My one laptop has a 9800MGS and I can go between the laptop clocks and the desktop clocks and thats it. Thats just in the nv utility too. 9800’s are on 340.9something right now so it might be different for newer cards.


If would be nice to know what the script does or have a pastebin of it :3


I’m talking about VRAM OC. I want to see how far I can take VRAM without memory errors, but to do that I have to be on windows. (Which is the OS that HWinfo runs on) And if it’s one thing I know from my experiments, it’s that windows doesn’t like it when non-stock BIOSes are flashed to the GPU with mem timing adjustments.

I’m trying to learn how memory timings work and so far this doesn’t seem to be a thing that the non ivory tower (“I’m better than you”) internet knows a lot about–either that, or i’m looking in the wrong places.

I just need to figure out how to test VRAM errors in linux.


Like I said. AMD cards autoclock, nvidia cards you’d have to look in the utility.


Thanks for the reply.
This is the whole command.
find /mnt/test/ -name “*.txt” -type f -mtime +365 -printf %P\0 | rsync -avr --remove-source-files --files-from=- --from0 /mnt/test/ /mnt/aws_s3_archive/

It’s not something complicated, but I just can’t understand what exactly the “-printf %P\0” and “–from0” options are doing. I’ve read both find and rsync man pages more than once, but still cannot understand it. :slight_smile:


So what find is doing is looking in the /mnt/test directory for
1.) Any file that has .txt in the file name, (-name “*.txt”)
2.) And Is a regular file (-type f)
3.) And was modified more than 365 days ago (365 * 24 h,ours ago, -mtime +365).
Then output each match in the format of a quoted string (-printf %P) that is vertically tabbed (\0).

This is then piped (|) to rsync.

rysync then takes each individual match from find and performs the follow action on those files that match the string.
-a Archive the file,
-v output verbosely
-r do this recursively

Remove the source file after archiving to the destination (–remove-source-files) from files in the directory echoed from find ( --files-from=-, when using | to pipe from another application, the - represents that output, it is short hand) and assume we are using C strings (–from0, C strings are usually delimited by \0 to represent the end of the character array), and place the archived copy of the file to “/mnt/test/ /mnt/aws_s3_archive/”

correction to “modified more than 365 days ago” versus “modified 365 days ago.”


If you are still feeling your way around, I recommend you use this site to look at man pages.


more than 365 days.


Thanks for the correction.

I will make an edit.



Quick question: is there anything I can do to turn off some of the eye candy in Gnome - especially the Dash overlay? Reason behind is I have a Thinkpad R31 with Core2Duo T7100 CPU which seems to not be up to the job with GNOME. I am quite new to Linux, and trying to use this computer to learn while I still rely on Win for some tasks (Gaming lol);

I use Fedora 27 on it. What I tried is: used Gnome-Classic, which sort of helps, but that overlay with the dash which comes up when I go with the mouse to the top left corner still slows me down, to the point where it becomes a hassle to use the computer. I also tried to look up the Gnome manuals, but none of the config options I found are related to the “eye candy” :slight_smile:

Thanks in advance for any advice.


Not a Gnome guy. But maybe Gnome Tweak Tool might help.