Return to Level1Techs.com

The small linux problem thread

linux
helpdesk

#897

Having a minor issue with OBS on Fedora 27. (using x264 encoder)

Every time I try to record (regardless of the scene setup), OBS doesn’t record and fails with “An unspecified error occurred while recording.”

OBS CLI output:

Attempted path: share/obs/obs-studio/locale/en-US.ini
Attempted path: /usr/share/obs/obs-studio/locale/en-US.ini
Attempted path: share/obs/obs-studio/locale.ini
Attempted path: /usr/share/obs/obs-studio/locale.ini
Attempted path: share/obs/obs-studio/themes/Default.qss
Attempted path: /usr/share/obs/obs-studio/themes/Default.qss
Attempted path: share/obs/obs-studio/license/gplv2.txt
Attempted path: /usr/share/obs/obs-studio/license/gplv2.txt
info: CPU Name: AMD Ryzen 7 1700 Eight-Core Processor
info: CPU Speed: 1486.463MHz
info: Physical Cores: 8, Logical Cores: 16
info: Physical Memory: 32165MB Total, 28675MB Free
info: Kernel Version: Linux 4.14.13-300.fc27.x86_64
info: Distribution: Fedora 27
info: Portable mode: false
QMetaObject::connectSlotsByName: No matching signal for on_advAudioProps_clicked()
QMetaObject::connectSlotsByName: No matching signal for on_advAudioProps_destroyed()
info: OBS 20.1.3 (linux)
info: ---------------------------------
info: ---------------------------------
info: audio settings reset:
	samples per sec: 44100
	speakers:        2
info: ---------------------------------
info: Initializing OpenGL...
info: OpenGL version: 4.5 (Core Profile) Mesa 17.2.4
info: ---------------------------------
info: video settings reset:
	base resolution:   1920x1080
	output resolution: 1920x1080
	downscale filter:  Bicubic
	fps:               60/1
	format:            NV12
info: Audio monitoring device:
	name: Default
	id: default
info: ---------------------------------
error: os_dlopen(libnvidia-encode.so.1->libnvidia-encode.so.1): libnvidia-encode.so.1: cannot open shared object file: No such file or directory

info: ---------------------------------
info:   Loaded Modules:
info:     text-freetype2.so
info:     rtmp-services.so
info:     obs-x264.so
info:     obs-transitions.so
info:     obs-outputs.so
info:     obs-filters.so
info:     obs-ffmpeg.so
info:     linux-v4l2.so
info:     linux-pulseaudio.so
info:     linux-jack.so
info:     linux-decklink.so
info:     linux-capture.so
info:     image-source.so
info:     frontend-tools.so
info: ---------------------------------
info: ==== Startup complete ===============================================
error: Service '' not found
info: All scene data cleared
info: ------------------------------------------------
info: pulse-input: Server name: 'pulseaudio 11.1-rebootstrapped'
info: pulse-input: Audio format: s16le, 44100 Hz, 2 channels
info: pulse-input: Started recording from 'alsa_output.pci-0000_12_00.3.analog-stereo.monitor'
info: pulse-input: Server name: 'pulseaudio 11.1-rebootstrapped'
info: pulse-input: Audio format: s16le, 44100 Hz, 2 channels
info: pulse-input: Started recording from 'alsa_input.pci-0000_12_00.3.analog-stereo'
info: Switched to scene 'Scene'
info: ------------------------------------------------
info: Loaded scenes:
info: - scene 'Scene':
info: ------------------------------------------------
info: adding 23 milliseconds of audio buffering, total audio buffering is now 23 milliseconds
info: ---------------------------------
info: [x264 encoder: 'simple_h264_recording'] preset: ultrafast
info: [x264 encoder: 'simple_h264_recording'] profile: high
info: [x264 encoder: 'simple_h264_recording'] settings:
	rate_control: CRF
	bitrate:      0
	buffer size:  0
	crf:          14
	fps_num:      60
	fps_den:      1
	width:        1920
	height:       1080
	keyint:       250

info: ---------------------------------
info: [FFmpeg aac encoder: 'simple_aac_recording'] bitrate: 128, channels: 2
info: ==== Recording Start ===============================================
info: [ffmpeg muxer: 'simple_file_output'] Writing file '/home/kbrennan/Videos/obs/2018-01-18 15-47-02.ts'...
sh: : command not found
info: adding 23 milliseconds of audio buffering, total audio buffering is now 46 milliseconds
warning: [ffmpeg muxer: 'simple_file_output'] os_process_pipe_write for packet data failed
info: [ffmpeg muxer: 'simple_file_output'] Output of file '/home/kbrennan/Videos/obs/2018-01-18 15-47-02.ts' stopped
info: Output 'simple_file_output': stopping
info: Output 'simple_file_output': Total frames output: 1
info: Output 'simple_file_output': Total drawn frames: 27
info: ==== Recording Stop ================================================
[aac @ 0x5637bd3492e0] Qavg: 65536.000
[aac @ 0x5637bd3492e0] 2 frames left in the queue on closing

Anyone encounter this issue? Fresh F27 install with RX 580 GPU on an AMD 1700.


#898

are you using the nvidia encoder?
it also looks like ffmpeg is trying to run a command that does not exsist


#899

I’m not.

I do have x11-drv-nouveau installed, but the kernel driver is blacklisted because I’m passing through my 1070 to a VM.

I’ve looked into that and couldn’t find anything about it except a bug report that was closed on the OBS bugtracker saying “fixed” with not much more info. That was back during F25. :confused:


#900

For anyone using OpenSUSE with Wayland and yast isn’t launching, just enter xhost +SI:localuser:root in terminal, I tried putting it in a crontab to run at reboot, but that didn’t solve anything, I still have to enter it manually. Anyone have an idea as to how this could be automated?


#901

put it in ~/.bashrc or ~/.xinitrc is what ive done


#902

I think that your problem is the script or profile “simple_file_output” does not exist, thus the MPEG Stream cannot be written.


#903

This gives me something to go on. Thanks!


#904

???

Are you trying to tell me that yast isn’t launching under wayland on your machine?

Yast launches just fine for me.


#905

Do you not have XWayland installed?


#906

Anyone have experience with the negativo17 Nvidia driver repo for Fedora? I’m thinking about reconfiguring my system and running proprietary drivers, but I don’t know if I should be using the official .run from nvidia or the ones that are bundled into these RPMs.


#907

Yes, I do, but it still doesn’t work.


#908

Yast launches once I run the previously mentioned command.


#909

I have a fresh Fedora 27 install and I just found out Docky has been abandoned.

Any suggestions on a replacement desktop Dock that run on Fedora 27?

Thanks!


#910

https://extensions.gnome.org/extension/307/dash-to-dock/

give that a go


#911

… or Plank if you’re not using Gnome :slight_smile:

@sgtawesomesauce : it’s has been a while since I switched to OpenSUSE, but from what I remember you have to be careful with Negativo repo. It was great last time I’ve used it, but it really didn’t mix well with some of the other repositories and I had to double check not to get packages mixed up.


#912

Thanks for the heads up!

I’m going to have to give it a go.


#913

I’d like to add a custom menu entry to the grub2 launcher - nothing fancy just a menu with IOMMU enabled. I figured out I need to modify /etc/grub.d/40_custom file:

	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_gpt
	insmod ext2
	set root='hd0,gpt2'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  391753fe-f39e-414b-92dc-505c512f73ae
	else
	  search --no-floppy --fs-uuid --set=root 391753fe-f39e-414b-92dc-505c512f73ae
	fi
	echo	'Wczytywanie systemu Linux 4.4.104-39-default...'
	linuxefi /vmlinuz-4.4.104-39-default root=UUID=3d697a71-17d6-4e7f-80df-2a202bc82583 ro  resume=/dev/disk/by-uuid/0addf297-4cab-4973-8faa-d6338dc8b573 splash=silent quiet showopts intel_iommu=on
	echo	'Wczytywanie początkowego dysku RAM...'
	initrdefi /initrd-4.4.104-39-default
}

but how should I set it up so it would pick up new kernel when it gets updated?


#914

If you want it to do this for all kernels in the future, you need to edit the /etc/default/grub file. The way that you did here is the sanctioned way but only for custom entries for a known kernel + configuration.

If you are building your kernel manually or know what you are doing, the proper way to set this up is to make symlinks (ln -s) to the vmlinuz and initrd files such that they point to the current kernel to boot. The symlinks would be named vmlinuz-linux and initrd-linux.

You would then do the same for the precious or recovery kernel and name the symlinks vmlinuz-linux.old and initrd-linux.old and point them to the fall back images. That way you can change the lines

to


#915

Man, last week was a crappy week. I am happy to report that I didn’t go into rage mode, and go full Windows/OS X/FreeBSD. I stuck through my little issues and it looks like they’ve worked themselves out. The video showing the laptop issue hasn’t happened anymore, I’m using Ubuntu 18.04 with Gnome. It had happened a couple of times on Ubuntu, but Gnome/Linux/Intel must have released an update.

My desktop is working flawlessly, Debian Stretch and i3wm aka suckless tools lmao.

Things couldn’t be better. I am back to my old workflow and more productive than ever. Really glad I toughed it out and stuck with it, because Linux is life <3


#916

Thanks for coming back and mentioning that. Hopefully your dedication helps someone else who may be in the same situation.

Sometimes we have to go through a little pain before things get better.