Return to

The small linux problem thread



DP is supported but the DP Audio may be problematic until Linux Kernel 4.15. As far as MST, there is a thread about this right now. A user is using a RX 580 with the two HDMI ports and one DP connected to a 3way MST hub.

IT will all depend on the cables and the bandwidth that you are trying to pump through the DP.


It works on my HP laptop dock (I guess intel GPU) and on my (now dead) GTX 660. I’m assuming that since I just switched GPU, all is safe.

Link? My search abilities have failed me.



Thanks! Reading through it makes me think I’m in the same boat.


the BBS link worked for me; thank you!


Hello everyone!

On my main computer I’m running Linux Mint 18.2 and Windows 10 in dual boot, and while i wait for the prices of the graphics cards to go down I’m using the integrated Intel HD 630 to drive my 3 monitors (two 24" FullHd and a cheap 10€ 17"), it all worked perfectly fine, but a few days ago got an “intel-microcode” update on Linux Mint (probably to fix that spectre/meltdown mess) and since then the 17" monitor that was in portrait is not usable anymore (with Linux, on Windows10 it still works fine).
In the control panel it is recognized but when i try to activate it and set it in portrait mode as it was before i get this error:

GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._gnome_2drr_2derror_2dquark.Code2: could not set the configuration for CRTC 65

I use Linux as my main OS, and i know that when I’ll buy a dedicated graphics card the problem will go away but still this issue is a bit disturbing…


Anyone have Broadcom wifi working on Solus?

Yes, I have checked their hardware manager application and installed that. No, that did not solve my issue.

Yes, I did search for Broadcom and Broadcom-wl and install any and everything, with reboots in between. No, that did not solve my issue.

Yes, I have read the Solus forums, and the solution seems to be to purchase a WiFi adapter, lol no thanks. I’ll use the 1,000s of other distros where WiFi works perfectly out of the box or with minimal configuration.

I like Budgie and eopkg, but this prevents me from using the distro. That and no (seemingly) stable UEFI installation without some serious [email protected]

Any tips? Going to try another 15 minutes or so and throw Kubuntu back on.



SOLVED :sunglasses:

I guess a deadline was all I needed.

“The ultimate inspiration is the deadline.”


sudo echo "install wl /sbin/modprobe cfg80211; /sbin/insmod /lib/modules/\$(/bin/uname -r)/kernel/drivers/net/wireless/wl.ko" > temp.conf

 sudo mv temp.conf /etc/modprobe.d/

sudo echo "wl" > wl.conf

sudo mv wl.conf /etc/modules-load.d/

sudo reboot now

Connected to WiFi as we speak, friends.

Long live GNU/Linux + Solus + Budgie + Ikey + RMS + ESR + Praise Wendell


If you got the micro code update, ensure that you are running with the latest supported kernel and that you have updated mesa and libdrm.

Depending on your distro, you may also want to ensure that you are running the latest firmware (free or non-free).

I use Debian so the example looks like this.

apt update && apt upgrade linux-firmware linux-firmware-nonfree mesa-intel libdrm-intel


Ugh, and I’m back.


After a couple of screen locks, the behavior in the video occurs upon waking the screen. This is fairly mild compared to other distros, but I thought I’d document it nonetheless.

This happens on every distro, much less frequently on Ubuntu 18.04 and it has only happened twice so far on Solus, which is as infrequent as it has ever been.

So with Solus and Ubuntu 18.04, I’d say it happens every 20 - 50 unlocks. With Debian, Arch, Fedora, Ubuntu 16.04, this happens all the time. In Debian, it happens when I connect to WiFi and open Terminal too quickly. Have to close the laptop to get it to stop, even then it doesn’t always stop until I reboot.

I can duplicate it pretty regularly by locking the screen and waiting a few seconds. As you can see above, once I log into Solus it stops.

But, why does it happen, and why does it happen on every Linux distro I use?

Does not happen on Windows 8.1 or Windows 10, I’ve tested to verify it’s not the screen or iGPU.

Any suggestions?


Looks like it’s failing to sync the stride.

What laptop?


Dell Inspiron 3543.

It’s very random as to when it occurs, but I can definitely duplicate after doing a series of locks and unlocks.

Like I said, in Debian (sadly), this happens so often that I can’t use it on that laptop. :frowning:


Since you’ve tried many distros, it’s unlikely it’s related to a kernel version.

I’m not really knowledgeable about these sort of problems.

Inspiron 3543

No hybrid graphics, correct? If it’s hybrid, you might be in for a world of hurt. If it’s just an iGPU, it’s probably fixable.

Have you updated to the latest bios version?


Nah, just Intel HD5000 graphics.

I’ll check the BIOS.

Does NOT happen in FreeBSD either, with Gnome and GDM. Weird.


That’s odd. Seems to be a Linux (kernel) problem then.

have you tried building a 4.15 kernel?


I’ve not, I will give that a go as well.


Just so you know, these are shots in the dark. Also, if you can find any errors in wayland/xorg/dmesg, that can definitely help arrive at a solution.


I would point the finger at wayland/X. What version of X does FreeBSD have?


I’ve got a somewhat similar-ish issue with Fedora. System is a Latitude E7440. Happens very sporadically. Been a couple weeks since it happened last. Only way to get it to stop is to put the computer to sleep, and that doesn’t always stop it.

WARNING: This is very probably a seizure-inducing video.


Yup, exact same thing happens here. Distro doesn’t matter, although it is significantly worse on some than others.

Oh well :frowning_face:

I’ll put up with it for a while, but I might have to go back to running Linux in a full screen VM.