Return to

The small linux problem thread



Can anyone tell me what's being edited here?


Hi guys. I have a small problem. I try to update my Ubuntu server 16.04 machine. It does not have anything installed which is not from the default repo’s and has had a weekly or daily update/upgrade run. And yes, I did try to reboot.

sudo apt-get update && sudo apt-get upgrade

Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt-get -f install’ to correct these.
The following packages have unmet dependencies.
apt-utils : Depends: apt (= 1.2.20) but 1.2.24 is installed
E: Unmet dependencies. Try using -f.

Running apt list --upgradable

apt-transport-https/xenial-updates 1.2.24 amd64 [upgradable from: 1.2.20]
apt-utils/xenial-updates 1.2.24 amd64 [upgradable from: 1.2.20]
libgl1-mesa-dri/xenial-updates 17.0.7-0ubuntu0.16.04.1 amd64 [upgradable from: 12.0.6-0ubuntu0.16.04.1]
linux-generic/xenial-updates,xenial-security amd64 [upgradable from:]
linux-headers-generic/xenial-updates,xenial-security amd64 [upgradable from:]
linux-image-generic/xenial-updates,xenial-security amd64 [upgradable from:]
linux-libc-dev/xenial-updates,xenial-security 4.4.0-89.112 amd64 [upgradable from: 4.4.0-87.110]
mesa-vdpau-drivers/xenial-updates 17.0.7-0ubuntu0.16.04.1 amd64 [upgradable from: 12.0.6-0ubuntu0.16.04.1]
open-iscsi/xenial-updates 2.0.873+git0.3b4b4500-14ubuntu3.4 amd64 [upgradable from: 2.0.873+git0.3b4b4500-14ubuntu3.3]
unattended-upgrades/xenial-updates,xenial-updates 0.90ubuntu0.7 all [upgradable from: 0.90ubuntu0.6]

So, I have apt version 1.2.24, need apt-utils version 1.2.24, but this needs version 1.2.20 of apt to upgrade. What the ****. Is it safe to downgrade apt and see if it will upgrade apt-utils?


Runs on local machine.


sounds like an issue with scope.


This may not be a small problem, but I’d like to see if anyone knows how to do this. Or if it’s even possible.

I have a motherboard with two physical NICs. I am currently using the first one (eth0) for internet access and local LAN access (it’s a file server).

I want to use the second NIC for qbittorrent. I want to do this “safely”, meaning I want the interface to block everything in and out except for the one specific port qbittorrent uses. I also would like to use openvpn, but only on that second interface.

Ideally I would like the second NIC connected directly to the internet modem, completely bypassing my internal network and firewall. I can’t do this right now, as I don’t have an easy way to route cable to the modem. So for testing purposes (and probably temporary use if I can get this working) it is connected to my internal network.

I tried setting the second interface to a couple different firewall zones (block and drop), but I could still ping the IP address that was assigned to that interface via DHCP. The firewall GUI is weird and hard to figure out what’s what. I also set up an openvpn connection, but I couldn’t find a way to assign it to the second NIC interface.

Does what I am trying to do make sense? Is it possible without being overly complicated and difficult?


I do my torrents with openvpn via a virtual machine and it works very well. Virt-manager and qemu. The virtual machine is ubuntu with openvpn and it seems locked down.


I was actually thinking about doing this. Just need to figure out how to give the VM access to the storage array on the host so it can download files directly to the fileserver (host).


I made a made a share on the VM and pull the files off with the host myself. However making a network share on the host works fine and the vm can mount it and use it.

I used samba / smb but since my host and VM are linux it could have been NFS for more speed.


That’s a good idea with the NFS share. I already have the fileserver setup as an NFS share, so that should be easy. I like the VM idea.


You can use to see if the VM is locked down. Myself I have adblock, privacy badger and javascript turned off with a white list on the VM browser.


Not sure why you’d need a second network card (you could do this with virtual interfaces), but you could create a second network namespace containing only the VPN interface

This is roughly what I had in mind, could be simpler but the steps there will get you the rough idea.


I’m revamping my vim completely and now that i’m trying colorschemes, it doing this no matter what the theme is (if the background isnt black). Anyone has a clue as to what is happening or what line i should add to my .vimrc, i really cant seem to find anyoen running into the same problem online, maybe i’m just too retarded and not searching the right thing tho…


Hey, well… this is a pretty bad error message. Have you found a solution as of yet?

if not, look up information on dpkg. Using this, you can install and remove .deb packages. I have run into a similar issue on RedHat. Basically it involves a failure during the yum/apt-get upgrade process. When this failure occurs, you’re stuck in a dependency cycle.

Let us know if you’re still having problems.


Wow I forgot this thread existed LOL. Haven’t seen it in so long.


Hey, thanks for the reply @jebbaxley. I did (maybe) fix it. Made a thread here. I -f installed apt-utils. It did install and I haven’t had any problems yet, but I don’t know if I will run into problems down the line when the next update comes. I am still on version 1.2.24 on both.


Glad you hear some updates on your issue Zumps. You went kind of quiet in that thread, not sure if what I had said helped you.


I updated the post, but of course you commenters didn’t get a notification. Didn’t think about it at the time. I did not try to fix the package as you recommended, just forced the update instead. However when the next update comes I anticipate I might need to try your advice, thanks :slight_smile:


without seeing what you have done to your vimrc its really anyone’s guess. have you posted it on github or something? either way if you are using a Color scheme that theme may do something to the background color of the vim window, or will highlight any white spaces in your code. begin checking there.


Ended up switching from ubuntu gnome to antergos, and rxvt unicode seems to handle colors better, and i dont have the problem anymore.


Is there a sort of process to transfer a ZFS pool? My current system (Fedora 23 or 24, can’t remember) doesn’t update properly. I think I posted about it in this thread actually. I just can’t get it to work right. So I want to do a clean install.

What are the proper steps to doing this? I feel like I have imported the pool before, but I am curious since it’s encrypted now. The disk UUIDs shouldn’t change, right? So I can just make a copy of the crypttab and fstab and use them to edit the new system, right? The thing that bothers me is the keyfile that was used when encrypting the disks with LUKS. How do I generate a new one and re-add it to the disks on the new system?

It feels like there are a lot of variables that need to be worked through. Anyone done this?