The small linux problem thread

May be an extension going awry for Gnome. What extensions are you running?

2 Likes

only freon (for cpu/gpu temps)

edit: more info

it only started doing this yesterday

(also happens to the same day I changed from 34" monitor to 49" monitor)

1 Like

I saw three on extensions. Looks like it is an extension of the sensors extension with GPU information. Should not be causing your issues.

A monitor change should no cause the issue. Any system updates between two days ago and today?

1 Like

Thanks

1 Like

I updated … but that was two days ago.

kernel 5.12.6

if the update caused it… it should have happened yesterday morning when I first logged in.

1 Like

Old hardware, old bugs. If anyone else has problems with Linux on Intel Baytrail CPUs, like freezing without any error log, you must add in your /etc/default/grub config, at “GRUB_CMDLINE_LINUX_DEFAULT=” after all the text " intel_idle.max_cstate=1"

My tablet has frozen 3 or 4 times in less than 24h, since I installed Linux on it. It won’t have as efficient a power consumption, but it’s a compromise I’m willing to make. Currently testing the workaround, hope it will work. If it doesn’t, I will report back to brainstorm the issue.

1 Like

So I think I figured out some more things about what’s going on:

  1. through the Gnome applet bluetooth gets soft blocked and basically won’t come back online unless I reboot the machine
  2. Using bluez I can turn the bluetooth off and will come back online, but it interferes with the Gnome applet so as soon as I open settings it gets enabled once more.

This is as far as I’ve been able to go, also following the Arch linux wiki on possible issues. I think I need to dig deeper on the card that I’m using, the Intel 7260.

This alias usually works for all my bluetooth related stuff (put at end of .bashrc):

alias btreload="sudo rmmod btusb; \
                sudo rmmod btintel; \
                sleep 1; \
                sudo modprobe btintel; \
                sudo modprobe btusb"

YMMV, and this is tied to Intel BT chips only.

1 Like

Thanks for the answer! How does this work precisely?

The alias kills the kernel modules completely for bluetooth, sleeps 1 second to make sure changes take effect, and then re-enables them. This in turn makes all init scripts run again further down the chain. This neatly sidesteps the issues without actually solving them, so hack, but it works. :smiley:

It is a bit of brute force though, and requires btusb and btintel to be compiled as kernel modules. On Ubuntu they are, no idea about Arch.

1 Like

well i tried the graceful shut down. no change…
i cleared the .zsh_history. shut down… booted fine. no error.
typed a couple of commands.
sudo su
sudo -l
ls -la
ls -l

saved with a graceful shut down.

booted.
error zsh history corrupt. :angry:

gonna try a new image and see if it happens again.

Oh okay, it’s just an alias to reload “easly” the bluetooth service and restore bluetooth.

They should be, the Intel 7260 has support in the Linux kernel. I don’t know where to bang my head. I might switch to Ubuntu if I need to keep digging out bugs like these and have my closest repo 404 on me.

I’m trying to replicate the functionality of the timeout in a script (BSDs do not have timeout). I have it working with a sleep and kill no problem, but I’m not sure what the appropriate kill signal would be. Is this what ALRM is supposed to be used for? It’s unclear to me.

Timeout let’s you tell it what kill signal to use…

1 Like

Ah yeah I should have looked at the man page. It uses TERM by default, but I kind of like using ALRM because nothing else is going to use it and I can let it be a dedicated timeout signal.

So now I’m wondering if that is its intended purpose? Most of what I find searching for it is how to use it in C. Nothing about using it in a shell script (although it’s working fine for me so far).

It (or something) is printing Alarm clock: 14 which I assume means something…

Hey people, I have an old Asus eeeBox, and since it’s collecting dust I’m giving it to the neighbors kid to play with servers, I figure dual core Atom, 2GB RAM and 320GB HDD should be plenty.
It was a media player and had some family photos so I’d like it wiped since it may end up somewhere else when he is done with it.
DBAN won’t boot from USB on it, and I’m too lazy to deal with it today.

Do you feel this is good enough, I found it on superuser:

sudo dd if=/dev/urandom of=/dev/sda bs=1M status=progress
Is it safe enough?
  • Yes, don’t be paranoid
  • HELLS NO!
  • Just use DBAN, figure it out you lazy bum

0 voters

You could do that scrub, it will take a couple of hours but is fine otherwise.

However, I’d like to point out a 256 GB SSD is hella cheap these days (30-40 bucks), saves you a bunch of headache and time, and would give a much better out-of-box experience. Your choice though!

If you’re wiping out the installation on it, you should figure out why it won’t boot from USB. Maybe try a Fedora or Ubuntu Live on it. Otherwise it is going to be very tough for your neighbor kid to install anything on it.

Also, if you do the dd command in a GUI environment running off that same sda disk it is going to be really risky because a GUI will try to run stuff off disk, might cause a filesystem kernel BUG and crash or just crash the GUI, killing your dd command. So if you really want to do it that way I would log into a command-line only session. Even better would be to boot into a single-user rescue environment from your GRUB menu.

3 Likes

Finally came around to trying this and it seems I don’t understand this option either. I added it to my ssh config file a while ago like this:

Host github                                                                      
  Hostname github.com
  IdentityFile $HOME/.ssh/my_keyfile
  AddKeysToAgent yes
  User git
  Compression yes

Note the user is git because that’s what GitHub uses in the clone/push addresses (i.e. [email protected]:account/repo, where git is the user… right?).
So I started the ssh-agent, just like before (and it showed the Agent pid). But it doesn’t load the identity file?

[[email protected]]~% ssh-agent
SSH_AUTH_SOCK=/tmp/ssh-loCRo562VUyS/agent.242842; export SSH_AUTH_SOCK;
SSH_AGENT_PID=242843; export SSH_AGENT_PID;
echo Agent pid 242843;
[[email protected]]~% ssh-add -L
The agent has no identities.
[[email protected]]~% ssh-add -l
The agent has no identities.

Reading man ssh_config sort of makes sense but then I don’t really get the point (again):

Specifies whether keys should be automatically added to a running ssh-agent(1). If this option is set to yes and a key is loaded from a file, the key and its passphrase are added to the agent with the default lifetime, as if by ssh-add(1).

Now I’m confused whether that bold part refers to any keyfile, in which case I still need to add something manually, or to that specific keyfile, in which case I don’t get the point of AddKeysToAgent at all…

Seems I can’t read or am too stupid to understand the documentation. Or I just messed up the config…

edit:
Should also note again, in case this makes a difference, I’m not (strictly speaking) trying to SSH into the GitHub servers… I’m just using git to push stuff there. But Git uses the ssh-agent from what I know, so it should be the same?