Return to Level1Techs.com

The small linux problem thread

I was only able to manage to break my network so far.

as in, the internet / browsing stopped working? DNS is hard, but there are fixes, if that is the issue?
and the changes made to get both the systems working can be worked around

What I was thinking, is if the DNS provider the system was relying on, was one that got changed, it might require the system to also use a different port/nameserver, matching the new one switched to, but I might be barking up the wrong tree

I got them both running now:

But Nextdns isn’t interfacing with DNSMasq, so basically it’s doing nothing.

Nice one so far.
I got no more ideas to try. Maybe back to the nextdns github? not sure/

Good luck though bud

No fractional scaling option in MATE Desktop (LightDM) - only scaling options are 100% and 200%. Fractional scaling available in Gnome Wayland, but I refuse to use because OS X clone. Also, no screen autorotation in MATE.

Just got this on my Proxmox machine. This is the second time I’ve seen this in about 3-4 weeks and I have no idea what this is actually about. It looks like it might be something network related, but as far as can see the network did not drop and is working fine. I was monitoring the the Summary page and at no point did I notice or see any disconnects.

Anyone know where I should start looking or what I need to research/learn here?

Partial screenshots:

EDIT:
This the last bit of the log of the event and it seems network related…
image

EDIT (02-Dec-2021):
I ended up changing the network device for the VMs to the Realtek option and that seems to have solved the issue.

It just happened again and this time I noticed the network actually go down and come back up. Took maybe 2-3 seconds.

This proxmox journey has been such a frustrating one…

I’ve no idea how relevant this is to you…

My desktop has the Intel ethernet that uses the e1000e driver. There’s a fault with the device that causes some rare systems to have ethernet pauses. When I was investigating this I gained the impression that the systems were usually servers. I might go a month without it happening, then every half an hour for a while.

Intel has published new versions of the driver over the years, but Linux kept using an old one for a long time. To use the latest one has to download, build, and install it; the process goes quite smoothly now, and the dkms integration works well now. The improved drivers don’t fix the problem, but make it happen less often and make recovery faster.

Another measure that has helped is pinging the router every few seconds.

2 Likes

So this is a driver issue then and not a whole lot I can do about it?

Forgot to add to my post:
Intel i5-4670K
Gigabyte ga-z97-dh3

I guess I will just monitor it for now and then make another plan if it becomes more of an issue. Maybe get a different network card.

Any recommendations for an alternative network cards to use with Proxmox?

Again, I don’t know if the e1000e driver problem is related to your system.

You can go to Intel download center and build from the tarball, or use
this build from git. The git repository includes dkms integration, which was a pain to do manually. It now “just works”.

I’m still quite new to linux and it’s been quite a frustrating journey to get where I am now and I don’t want to risk messing up the setup now since we are actually using it at this point. I would rather just get a new 1Gb network card and call it a day.

Can someone please tell me where is all of kde’s theme files’ directories? They seem to be all over the place. I’m talking about global themes, color schemes, application style, plasma style, gtk style, cursor, and icons.

They are. I don’t know where the themes themselves are, but icon themes are located in /usr/share/icons. They are split because many desktop environments, file managers and other programs can make use of the same theme and icons, so you don’t have to re-download / duplicate all into each programs’ install folder. It can be confusing at times, but they are there for a reason.

After a second look, it appears like the folders gtk and qt5 are also located in /usr/share, probably for the same reason.

As well, most stuff in /usr/share is overridden by each user’s ~/.local/share. So, if user settings are used to get new icons, they’ll go in ~/.local/share/icons.

If you are changing icons, be aware of icon caches. A change might not have an effect because the old icon is coming out of a cache. My KDE uses ~/.cache/icon-cache.kcache, and I just delete it.

1 Like

I also found ~/.kde which seems to be about color-schemes. In /usr/share/ there’s also a color-schemes folder too. There’s a good deal of legacy stuffs that confuses me too.

It’s not “legacy” as it’s still part of the current model (with maybe the exception being nixOS).

~/.kde only exists now for compatibility with apps built for KDE 4, before about 2015. When KDE went to “KDE plasma” stuff got moved to .config and .local/share to conform to desktop standards.

Those standards say where icon files are meant to go, so one can try to use Gnome icon themes with KDE; in the past I’ve sort of patched together icons from various Gnome themes to work with KDE, because I strongly dislike the default KDE Breeze icons. You can go deep with hundreds of forks of the big themes, they’re like Linux distros on a smaller scale.

2 Likes

Hi guys I don’t know where to start with this one, but I have a new Alderlake system (with Nvidia gpu…) that refuses to shutdown at all. I was reading it might be todo with PCI device poweroff. Anything else I can provide?

Oooof… Since Alder Lake is a brand spanking new architecture, lots of things that could go wrong here.

First off, with any hardware newer than 6 months, you pretty much will need to run the most recent kernel (5.15.4 as of last Sunday).

Second, start by upgrading to 5.15.4, uname -a will tell you all about which kernel you are currently using.

Third, what does your dmesg say if this problem persists?

1 Like

also, after the kernel upgrade, if it still does not shutdown, run ‘shutdown -h now’ in a terminal. this might show you an error that is traceable. NOTE: depending on distro it may need to be ‘sudo shutdown -h now’