Return to Level1Techs.com

Taking The Fedora Plunge

I’m wanting to take a jump into Fedora on my streaming box. This machine is a test box where I toss on a few different distros from time to time. Mainly I’ve been running Ubuntu Studio, Mint and a couple of hacky distros.

This machine is an old i5 quad core with a gtx970.

Any gotchas I should look out for? Does Fedora just use Grub 2 or should I worry about the bootloader? Any specific version you would recommend for a general purpose version?

It uses Grub 2. it’ll use EFI if you boot the install media in EFI mode. Includes driver signing.

You’ll want Negativo’s nvidia drivers for the 970.

Start with the normal Workstation version. (Gnome) If you’re not satisfied with it, try one of the spins, but you should be able to install different DEs with DNF’s groups. @kde-desktop for KDE, for example.

1 Like

Workstation is my go to. add RPMfusion repo and have fun… I wouldnt call it a plunge personally, everything seems to just work™.

actually I take that back, sometimes the steam in rpmfusion doesnt want to work quite right but I just go get the flatpak one instead.

2 Likes

thanks for the detailed response!

this will help me out quite a bit. I do plan on using the kde spin as I’m not a gnome fan. I had read about the rpmfusion so i’ll be using that, and glad you mentioned the nvidia driver package, it sure seems better than the defaults!

Yeah, the inbuilt and rpmfusion ones basically suck. half the time the driver doesn’t install, so you fallback to nouveau on reboot, half the time it does, but the userland stuff isn’t working properly.

It’s a mess.

1 Like

I havent personally had any issues with the RPMFusion repo for the nvidia driver but I stopped using it anyway at the recommendation of you and @AdminDev in favor of the negativo repo and never had problems with that either.

10/10 would get peer pressured again.

So I’ve gotten the install running pretty well. Thanks for all your help on this. I have some personal issues that have slowed down my progress for a few days, so starting to get back on track.

I am finding a weird quirk with OBS (open broadcaster studio)

I cannot seem to get NVENC to work in OBS.
it’s very odd as the drivers are installed, NVENC tests come back positive etc.

Could this be a weird bug with the new version?
Should I have foregone KDE and done Gnome?

My googlefu has failed me so any suggestions would be welcome!

Does OBS even work at all with wayland? or did you log in with X.

My brain says yes, but I also remember there being issues.

1 Like

The issue isn’t with the display. So everyone understands this issue: in some wayland sessions, the OBS screen will be rendered weird or will show up as see through. This issue isn’t occurring for me, it generally happens on very old nvidia cards.

the issue I am seeing is with the codec not showing up for compression. It only shows H264 and FFMPEG but no NVENC.

I did verify that FFMPEG does have the correct NVENC libraries, that CUDA is on the machine etc. Some of my research pointed to two different libraries with similar names, but I didn’t want to muddy the waters with red herrings, so I’ve left that out for now as that info was from 4 years ago.

So, when I was on Fedora, NVENC never worked for me. I didn’t much care, since I have the HP to get it done on the CPU, with better results. I wonder if it has to do with how obs was built? I’m just taking shots in the dark though.

1 Like

Thanks for that info, sgt.

I did install the negativo drivers and those worked amazingly in setting up nvidia, so I can tell everything went well there. I might give up on fedora and just install arch because with that I know every piece that’s installed. I’m thinking there may be some weird library missing or some such and it might be worth figuring out before I just give it up.

I am not ruling out Wayland as a possibility, it’s entirely possible there is some component Wayland installs that could potentially break the nvidia cuda somehow, it just seems unlikely. I never use Wayland and usually just go with X, but fedora uses it so . . . just figured I’d try it.

where did you get OBS from? RPMfusion repo?

I believe it was installed through the default repos. It is up to date and matches the version I have on my Arch box 24.03.

For shits and giggles you could try the flathub one. Its a shot in the dark though. I never tried OBS in linux so I’m ill equipped to help.

https://flathub.org/apps/details/com.obsproject.Studio

it’s worth a shot, I’ll test tonight and report back.

If this fails I might just build a custom streaming distro based off arch and post it for the masses. I was really hoping fedora would kick ass out of the box.

1 Like

puts on defensive armoring
adjusts hockey mask
clears throat

Just install Windows. :troll:

(No one should take this post seriously… Its low hanging fruit for every time I saw someone suggest linux in a windows problem thread)

this is a valid suggestion, eespecially considering the prevalence of SLOBs in the space.

I want to stream 100% on linux as a personal goal and find work arounds for the most common problems so that is why I’m doing this. Another reason is if I can find a decent easy to use distro that works out of the box, it’s much easier to recommend that to a fellow Linux user than say ‘download my custom distro, install it and hope it doesn’t break when you run pacman -Syu’

Are you on fedora 30 or 31?

31 baby! Whooooooo!

(please read in Rick Flair’s voice)

1 Like