Return to Level1Techs.com

[SOLVED]Ryzen build RAM not stable at 3200MHz


#1

I recently put together a ryzen 2700 build on the ASUS ROG Strix B450-f mobo. I cannot get my RAM to run at rated 3200Hz speed. My RAM is on the supported RAM list for my MOBO for the rated 3200 speed.

Does anyone have any suggestions on how to get the RAM to run at full speed?

UPDATE:
Solution turned out to be that RAM slots A2 & B2 as primary not A1 & B1. So I put the RAM in the Primary slots and boom full speed.

The RAM I have:


#2

Just going to throw out a dumb fix that Fixed my recent RAM install with similar issues.

Try re-seating it.


#3

Also check your ddr4 voltage and you may have to set it manually along with manually set ddr4 speed in bios.


#4

I tried manually entering speed, voltage, and timings but it won’t boot with numbers that are on the box.


#5

You can always contact the manufacture of the mobo and the ram and see if they have any advice

Had a similar issue with X99 and ram on the QVL was never able to get it working, so i always take QVL with a grain of salt


#6

SOC voltage?


#7

1.550


#8

Have you tried running the ram at 1.35- 1.4v?
Also someone correct me but I swear on my MSI B350 board my SOC voltage option is 1.05 volts. But this one shows that as the SB ?


#9

I have the RAM set to 1.35, that’s what the box for the RAM said.


#10

Well try 1.37 up to 1.4 and see how she does.
Why is the left not showing 1.35v for it. On MSI board when I change the setting and reboot into bios the left value reflects what I put in.


#11

No luck, tried 1.37 then 1.4 and it power cycled 3 times then reset the RAM speed.


#12

Hmmm man I am stumped


#13

Memtest?


#14

That looks wrong. If that is correct your chip might be toast already. SOC should be 1.1 to 1.2V or so.


#15

ASUS seems to have this notorious reputation of not overclocking M-Die memory that well on their Xx70/Bx50 motherboards. My ROG STRIX B350-F wouldn’t go past 3066 when it came to my Ripjaws V modules. I changed boards recently due to downsizing my build, and threw them into an AB350 Gaming-ITX/ac. I was astonished to find that they work just fine in that motherboard.

Capture1 Capture3 Capture2


#16

Your UEFI is updated to the latest?


#17

yes, updated it as soon as I got it.


#18

I checked the SOC voltage using HWinfo. It is actually at 1.087 - 1.094
SOC


#19

I am not sure which setting to use in your bios since your soc shows 1.55 but reads out as 1.094, but if you can figure that out maybe bump it up in .125 increments and just do not go past 1.2v and see if that gets you where you need to be.


#20

What @sanfordvdev said but I would straight up overrule that stupid auto setting and nail it to 1.1V as a base.